7 7

About This Club

Running Armbian on all kinds of ARM based TV boxes. Select a topic clicking on a tab above. If you are new to Armbian for TV boxes you should start by reading the FAQ entry "Status of Armbian on TV boxes - Please read first": https://forum.armbian.com/topic/16976-status-of-armbian-on-tv-boxes-please-read-first
  1. What's new in this club
  2. That sounds reasonable, thanks. I am just not sure how to do that. Could you please point me a little? I guess uboot is not stored as a file (there is only a few files in Libreelec) but a part of some partition that I need to write from one image to another. Right?
  3. @Wizzard In searching through this thread and the forums, I can't see anyone reporting to have tried installing on your model. Since no one has responded to your post, it is unlikely anyone around here has your model of box and therefore unlikely to be able to help you out. There are hundreds of different TV box models each with different components which makes support for the vast majority nearly impossible. There is likely information in this thread that could help you, but unfortunately you are likely on your own to sort through it and try out potential solutions to get your box working.
  4. Hi, I tried almost all the images but it seems like it does not boot at all. Changed DTB config to Rockbox. SD card is not faulty, cause I was able to boot Libreelec from the same card. What is wrong? Help, please.
  5. Use the USB 3.0 port...probably with the toothpick ....now if you are going to get a steady working environment or not is another story.....
  6. Here it is! It's still weird you have building issues with Focal too, in a step (write uboot) that is mostly just bash scripting...
  7. Just got the same error "ERROR in function write_uboot [ image-helpers.sh:103 ]" Any suggestions?! Attaching the log here. So, @jock, if you try to troubleshoot and generate this image successfully, can you post it for me? A rk322x-box minimal server Focal legacy... It's just I'm trying since Sunday and nada. It'd REALLY help me... I'd appreciate it. But it's OK if you can't. I will try to ask around. Thanks again! output.log
  8. Hmmm... yes, it is indeed contradictory... The "native" building should be referred to building armbian on the board itself, but there is an "x64" there which adds more contradiction confusion. By the way, I'm using Focal to build Focal, Buster and Bullseye images and it works fine. Historically the supported distribution for x86-64 building was the latest Ubuntu LTS. There is only a bug in the build system that I don't know if it has been fixed yet, but you may need to install some packages manually (like libfdt), but then it should go on without any more issues
  9. Well, that's odd and unfortunate. If you have a USB male-to-male cable try to connect it to the USB OTG port (without connecting the power cable, just the USB cable) and see if your computer shows the device in maskrom mode. As usual, the serial adapter is useful for debug. It is very odd, because an empty eMMC will always trigger the sdcard boot, so I wonder what really happened when you did the flash erase...
  10. HI @jock! I will try that, but I'd like to mention the following from https://github.com/armbian/build#what-do-you-need-to-get-started "Ubuntu Hirsute 21.04 x64 for native building" + "If building for LTS releases.. ex: Focal, Bionic, Buster, it is possible to use Ubuntu 20.04 Focal, but it is not supported" So that's a bit contradictory, no? I thought the Readme.md on github was more up-to-date, so I followed it. But I will try focal now. Thanks for the help!
  11. Thank you for your time jock, I tried the method you've described, but unfortunately the box doesn't boot yet., what a bummer
  12. Hi @gnusmag45, I'm sorry you are having issues with your board. I hope the multitool still boots after you erased the flash Unfortunately your board has an eMCP, which is a chip that contains both the eMMC and the DDR memory. I never had the chance to test a board with such chip by myself, so it is totally guesswork. The multitool has a dtb which is usually very compatible because it does not use any "advanced" features of the board, and also uses lower operating frequencies to maximize compatibility at the expense of performance. Something does not work for your board althou
  13. Hello @ArkhanLK, be aware of this: so everything else is a moving target. The tools may work differently on other distributions, with subtle bugs or even build failures, so it is preferable to support a single distro and support it well. Personally, I have my 100Gb Ubuntu Focal 20.04 Server virtual machine to do such jobs.
  14. @gnusmag45 don't panic those boards are unbrickables if no phisycal damage occurs. Let's wait @jock
  15. After 20 tries i finally managed to select the Erase option from the Multitool and it actually let me select the eMMC partition, but afterwards i restarted the box and now it doesn't boot anymore :/ wth
  16. @gnusmag45 don't worry about english , me too I'n mot native. Ok let' s see what @jock suggests about this emmc related problem And PEOPLE don't forget to put a simple like ( the heart icom ) to help good reputation of people here.
  17. Thanks, I've opened the box and looked at the memory chip and googling it shows it is eMMC (Micron Part number 4QA98 JWA60). I read everything multiple times, and the instructions for NAND say to first use the Erase option in Multitool, but this option doesn't work for me either (even if we assume mine has NAND), so im not sure how to progress from here. * I apologize in advance if i overlooked or missed understand any of the instructions as English is not my native language
  18. @gnusmag45 read again the 3ad , all infos, you will see that some boards came with NAND and not EMMC and I guess this is your case. You should follow the STEP-NAND instructions instead and see if this fits to you
  19. Your question is off topic for these forums as we deal with running armbian on SBCs and TV Boxes. Not with apks and android.
  20. Hi, I am sorry if it was already answered, but I've searched the forums and couldn't find an answer. I'm trying to burn Armbian for the first time, but i cant flash it for some reason. My device is MXQ 4k Pro 5G (RK3228A, eMMC). I've burned the image of Multitool on an SD card, then i placed the image of Armbian in the "images" folder, and then i placed the SD card in my box and connected it to the electricity. Multitool loaded fine, and i can see the main blue menu with options such as backup/restore/erase/etc When choosing the "Burn image to fl
  21. Hi, Im trying to burn Armbian for the first time, but i cant flash it for some reason. I've burned the image of Multitool on an SD card, then i placed the image of Armbian in the "images" folder, and then i placed the SD card in my box and connected it to the electricity. Multitool loaded fine, and i can see the main blue menu with options such as backup/restore/erase/etc My box has eMMC memory (according to specs), but when choosing the "Burn image to flash" in Multitool, i get a message saying "There are no eMMC devices suitable for image burn". I actually
  22. The android tv box(Jio STB) is completely locked down. It can run apps only that the manufacturer has included and through their store. adb is disabled. There is almost no way to sideload apps. I have tried to use UART with usb to ttl converter to gain access to root and below is the screen that I have got. I just want to just sideload apk files in it. Anyone please help. output on putty after turning on the stb : - https://drive.google.com/file/d/1viB7AEZr_634XNDCq6A7cdoEbi90Q_lI/view?usp=sharing
  23. Hello again @jock! Sorry to bother you, but I think I need your help. I am now trying to compile a Legacy image of Focal from a Hirsute installation. I followed the steps on https://docs.armbian.com/Developer-Guide_Build-Preparation/ and also on the readme.md after cloning it from github. Yet, I am hitting a wall: Displaying message: Writing U-boot bootloader /dev/loop7 info Displaying message: ERROR in function write_uboot image-helpers.sh:103 err Displaying message: U-boot bootloader failed to install @host err Displaying message: Process terminated info Displayi
  24. Was anybody successfull installing Armbian to Rockbox (Rock64 chipset)?