18 18

About This Club

Dedicated section for talk & support for the Helios4 and Helios64 open source NAS. Lead and moderated by the Kobol Team.
  1. What's new in this club
  2. had to install kernel headers and reinstall zfs and then it worked! thanks! let's see how it goes now...
  3. dmitri don first of all thanks so much sharing the third command this fixed my ZFS in OMV5!! I installed omv https://www.youtube.com/watch?v=M_oxzpvMPTE and also the extras as per the video above. https://wiki.omv-extras.org/ commands: wget -O - https://github.com/OpenMediaVault-Plugin-Developers/packages/raw/master/install | bash nano /etc/apt/sources.list #add these lines to your file. #---------------------------------------------------------------------------------------------------- deb http://deb.debian.org/debian bu
  4. @hartraft Yeah you could try to update the uboot on the microSD card using your spare linux computer.(Note: This can mess up your sdcard if you do it wrongly) You will need again to mount the microSD. cd <sdcard-mount>/usr/lib/linux-u-boot-current-helios64* dd if=idbloader.bin of=<sd-card device> seek=64 conv=notrunc dd if=uboot.img of=<sd-card device> seek=16384 conv=notrunc dd if=trust.bin of=<sd-card device> seek=24576 conv=notrunc where <sd-card device> is something like /dev/mmcblk1
  5. Did you follow https://wiki.kobol.io/helios64/software/zfs/install-zfs/ and also installed zfs-dkms ?
  6. Hello, Followed instructions and installed zfs, rebooted, installed all updated via apt update and apt upgrade, rebooted and situation is like this: root@helios64:~# zpool status The ZFS modules are not loaded. Try running '/sbin/modprobe zfs' as root to load them. root@helios64:~# modprobe zfs modprobe: FATAL: Module zfs not found in directory /lib/modules/5.10.21-rockchip64 root@helios64:~# apt install zfsutils-linux Reading package lists... Done Building dependency tree Reading state information... Done zfsutils-linux is already the
  7. @gprovost I took a quick look at your previous reply in the thread. It looks like I have the Rockchip blob (line "DDR Version 1.24 20191016") since I haven't updated since 2020.07 LK 5.9.X and initially my LK 5.10.X upgrades had issues. Is there a way to update the UBoot without losing the rest of the system? Perhaps that was my issue and since I didn't reboot in a while, I avoided that scenario...? Modified the armbianEnv.txt on a spare Linux machine. Output below:
  8. Just a heads up that I reinstalled my Helios 64 with the latest armbian buster (currently running from SD) and it has been running solid as a rock for 7 days. No longer using OMV and I don't really miss it
  9. @hartraft Could you modify /boot/armbianEnv.txt and add/modify following lines: verbosity=7 console=serial extraargs=earlyprintk ignore_loglevel If you are booting from eMMC, you will need to first boot from a fresh image on microSD, then mount the eMMC to modify /boot/armbianEnv.txt
  10. Okay... So I had to jinx it... After 100 days of uptime, I had to do some electricity work in the house. Either the Helios64 shut-down after the UPS was spent or it rebooted / shut-down. Now I can't boot the thing back up anymore. Connected through picocom and it doesn't get past "Starting kernel". Tried without any disks attached, same thing. Similar to another thread, the LAN LEDs don't light up (obviously). Any ideas?
  11. Mine is running just fine for months now. Just upgraded it (kernel 5.9... to 5.10..) and it's still running fine. openmediavault 5.6.5-1 Mirror Raid with XFS and 2 disks NFS, SMB Shares Welcome to Armbian 21.02.3 Buster with Linux 5.10.21-rockchip64
  12. I am having the issue that after some time running (like a day). Rebooting results in crashing during kernel loading. Than I have to hardreset the system and it boots. If I reboot right away again, no issue. I used to have quite a few stability issues, which are now all solved with the voltage fix applied. Running stock frequencies with on-demand. Anyone having any ideas? I hope the Kobol team is enjoying some time off though I still see you around. Keep recharging, you really deserve it.
  13. Maybe check if on Infuse app has some settings to tweak the caching. Did you check on Helios64 if something is happening while streaming those MP4 file ? (use dmesg -w to see if anything wrong happen). You could also try with the 1GbE (eth0) interface this way you can narrow down the issue.
  14. for 1) I would not call it a debian issue. It is more like a general Linux issue and has been addressed in the way there is /dev/disk/by-{id,partuuid,path,uuid} to reliably address the disks. for 3) the 10s is if I'd guess, to spin up the disks. Quick research shows me hdparm should be helpful. Never use that myself though. if your board is running stable in stock settings, then all cores will go to the lowest clock possible. Overall consumption in idle will be dominated by the spinning disks if they are running. Also check the wiki on consumption: https://wiki.
  15. Dear all, I am highly interested in the Helios64 and registered for the next batch. Here are a few questions, I hope that your guys can answer. The OS is Embedded Debian I assume. Questions are quite simple: 1) Hard drive numbering on startup Under Debian, the hard drives in a RAID array are renumbered on each startup by random: /dev/sda, /dev/sdb, etc ... This means that if drive /dev/sdb fails ... it is not necessarily the second hard drive in the bay. I already lost a RAID server extracting the wrong disc in an array. Then
  16. Hi folks I'm running a fresh install of the Debian branch with 5.X Kernel branch. I got 2 new 4TB HD setup with MDAM in RAID 1 mode to store my photo and documents with Syncloud also running on the HELIOS64. I Got also a 2,5 Sata drive mount and share via Samba to my home network. My Helios64 is plugged via the 2,5GB Ethernet port directly to my Router on the 2,5GB port. I didn't fix the hardware bug, but if I understood it's not necessary in my case ( 2,5GB Ethernet on a 2,5GB Ethernet Router) My problem is that on the same router I got an Apple TV (on e
  17. Wanted to extend another gesture of support for taking a break. Hopefully the market will be more flexible to enable you guys to push a new product in the coming months.
  18. current rating != startup current. elementary electronics knowledge
  19. As i said in the original post, I tried 2 hard drives, the first one being rated for 700mA.
  20. On the link @Igor sent, the spike is almost 2s long. My power meter has a 0.1s resolution so I don't know why it couldn't catch it… anyways I could plug my oscilloscope on the power meter to have a better resolution.
  21. That's not a Linux issue here, but a hardware issue. The hard drives run fine with armbian on a rpi3b+
  22. Hello, well deserved break. (In comparison, the helios4 is not that great. The plastic breaks easily and the disposition of the elements is not practical) A great job. Have a good break!!
  23. Great! Thanks @SvenHz for sharing your experience! Yes, it's very likely the issue I mentioned above with binutils, for the Debian Buster image I am actually sure as the stable repositories still have version 2.31 which is too old. The simple solution here is to use the packages from the Debian testing repository. This can be simply done by adding two files: /etc/apt/sources.list.d/testing.list: deb http://httpredir.debian.org/debian testing main #deb-src http://httpredir.debian.org/debian testing main /etc/apt/preferences.d/10_
  24. Oups sorry. Stupid am I ! The SATA connector has been mounted upside down !! It works wonderfully now ! Sorry.
  25. Hello, we have a strange thing here. Since ... (I don't remember), the tray number 2 is not working. We tried with 3 different disks but each of them, when inserted in tray n2, aren't start. Why ? And how to fix that ? Thank you. PS: other trays (n1, n3, n4, n5) are ok.