Jump to content


Photo

OrangePi as iTunes server with forked-daapd


38 replies to this topic

#31 zador.blood.stained

zador.blood.stained

    Advanced Member

  • Moderators
  • 1609 posts

Posted Yesterday, 11:34

You need to create ctl.!default block in asoundrc too, since the log tells that it fails to open the mixer controls.

Also I may be wrong about referencing the card in forked-daapd, you should check its manuals too.


Spoiler

#32 dony71

dony71

    Advanced Member

  • Senior Members
  • PipPipPip
  • 66 posts

Posted Yesterday, 11:40

You need to create ctl.!default block in asoundrc too, since the log tells that it fails to open the mixer controls.

Also I may be wrong about referencing the card in forked-daapd, you should check its manuals too.

 

I read below link under software mixing

https://www.alsa-pro...p/Asoundrc#dmix

 

I follow .asoundrc overthere and aplay running with default device

 

unfortunately forked-daapd has very limited reference for the card



#33 zador.blood.stained

zador.blood.stained

    Advanced Member

  • Moderators
  • 1609 posts

Posted Yesterday, 11:45

Please try

card = "default"

in forked-daapd


Spoiler

#34 dony71

dony71

    Advanced Member

  • Senior Members
  • PipPipPip
  • 66 posts

Posted Yesterday, 21:29

Please try

card = "default"

in forked-daapd

 

/var/log/forked-daapd.log

----------------------------------------

[2017-01-16 12:28:51] [  LOG]   laudio: Failed to open configured mixer element 'I2s Or Pcm Audio Mode Select format'
[2017-01-16 12:28:51] [  LOG]   laudio: Could not open mixer
[2017-01-16 12:28:51] [  LOG]   player: Could not start ALSA device 'BPi-M2P'
[2017-01-16 12:28:51] [  LOG]   player: Could not activate ALSA device 'BPi-M2P'
 
FYI, sound output is OK by testing "aplay -f cd -D default test.wav"


#35 zador.blood.stained

zador.blood.stained

    Advanced Member

  • Moderators
  • 1609 posts

Posted Yesterday, 21:46

So you need to change the mixer line too in the config


Spoiler

#36 dony71

dony71

    Advanced Member

  • Senior Members
  • PipPipPip
  • 66 posts

Posted Yesterday, 21:52

So you need to change the mixer line too in the config

 

i have no idea change to what?



#37 zador.blood.stained

zador.blood.stained

    Advanced Member

  • Moderators
  • 1609 posts

Posted Yesterday, 21:57

i have no idea change to what?

I have no idea too. Please try to experiment, maybe comment out this line, use something like "default" or "dmix".


Spoiler

#38 dony71

dony71

    Advanced Member

  • Senior Members
  • PipPipPip
  • 66 posts

Posted Yesterday, 22:08

I have no idea too. Please try to experiment, maybe comment out this line, use something like "default" or "dmix".

 

try mixer = "dmix" or mixer = "default", not working

forked-daapd has very poor documentation regarding sound output setting

now to find correct setting, it's like trying to find needle in the desert :( 



#39 Bernie_O

Bernie_O

    Member

  • Senior Members
  • PipPip
  • 19 posts

Posted Today, 8:21

I think the developer (E.Jurgensen) might be willing to help. So I would suggest to ask him directly in this thread:
https://www.raspberr...pic.php?t=49928

I know this is a Raspberry-Pi Forum, but regarding sound-card configuration there should be no difference. Maybe he has an idea, or another user has a similar setup to yours. If you can solve your problem it would be nice to post the solution here as well.

Best wishes, Bernie_O