• Before reporting problems with your board running Armbian, check the following:

    • 1. Check power supply, check SD card and check other people experiences   06/23/17

      Power supply issues are one of the three biggest issues you'll face when starting with Single Board Computers (SBCs). SD card issues, whether fake or faulty, are another and issues resulting from poor board design is the other common issues you can encounter.   Power supply issues can be tricky. You might have a noisy power supply that works with one board because it has extra filtering, but won't work with another. Or you're using that cheap phone charger because your board has a microUSB connector, and it is either erratic, or doesn't start up, or even becomes the cause of some SD card issues.    Some tips to avoid the most common causes of problems reported:   Don't power via micro USB  - unless you have optimised your setup for low power requirements. Micro USB is great for mobile phones because they are simply charging a battery. It's bad for SBCs. Yes, it does work for a lot of people, but it also causes more problems and headaches over time than it is worth, unless you know exactly what you are doing. If you have a barrel jack power connector on your SBC, use it instead! If there is an option for powering via header connections, use that option!
        Don't use mobile phone chargers. They might be convenient and cheap, but this is because they are meant for charging phones, not powering your SBC which has particular power requirements.
        When you are evaluating a power supply, make sure you run some stress tests on your system to ensure that it will not cause issues down the path.   (Micro) SD card issues can be sneaky. They might appear right at the start causing strange boot and login errors, or they might cause problems over time. It is best to run a test on any new SD card you use, to ensure that it really is what it is, and to ensure that isn't faulty. Armbian provides you a simple way to do this   --   armbianmonitor -c /path/to/device/to/test  
    • 2. Make sure to collect and provide all necessary information   06/24/17

      We can only help if you provide quality information for us to work with. All stable images from the download section are tested, most stable upgrades are tested and we have tens of thousands of users. Even with regular and extensive testings, bugs sometimes do slip through. This is a voluntary support service and is unrelated to board makers, and is not obligated to provide you any answers. Repeated asking the same questions because you're not happy with the answers will result in you being ignored.

      Before you post a question, use the forum search as someone else might have already had the same problem and resolved it. And make sure you've read the Armbian documentation. If you still haven't found an answer, make sure you include the following in your post:   1. Logs when you can boot the board: armbianmonitor -u (paste URL to your forum post)   2. If your board does not boot, provide a log from serial console or at least make a picture, where it stops.   3. Describe the problem the best you can and provide all necessary info that we can reproduce the problem. We are not clairvoyant or mind readers. Please describe your setup as best as possible so we know what your operating environment is like.     We will not help in cases you are not using stable official Armbian builds, you have a problem with 3rd party hardware or reported problem would not be able to reproduced.

Wireless AP OPI One
0

8 posts in this topic

Recommended Posts

Hello,

 

I have just been following the instructions set up here to make an access point out of my orange pi one which has the 4.9.4-sun8i dev kernels (they are not the problem). https://learn.adafruit.com/setting-up-a-raspberry-pi-as-a-wifi-access-point/install-software

 

When I begin the first test I get an error that is spit out by the interface I guess? (I'm relatively new to linux and am trying to get a hang of it)

Configuration file: /etc/hostapd/hostapd.conf
nl80211: Could not configure driver mode
nl80211: deinit ifname=wlx40a5ef0eea56 disabled_11b_rates=0
nl80211 driver initialization failed.
wlx40a5ef0eea56: interface state UNINITIALIZED->DISABLED
wlx40a5ef0eea56: AP-DISABLED 
hostapd_free_hapd_data: Interface wlx40a5ef0eea56 wasn't started

My hostapd.conf file is also as follows, although it looks OK to me.

ssid=PI_AP            
interface=wlx40a5ef0eea56
hw_mode=g
channel=5
driver=nl80211
logger_syslog=0
logger_syslog_level=0
wmm_enabled=1
ieee80211n=1
wpa=3
preamble=1
#wpa_psk=66eb31d2b48d19ba216f2e50c6831ee11be98e2fa3a8075e30b866f4a5ccda27
wpa_passphrase=12345678
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
auth_algs=1
macaddr_acl=0
noscan=1
#ht_capab=[HT40-][SHORT-GI-40][SHORT-GI-40][DSSS_CCK-40]
country_code=US
#ieee80211d=1
root@orangepion

Share this post


Link to post
Share on other sites

Running wireless AP on developing kernel (no end user support by default) and 3rd party wireless hardware (also unsupported by us since it's mission impossible) is a hard nut even for experienced users. If you are newbie go the other way and search for & buy a working combination, Orange board with supported on-board WiFi(s) or just prepare yourself for many trial and errors. 

And we use NetworkManager, since it's more user friendly for newbies. The manual above is wrong in first place. Try this.

Share this post


Link to post
Share on other sites

The current mainline kernel has the same problem with orange pi pc plus. Legacy image works but mainline don't. On mainline the wireless don't work even on client the initialization just fails. Tried my own build and the image provided, on a working installation the command what it is trying is to set the ap mode...

Share this post


Link to post
Share on other sites

Another quick one...

 

What causes network manager to instinctively port traffic from a wireless interface to the ethernet interface in an access point setting? I will read up on the documentation but essentially I am thinking of setting up an access point that ports traffic to another wireless network interface.

Share this post


Link to post
Share on other sites

don't know if you are using the post marked by igor it show nothing on actual routing.

perhaps the network manager does it internally adding iptable rows or something similar.

 

hostap itself don't actually do anything for the networking layer other than just give the client ip-address all the interface tied routing is done by normal procedures.

at least I don't know any other way to route traffic from one interface to another than iptables rules

 

one thing to test whenever have some extra time...

 

 

Another quick one...

 

What causes network manager to instinctively port traffic from a wireless interface to the ethernet interface in an access point setting? I will read up on the documentation but essentially I am thinking of setting up an access point that ports traffic to another wireless network interface.

Share this post


Link to post
Share on other sites

You can use iptables to set up NAT routing.  If you don't need NAT, "echo 1 > /proc/sys/net/ipv4/ip_forward" will turn on ipv4 routing.  I've never set up bridging.

Share this post


Link to post
Share on other sites

Alright, I will see if routing the traffic to and from my other adapter will work on its own trough iptables. I wasn't sure if there was an open file in NM that had the routing rules before I just tried to do it through iptables manually. I kind of assumed it was done internally but wanted to check. I will let you know if it works.

Share this post


Link to post
Share on other sites

Ok I did some more testing and it turns out that wpa_supplicant is interfering with hostapd, so I don't have to specifically worry about network manager anymore. All i did to fix the issue was define the cards in wpa_supplicant and then it worked as planned.

 

As for Network Manager, putting iptables over the instinctive routing path didn't change anything as I'd expected, I talked to someone that said making hard routes with the "route" command would be a better Idea and more likely to work but I've never really done that.

 

Overall, wpa_supplicant seems to mess around with the wireless interface AP mode and encourage anyone else with a similar problem to either disable it or write in the arguments that you need.

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

0

  • Support the project

    We need your help to stay focused on the project.

    Choose the amount and currency you would like to donate in below.