testers wanted armbian-config
4 4

76 posts in this topic

serverinstallnew2.png

 

Samba, TV headend, BitTorrent Sync, SoftEther VPN server, CUPS, scanner + buttons + OCR, Temper, Rpimonitor + 3 additional sensors, Transmission, ISPConfig (Apache2 or NginX, PHP, Mysql with phpMyAdmin, Postfix, Dovecot)

 

Project realisation: http://www.igorpecovnik.com/2013/12/10/micro-home-server/

sudo apt-get -y install git
cd ~
git clone https://github.com/igorpecovnik/Debian-micro-home-server
chmod +x ./Debian-micro-home-server/softy
chmod +x ./Debian-micro-home-server/debian-config
sudo ./softy
# or
sudo ./debian-config
  • welcome to submit / push your modifications if you think they are interesting for general public.
  • scripts are a part of nightly images from 5.4.2017
manuti likes this

Share this post


Link to post
Share on other sites

also another thing that i find better is Syncthing rather then Bittorrent Sync since BT got greedy been messing around with it and its really easy and faster then BT Sync with more options for Backups

Share this post


Link to post
Share on other sites

also another thing that i find better is Syncthing rather then Bittorrent Sync since BT got greedy been messing around with it and its really easy and faster then BT Sync with more options for Backups

 

I agree. I also dumped BTSync from usage some time ago but haven't adjust the build script yet. Currently I am developing the backup / restore part which hanged somewhere in the middle.

 

All general services are open / free to change. I don't prefer any - it must work / suit the purpose.  :)

Toast likes this

Share this post


Link to post
Share on other sites
Igor first of all thank you for your work and for allowing us we can use it.

 

Sorry to use google translator.

 

I am a total and complete novice, but I can follow directions.

I'm trying to setup SAMBA so as to share folders with other devices in my home.

 

I'm using the img I downloaded from your site:

Bananapi_Debian_3.0_wheezy_3.4.107

And I'm using your scrip Micro Home Server

 

I connected a hard disk formatted in NTFS to BPI and is configured to mount on startup within this folder /media/HDD1 (from the console I can see and enter the disk).

My fstab looks like this:

/dev/sda1 /media/HDD1 ntfs-3g defaults, locale = es_AR.UTF-8 0 0

 

Within the smb.conf file parameters copied to the folder /ext shared but changing routes to the folder riding my record.

 [HDD1]

        comment = HDD1

        patch = /media/HDD1

        writable = yes

        public = yes

        valid users = banana

        force create mode = 0777

        force directory mode = 0777

 

 

Both Windows and android I can see the folder /ext, but since neither OS I can see my hard drive

 

Any hints of what can I be doing wrong?

 

Thanks in advance

 

EDIT:


Some progress I've made:

no matter where I create a folder, smb.conf does not recognize or show that shared folder.

But if I edit the first block that comes after the settings for sharing printers recognize any folder you configure it. It is as if he had a cap of lines that can be read EJ:

 

In this case it recognizes and shares the folder / ext but does not recognize or share /HDD1

 

[Ext]

        comment = Storage

        patch = /ext

        writable = yes

        public = no

        valid users = banana

        force create mode = 0777

        force directory mode = 0777

 

[HDD1]

        comment = HDD1

        patch = /media/HDD1

        writable = yes

        public = no

        valid users = banana

        force create mode = 0777

        force directory mode = 0777

 

In this case it recognizes and shares the folder / HDD1 but does not recognize or shared / ext

 

[HDD1]

        comment = HDD1

        patch = /media/HDD1

        writable = yes

        public = no

        valid users = banana

        force create mode = 0777

        force directory mode = 0777

 


[ext]

         comment = Storage

         patch = /ext

         writable = yes

         public = no

         valid users = banana

         force create mode = 0777

         force directory mode = 0777

 

In this case if I mention the first block does not recognize or share anything:

 

# [ext]

# Comment = Storage

# Patch = /ext

# Writable = yes

# Public = no

# Valid users = banana

# Force create mode = 0777

# Force directory mode = 0777

 

[HDD1]

         comment = HDD1

         patch = /media/HDD1

         writable = yes

         public = no

         valid users = banana

         force create mode = 0777

         force directory mode = 0777


Edited by enredar

Share this post


Link to post
Share on other sites

You are typing patch instead of path. This works for me

[TV] #This is the name of the share it will show up as when you browse
comment = TV Folder
path = /mnt/usbstorage/TV
create mask = 0755
directory mask = 0755
read only = no
browseable = yes
public = yes
force user = pi
#force user = root
only guest = no

Share this post


Link to post
Share on other sites
I'm an idiot!

Shame on me! :unsure:

You are right!

Everything works OK without my error. 

 

Thanks!!

Share this post


Link to post
Share on other sites

I have forked your repo to add a lot of media server stuff, I added syncthing too with the code below

 

install_syncthing () {
#--------------------------------------------------------------------------------------------------------------------------------
# Install syncthing
#--------------------------------------------------------------------------------------------------------------------------------
SYNCTHINGUSER=$(whiptail --inputbox "Enter the user to run Syncthing as (usually pi)" 8 78 $SYNCTHINGUSER --title "$SECTION" 3>&1 1>&2 2>&3)
exitstatus=$?; if [ $exitstatus = 1 ]; then exit 1; fi
if ! getent passwd $SYNCTHINGUSER > /dev/null; then
echo "User $SYNCTHINGUSER doesn't exist, exiting, restart the installer"
exit
fi
if !(cat /etc/apt/sources.list.d/syncthing-release.list | grep -q Syncthing > /dev/null);then
cat >> /etc/apt/sources.list.d/syncthing-release.list <<EOF
# Syncthing
deb http://apt.syncthing.net/ syncthing release
EOF
wget -O - https://syncthing.net/release-key.txt | apt-key add -


debconf-apt-progress -- apt-get update
debconf-apt-progress -- apt-get install syncthing -y
sudo -u $SYNCTHINGUSER timeout 120s syncthing
#Make syncthing webui remotely accessible
sed -i "/ <address>127.0.0.1:8384/c\ \<address>0.0.0.0:8384\<\/address\>" /home/$SYNCTHINGUSER/.config/syncthing/config.xml
cd /etc/init.d/
wget https://raw.github.com/blindpet/MediaServerInstaller/usenet/scripts/syncthing
sed -i "/DAEMON_USER=root/c\DAEMON_USER=$SYNCTHINGUSER" /etc/init.d/syncthing
chmod +x /etc/init.d/syncthing
cd /tmp
update-rc.d syncthing defaults
service syncthing start
echo Syncthing is running on $showip:8384
fi
}

I also changed btsync so it uses a repo and makes it much easier

 

cd /tmp
wget http://debian.yeasoft.net/add-btsync-repository.sh
( echo yes && \
echo yes ) \
| sh add-btsync-repository.sh
apt-get update
apt-get install btsync -y

I haven't ever made a pull request but will try sometime next month

Share this post


Link to post
Share on other sites

I have installed Samba, CUPS and RPiMonitor, but I wanted to install mysql as well, so I git-cloned again and marked just the mysql option during installation.

But I am getting this error after marking "apache" in webserver config:

 

./Debian-micro-home-server/install.sh: line 99: install_Apache: command not found
./Debian-micro-home-server/install.sh: line 101: create_ispconfig_configuration: command not found
./Debian-micro-home-server/install.sh: line 102: install_PureFTPD: command not found
./Debian-micro-home-server/install.sh: line 102: install_Fail2BanDovecot: command not found
./Debian-micro-home-server/install.sh: line 102: install_Fail2BanRulesDovecot: command not found
./Debian-micro-home-server/install.sh: line 102: install_ISPConfig: command not found
 

Any ideas why? I have redownloaded the whole thing again, so I am sure it is complete.

Share this post


Link to post
Share on other sites

Mysql is a part of the whole package and can't be installed this way.

You can issue a simple command to install it:

apt-get intall mysql-server

If this is what you need.

Share this post


Link to post
Share on other sites
root@homeserver:~# cd ./Debian-micro-home-server
root@homeserver:~/Debian-micro-home-server# sudo ./install.sh
sudo: unable to stat /etc/sudoers: Permission denied
sudo: no valid sudoers sources found, quitting
sudo: unable to initialize policy plugin

try:

chown root:root /etc/sudoers
sudo chown root:root /etc/sudoers.d
sudo chmod 755 /etc/sudoers.d
does not work

Share this post


Link to post
Share on other sites
Configuring phpmyadmin +-------------------------¬  

 Â¦                                                                           ¦  

 Â¦ An error occurred while installing the database:                          Â¦  

 Â¦                                                                           ¦  

 Â¦ ERROR 2002 (HY000): Can't connect to local MySQL server through socket    Â¦  

 Â¦ '/var/run/mysqld/mysqld.sock' (2)                                         ¦  

 Â¦                                                                           ¦  

 Â¦ If at this point you choose "retry", you will be prompted with all the    Â¦  

 Â¦ configuration questions once more and another attempt will be made at     ¦  

 Â¦ performing the operation. "retry (skip questions)" will immediately       ¦  

 Â¦ attempt the operation again, skipping all questions. If you choose        Â¦  

 Â¦ "abort", the operation will fail and you will need to downgrade,          Â¦  

 Â¦ reinstall, reconfigure this package, or otherwise manually intervene to   ¦  

 Â¦ continue using it. If you choose "ignore", the operation will continue,   ¦  

 Â¦ ignoring further errors from dbconfig-common.

Share this post


Link to post
Share on other sites
 Unable to set password for the MySQL "root" user                          â”‚  

 â”‚                                                                           │  

 â”‚ An error occurred while setting the password for the MySQL                â”‚  

 â”‚ administrative user. This may have happened because the account already   │  

 â”‚ has a password, or because of a communication problem with the MySQL      â”‚  

 â”‚ server.                                                                   │  

 â”‚                                                                           │  

 â”‚ You should check the account's password after the package installation.   │  

 â”‚                                                                           │  

 â”‚ Please read the /usr/share/doc/mysql-server-5.5/README.Debian file for    â”‚  

 â”‚ more information.

Share this post


Link to post
Share on other sites

Unable to connect to the specified MySQL server Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)

Share this post


Link to post
Share on other sites

These are errors when attempting to perform
sudo apt-get -y install git
cd
~
git clone https://github.com/igorpecovnik/Debian-micro-home-server
chmod +x ./Debian-micro-home-server/install.sh
cd
./Debian-micro-home-server
sudo
./install.sh

not available mysql-server :( 

 

Share this post


Link to post
Share on other sites
Stopping MySQL database server: mysqld.

150911 23:00:30 [Warning] Using unique option prefix key_buffer instead of key_buffer_size is deprecated and will be removed in a future release. Please use the full name instead.

150911 23:00:30 [Note] /usr/sbin/mysqld (mysqld 5.5.44-0+deb7u1) starting as process 9717 ...

150911 23:00:30 [Warning] Using unique option prefix myisam-recover instead of myisam-recover-options is deprecated and will be removed in a future release. Please use the full name instead.

150911 23:00:30 [Note] Plugin 'FEDERATED' is disabled.

150911 23:00:30 InnoDB: The InnoDB memory heap is disabled

150911 23:00:30 InnoDB: Mutexes and rw_locks use GCC atomic builtins

150911 23:00:30 InnoDB: Compressed tables use zlib 1.2.7

150911 23:00:30 InnoDB: Using Linux native AIO

/usr/sbin/mysqld: Can't create/write to file '/tmp/ibD31lDv' (Errcode: 13)

150911 23:00:30  InnoDB: Error: unable to create temporary file; errno: 13

150911 23:00:30 [ERROR] Plugin 'InnoDB' init function returned error.

150911 23:00:30 [ERROR] Plugin 'InnoDB' registration as a STORAGE ENGINE failed.

150911 23:00:30 [ERROR] Unknown/unsupported storage engine: InnoDB

150911 23:00:30 [ERROR] Aborting

 

150911 23:00:30 [Note] /usr/sbin/mysqld: Shutdown complete

Share this post


Link to post
Share on other sites

I tried last week on Jessie. Tested just now on Wheezy. In both cases full install with samba, tvheadend and ispconfig.

Working without a problem!

Welcome to the MySQL monitor.  Commands end with ; or \g.
Your MySQL connection id is 44
Server version: 5.5.44-0+deb7u1 (Debian)

Copyright (c) 2000, 2015, Oracle and/or its affiliates. All rights reserved.

Oracle is a registered trademark of Oracle Corporation and/or its
affiliates. Other names may be trademarks of their respective
owners.

Type 'help;' or '\h' for help. Type '\c' to clear the current input statement.

mysql>

Can u elaborate what are you doing? Which steps are you taking that you fail?

Share this post


Link to post
Share on other sites

On just installed system I start a script:

sudo apt-get -y install git
cd ~
git clone https://github.com/igorpecovnik/Debian-micro-home-server
chmod +x ./Debian-micro-home-server/install.sh
cd ./Debian-micro-home-server
sudo ./install.shEverything works without problems to a stage of request of the password of root mysgl.
I import any passwords: both simple and difficult.
There are mistakes:

 Unable to set password for the MySQL "root" user  
                   
                                                                     
 
│ An error occurred while setting the password for the MySQL
 â”‚ administrative user. This may have happened because the account already
 â”‚ has a password, or because of a communication problem with the MySQL 
 â”‚ server.                                                                
 â”‚                                                                      
 â”‚ You should check the account's password after the package installation. 
 â”‚                                                                       
 â”‚ Please read the /usr/share/doc/mysql-server-5.5/README.Debian file for   
 â”‚ more information.

Unable to connect to the specified MySQL server Can't connect to local MySQL server through socket '/var/run/mysqld/mysqld.sock' (2)

 

And so around. Mysql asks the password, I import and again these mistakes. On all kernels.
Before such wasn't. I don't know why. I tried early assemblies, the same situation.

 

Can do it it is connected with that that at me costs SSD? and there remains of unsuccessful transfer of system?

Share this post


Link to post
Share on other sites

But do you input any password or you leave blank? I always use a password. Maybe you use too short or invalid. I don't know exactly what is allowed by mysql. Script just read a password and pass it to mysql install program.

 

It should not be connected to SATA / SSD / NAND install.
 

apt-get update

 

prior to starting is good thing but not necessary.

 

Script is working properly only on a clean system. If you break and start over it might fail.

 

It's not that bullet proof.

Share this post


Link to post
Share on other sites
I found the reason why so occurs: if to establish only the last point in a script (ISPconfig) that everything perfectly works. If to select one more item of the menu: transmission and VPNserver that Mysql won't be established and if it worked earlier that will cease to work.

I for the present didn't find out precisely what point of the menu in a script breaks work of Mysql

Share this post


Link to post
Share on other sites

I guess VPN server must be the problem since I was testing without, but installing Transmission and TVheadend. 

 

Thanks for this info. It will save time for others and I'll fix this somehow.

 

Maybe it's time that we do some updates to the script.  :P

Share this post


Link to post
Share on other sites

I checked other points of a script. Works all but vpn server. Its installation causes errors of Mysql and apache (403 forbidden you don't have permission to access on this server)

Igor likes this

Share this post


Link to post
Share on other sites

You can include minidlna, a media server software fully compliant with DLNA/UPnP-AV clients.

I use it to watch my downloaded films on my smart tv.

sudo apt-get install minidlna

Share this post


Link to post
Share on other sites

 

You can include minidlna, a media server software fully compliant with DLNA/UPnP-AV clients.

I use it to watch my downloaded films on my smart tv.

sudo apt-get install minidlna

 

The version in the repo (even jessie) is a year old. Build miniDLNA from source in case you get any problems with the old version.

Rui Ribeiro likes this

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
4 4

  • Support the project

    We need your help to stay focused on the project.

    Choose the amount and currency you would like to donate in below.