kernel 4.11-rc7
1 1

7 posts in this topic

Hi all,

I'd like to compile latest kernel 4.11-rc7, so i added

KERNELTAG="v4.11-rc7" to ./compile.sh and created file /userpatches/lib.config and added KERNELBRANCH="4.11" to it

i also added to /lib/configuration.sh according to documentation

ARMBIAN_MAINLINE_KERNEL_VERSION='4.11' # lock in a particular kernel version

but i get this error :

[ o.k. ] Using user configuration override [ userpatches/lib.config ]
[ o.k. ] Syncing clock [ host ]
[ o.k. ] Downloading sources 
[ o.k. ] Checking git sources [ u-boot v2017.03 ]
[ .... ] Up to date 
[ error ] ERROR in function fetch_from_repo [ general.sh:184 ]
[ error ] Error in configuration 
[ o.k. ] Process terminated 

what is wrong?

 

Share this post


Link to post
Share on other sites
1 minute ago, rogus said:

what is wrong?

 

KERNELBRANCH syntax is wrong, it should be KERNELBRANCH='branch:orange-pi-4.11'

 

Please keep in mind that if you switch the kernel branch you may have to update the kernel configuration and you will have to update all the patches that may cause conflicts.

Share this post


Link to post
Share on other sites
29 minutes ago, zador.blood.stained said:

Please keep in mind that if you switch the kernel branch you may have to update the kernel configuration and you will have to update all the patches that may cause conflicts

 

Which are essentially all except packaging patch ;)

Share this post


Link to post
Share on other sites
6 hours ago, zador.blood.stained said:

Please keep in mind that if you switch the kernel branch you may have to update the kernel configuration and you will have to update all the patches that may cause conflicts.

The syntax was wrong, and it worked with KERNELBRANCH='branch:orange-pi-4.11' , is it the same syntax for all orange pi boards ( i use Opi lite)?

The u-boot package build was successful, but problems appear with kernel, so  about the patches, what you mentioned above is exactly what happened,  but it is not as disastrous as i expected, only few failed (if you except my userpatches) :

[ .... ] Patching kernel for compiler support 
[ o.k. ] Started patching process for [ kernel sun8i-dev ]
[ o.k. ] Looking for user patches in [ userpatches/kernel/sun8i-dev ]
[ o.k. ] ... [u][c] 9700-1.patch [ succeeded ]
[ o.k. ] ... [u][c] 9700-2.patch [ succeeded ]
[ o.k. ] ... [u][c] 9700-3.patch [ succeeded ]
[ o.k. ] ... [l][c] add-BergMicro-SPI-flashes.patch [ succeeded ]
[ o.k. ] ... [l][c] add-ad9834-dt-bindings.patch [ succeeded ]
[ warn ] ... [l][c] add-beelink-x2.patch [ failed ]
[ o.k. ] ... [l][c] add-configfs-overlay-for-v4.10.x.patch [ succeeded ]
[ o.k. ] ... [l][c] add-emac-pwr-en-orangepi-plus2e.patch [ succeeded ]
[ warn ] ... [l][c] add-h3-aliases.patch [ failed ]
[ o.k. ] ... [l][c] add-h3-overlays.patch [ succeeded ]
[ warn ] ... [l][c] add-h3-simplefb.patch [ failed ]
[ warn ] ... [l][c] add-opi-zero-dts-with-wireless.patch [ failed ]
[ o.k. ] ... [l][c] add-overlay-compilation-support.patch [ succeeded ]
[ o.k. ] ... [l][c] add-realtek-8189fs-driver.patch [ succeeded ]
[ warn ] ... [l][c] add-thermal-otg-wireless-opi-lite.patch [ failed ]
[ warn ] ... [l][c] add-uart-rts-cts-pins.patch [ failed ]
[ o.k. ] ... [l][c] add-wifi-pwrseq-opi-pc-plus.patch [ succeeded ]
[ o.k. ] ... [l][c] add-xradio-wireless-driver.patch [ succeeded ]
[ o.k. ] ... [u][c] dm9601-bug.patch [ succeeded ]
[ o.k. ] ... [l][c] enable-codec-orange-pi-2.patch [ succeeded ]
[ o.k. ] ... [l][c] enable-codec-orange-pi-pc.patch [ succeeded ]
[ o.k. ] ... [l][c] nanopi-neo-air-wireless-and-dvfs.patch [ succeeded ]
[ o.k. ] ... [l][c] packaging-4.x-DEV-with-postinstall-scripts.patch [ succeeded ]
[ warn ] ... [u][c] patch01.patch [ failed ]
[ o.k. ] ... [u][c] patch02.patch [ succeeded ]
[ o.k. ] ... [u][c] patch03.patch [ succeeded ]
[ o.k. ] ... [u][c] patch04.patch [ succeeded ]
[ o.k. ] ... [u][c] patch05.patch [ succeeded ]
[ o.k. ] ... [u][c] patch06.patch [ succeeded ]
[ o.k. ] ... [u][c] patch07.patch [ succeeded ]
[ warn ] ... [u][c] patch1.patch [ failed ]
[ warn ] ... [u][c] patch17.patch [ failed ]
[ o.k. ] ... [u][c] patch18.patch [ succeeded ]
[ warn ] ... [u][c] patch2.patch [ failed ]
[ warn ] ... [l][c] scripts-dtc-Update-to-version-with-overlays.patch [ failed ]
[ o.k. ] ... [l][c] spi-sun6i-allow-large-transfers.patch [ succeeded ]
[ o.k. ] ... [l][c] spidev-remove-warnings.patch [ succeeded ]
[ o.k. ] Compiling dev kernel [ 4.11.0-rc7 ]
[ o.k. ] Compiler version [ arm-linux-gnueabihf-gcc 6.3.1 ]
[ o.k. ] Using kernel config file [ lib/config/kernel/linux-sun8i-dev.config ]

After kernel configuration, it seems that the /sources/linux-sun8i/sun8i/scripts/dtc/livetree.c file is problematic. for now, i have no idea what this file is and what to adjust in source code.

*** End of the configuration.
*** Execute 'make' to start the build or try 'make help'.
Compiling kernel...
----------------------------------------------------------------------------------------------------------------------

scripts/dtc/livetree.c:1008:6: warning: no previous prototype for ‘generate_label_node’ [-Wmissing-prototypes]                                  │  
                                            │  void generate_label_node(struct node *node, struct node *dt)                                                                                   │  
                                            │       ^                                                                                                                                         │  
                                            │ scripts/dtc/livetree.c: In function ‘generate_label_node’:                                                                                      │  
                                            │ scripts/dtc/livetree.c:1058:7: error: ‘symbol_fixup_support’ undeclared (first use in this function)                                            │  
                                            │    if (symbol_fixup_support)                                                                                                                    │  
                                            │        ^                                                                                                                                        │  
                                            │ scripts/dtc/livetree.c:1058:7: note: each undeclared identifier is reported only once for each function it appears in                           │  
                                            │ scripts/dtc/livetree.c: At top level:                                                                                                           │  
                                            │ scripts/dtc/livetree.c:1066:13: error: conflicting types for ‘add_fixup_entry’                                                                  │  
                                            │  static void add_fixup_entry(struct node *dt, struct node *node,                                                                                │  
                                            │              ^                                                                                                                                  │  
                                            │ scripts/dtc/livetree.c:862:13: note: previous definition of ‘add_fixup_entry’ was here                                                          │  
                                            │  static void add_fixup_entry(struct dt_info *dti, struct node *fn,                                                                              │  
                                            │              ^                                                                                                                                  │  
                                            │ scripts/dtc/livetree.c:1098:13: error: conflicting types for ‘add_local_fixup_entry’                                                            │  
                                            │  static void add_local_fixup_entry(struct node *dt, struct node *node,                                                                          │  
                                            │              ^                                                                                                                                  │  
                                            │ scripts/dtc/livetree.c:925:13: note: previous definition of ‘add_local_fixup_entry’ was here                                                    │  
                                            │  static void add_local_fixup_entry(struct dt_info *dti,                                                                                         │  
                                            │              ^                                                                                                                                  │  
                                            │ scripts/dtc/livetree.c:1159:6: warning: no previous prototype for ‘generate_fixups_node’ [-Wmissing-prototypes]                                 │  
                                            │  void generate_fixups_node(struct node *node, struct node *dt)                                                                                  │  
                                            │       ^                                                                                                                                         │  
                                            │ make[2]: *** [scripts/dtc/livetree.o] Erreur 1                                                                                                  │  
                                            │   HOSTLD  scripts/mod/modpost                                                                                                                   │  
                                            │ make[1]: *** [scripts/dtc] Erreur 2                                                                                                             │  
                                            │ make: *** [scripts] Erreur 2
5 hours ago, tkaiser said:

Which are essentially all except packaging patch

As you can see, it's not all the patches that are concerned ;), but may be i'm going to face other errors if this one is solved. i realize now what amount of work for each kernel change the community have to provide to make things easier for us.

 

Share this post


Link to post
Share on other sites

I think i have to adapt this patch to current kernel branch, which is 4.11. should i use the patch program or git ?

Share this post


Link to post
Share on other sites

It is not the patching tool that is broken, it is the content of the patch that doesn't match code changes in 4.11.

You probably need to find out those change by comparing 4.10 and 4.11 together, and check which parts of the patch are broken.

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!


Register a new account

Sign in

Already have an account? Sign in here.


Sign In Now
1 1

  • Support the project

    We need your help to stay focused on the project.

    Choose the amount and currency you would like to donate in below.