Orange Pi Zero and NEXT kernel
2 2

22 posts in this topic

Recommended Posts

Hi,

 

I have today on ma Orange Pi Zero switch kernel from dev 4.11.12 to NEXT kernel 4.13.4 and notice that defined modules in /etc/modules file are not loaded during start system

I must manually load

 

and in log system:

 

   0.002070] CPU: Testing write buffer coherency: ok
[    0.002628] /cpus/cpu@0 missing clock-frequency property
[    0.002662] /cpus/cpu@1 missing clock-frequency property
[    0.002692] /cpus/cpu@2 missing clock-frequency property
[    0.002725] /cpus/cpu@3 missing clock-frequency property

 

and armbianmonitor don't show CPU frequency but on kernel  4.11.12 was OK

 

I know that NEXT kernel for tests, for this reason, I sen only my feedback

 

Regards

 

 

 

 

 

Share this post


Link to post
Share on other sites

Compiling a NEXT kernel now will give you CPU frequency scaling for the Opi Zero - up to 1200 MHz.

I upgraded an existing 4.11.12 install via freshly compiled kernel-debs (dtb,header,image).

 

Tested overlays: spi, analog-codec, ubhost2, usbhost3.

Issues: the already poor WLAN performance seems to have suffered some more => RX: 3mbit/s, TX: 9mbit/s (down from 10/13 mbit/s)

 

 

Share this post


Link to post
Share on other sites

Today I have updated my OPiZero to  ARMBIAN 5.33.171010 nightly Debian GNU/Linux 8 (jessie) 4.13.5-sunxi

and cpufreq is visible in armbianmonitor 

 

but in messages from dmesg still:

 

[    0.002072] CPU: Testing write buffer coherency: ok
[    0.002630] /cpus/cpu@0 missing clock-frequency property
[    0.002665] /cpus/cpu@1 missing clock-frequency property
[    0.002698] /cpus/cpu@2 missing clock-frequency property
[    0.002733] /cpus/cpu@3 missing clock-frequency property

 

Thank you

 

 

Share this post


Link to post
Share on other sites

 

@IgorThe for the performance drop seems to be a missing interrupt definition in the device tree.

 

@geotravelI am getting the same dmesg warnings, but frequency scaling (and thermals!) work.

 

Share this post


Link to post
Share on other sites

@Igor quick fix (fix-xradio-interrupt.patch):

diff --git a/arch/arm/boot/dts/sun8i-h2-plus-orangepi-zero.dts b/arch/arm/boot/dts/sun8i-h2-plus-orangepi-zero.dts
index 454408b..df356b5 100644
--- a/arch/arm/boot/dts/sun8i-h2-plus-orangepi-zero.dts
+++ b/arch/arm/boot/dts/sun8i-h2-plus-orangepi-zero.dts
@@ -49,6 +49,7 @@
 
 #include <dt-bindings/gpio/gpio.h>
 #include <dt-bindings/input/input.h>
+#include <dt-bindings/pinctrl/sun4i-a10.h>
 
 / {
 	model = "Xunlong Orange Pi Zero";
@@ -157,6 +158,10 @@
 	 */
 	xr819: sdio_wifi@1 {
 		reg = <1>;
+		compatible = "xradio,xr819";
+		interrupt-parent = <&pio>;
+		interrupts = <6 10 IRQ_TYPE_EDGE_RISING>;
+		interrupt-names = "host-wake";
 	};
 };
 

performance is back up to around 10 mbit/s ... (PCB rev 1.1). 

Igor likes this

Share this post


Link to post
Share on other sites

I have use kernel 4.13.5 from 10 October update with WIF setup and I have seen a lot of the messages after command "dmesg":

 

.....

[63639.603942] xradio_wlan mmc1:0001:1: missed interrupt
[63983.021823] xradio_wlan mmc1:0001:1: missed interrupt
[65262.383433] xradio_wlan mmc1:0001:1: missed interrupt
[66343.960082] xradio_wlan mmc1:0001:1: missed interrupt

........

Share this post


Link to post
Share on other sites

Today I made updates (apt update; apt upgrade) from 4.13.5 to kernel 4.13.7 and after restarting my Orange Pi Zero did not start up

I have an SD card archive before updating so I can restore system

 

Share this post


Link to post
Share on other sites

I have review syslog and messages under linux mounted SD card from Orange Pi zero and I have found message

 

logger: Can not find script.bin Ensure boot partition is mounted

 

Share this post


Link to post
Share on other sites
2 hours ago, geotravel said:

I have review syslog and messages under linux mounted SD card from Orange Pi zero and I have found message


This could mean you made some ugly upgrade from old 3.4.113 kernel to NEXT 4.13.x and further ? ... without actually removing the old one and when apt update is issued, kernel package that is updated last, takes the lead.

Share this post


Link to post
Share on other sites

Ok I have found the problem with the update to 4.13.7 .

 

Short history my test system on Orange Pi Zero

 

I have installed Armbian Jessie dev with kenel v4.11.5

Next, I have switch in armbian-config to nightly build kernel

After a few updates kernel 4.12. I have switch in armbina-config to NEXT kernels

I have updated regularly kernel with version 4.13.x to 4.13.5 

During use kernel 4.13.5 I have solved a problem with WIFI use when unplugging ethernet cable WIFI stopped working.

I have found a solution that I need set metric higher for WIFI than ethernet. I have use package 'ifmetric' and put in /etc/network/interfaces

 

in a definition of each interface

 

for ethernet

metric 20

 

and for WIFI

metric 10

 

After this, all working perfectly without any problems 

 

Today after update to 4.13.7 it looks that  'metric' is a problem for setup interface and for this reason system startup but without any network interface. If I put # before metric for eth0 and wlan0 system with kernel 4.13.7 startup network interfaces. It looks like I can not use 'metric' in /etc/network/interfaces with kernel 4.13.7 and I must restore my backup system with kernel 4.13.5 where all working.

 

Information about ifmetric:

https://www.debian.org/doc/manuals/debian-reference/ch05.en.html#_the_ifmetric_package

 

(Sorry for my English is not perfect )

 

 

 

Share this post


Link to post
Share on other sites

I have try add in /etc/network/interfaces add line:

 

up ifmetric eth0 20 

 

My whole define eth0:

auto lo
iface lo inet loopback


auto eth0
allow-hotplug eth0


iface eth0 inet static
 address 172.16.1.2
 netmask 255.255.255.0
 gateway 172.16.1.1
 dns-nameservers 8.8.8.8 8.8.4.4

 

 

If I add on end this "metric 20"  or "up ifmetric eth0 20"

during start up system I don't have network

 

But with kernel 4.13.5 working without problem ad set up metric value 20 for eth0 

 

 

 

 

 

Share this post


Link to post
Share on other sites

It's pretty pointless to compare RPi kernel 4.4 with a just-released modern kernel for H3. Perhaps and it's possible that something needed is missing. Then I am not sure you are using Ubuntu or Debian based base. This usually brings some difference. Is it hard to type armbianmonitor -u (which save a lot of our time) before asking questions?

 

What exactly you are trying to achieve? Perhaps you are using wrong tools?

Share this post


Link to post
Share on other sites

I have use


 

Welcome to ARMBIAN 5.33.171017 nightly Debian GNU/Linux 8 (jessie) 4.13.7-sunxi

I need set up metric value for eth0 20 and for wlan0 10

 

Typical tool is 'ifmetric' and I can put in /etc./network.interfaces in definition of interface like eth0 and wlan0 different  value of metric .

 

 

Quote

The ifmetric package enables us to manipulate metrics of routes a posteriori even for DHCP.

The following sets the eth0 interface to be preferred over the wlan0 interface.

Install the ifmetric package.

Add an option line with "metric 0" just below the "iface eth0 inet dhcp" line in "/etc/network/interfaces".

Add an option line with "metric 1" just below the "iface wlan0 inet dhcp" line in "/etc/network/interfaces".

The metric 0 means the highest priority route and is the default one. The larger metric value means lower priority routes. The IP address of the active interface with the lowest metric value becomes the originating one. See ifmetric(8).

9

 

Share this post


Link to post
Share on other sites

Read my post once again.

 

1. Provide logs with armbianmonitor -u Always.

2. Describe what do you want to achieve. The main purpose, with simple words. Almost like describing this problem to your mother. Perhaps a better / more simple way exists?

In any case, this problem is looks off topic. It looks like a generic network related problem, unrelated to Armbian or Orangepi Zero. 

Add.  And I would recommend you to start with Ubuntu based Armbian. It's less troublesome than Jessie. 

Share this post


Link to post
Share on other sites

Thank you for the advice ...

Quote

Read my post once again.

 

1. Provide logs with armbianmonitor -u Always.

2. Describe what do you want to achieve. The main purpose, with simple words. Almost like describing this problem to your mother. Perhaps a better / more simple way exists?

In any case, this problem is looks off topic. It looks like a generic network related problem, unrelated to Armbian or Orangepi Zero. 

Add.  And I would recommend you to start with Ubuntu based Armbian. It's less troublesome than Jessie. 

 

5

 

Share this post


Link to post
Share on other sites

Create an account or sign in to comment

You need to be a member in order to leave a comment

Create an account

Sign up for a new account in our community. It's easy!

Register a new account

Sign in

Already have an account? Sign in here.

Sign In Now

2 2

  • Support the project

    We need your help to stay focused on the project.

    Choose the amount and currency you would like to donate in below.