All Activity

This stream auto-updates     

  1. Past hour
  2. Igor

    Adding Debian buster

    It seems that base packages are different ... I didn't check anything at this stage. Perhaps a diff between stretch and buster packages should be nice to have. From CLI and desktop ... and adjust accordingly. Probably there are some other packages missing.
  3. Today
  4. Igor

    Orangepi 3 h6 allwiner chip

    Kernel configuration that is used for development is not fine tuned. Add those: CONFIG_PARPORT=m CONFIG_PRINTER=m CONFIG_PPDEV=m and this error will go away.
  5. martinayotte

    Orangepi 3 h6 allwiner chip

    Your image seems to try to find those modules and not finding them ... This doesn't seem to be a "untouched" image, since those modules are not part of the build. Did you install a specific applications or did you modified /etc/modules-load.d/modules.conf ?
  6. martinayotte

    A64 date/time clock issue

    Don't confuse me : Pine64 != Rock64 ... I don't understand why using Armbian_5.79.190418_Pine64_Ubuntu_bionic_dev_5.0.7.img. On my side, here is "dmesg | grep eth" give : root@pine64:~# dmesg | grep eth [ 4.651697] dwmac-sun8i 1c30000.ethernet: PTP uses main clock [ 4.662672] dwmac-sun8i 1c30000.ethernet: Linked as a consumer to regulator.6 [ 4.677055] dwmac-sun8i 1c30000.ethernet: Current syscon value is not the default 6 (expect 0) [ 4.685758] dwmac-sun8i 1c30000.ethernet: No HW DMA feature register supported [ 4.693011] dwmac-sun8i 1c30000.ethernet: RX Checksum Offload Engine supported [ 4.700246] dwmac-sun8i 1c30000.ethernet: COE Type 2 [ 4.705231] dwmac-sun8i 1c30000.ethernet: TX Checksum insertion supported [ 4.712026] dwmac-sun8i 1c30000.ethernet: Normal descriptors [ 4.717702] dwmac-sun8i 1c30000.ethernet: Chain mode enabled [ 18.403292] dwmac-sun8i 1c30000.ethernet eth0: No Safety Features support found [ 18.403309] dwmac-sun8i 1c30000.ethernet eth0: No MAC Management Counters available [ 18.403316] dwmac-sun8i 1c30000.ethernet eth0: PTP not supported by HW [ 31.712399] dwmac-sun8i 1c30000.ethernet eth0: Link is Up - 100Mbps/Full - flow control rx/tx [ 31.712430] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
  7. Petee

    A64 date/time clock issue

    Yes per your instruction did not utilize the 3.3VDC pin on the JTAG port and used a 2 AMP external PS connected to Euler Bus. Aside from the time sync issue (well the time going way off) the network port just disconnects randomly after a day or so with the default Gb setting or adjusted to Mb setting. Does this mean that I have a bad Pine64 here? With the original posted on the Pine64 wiki / forum never had an issue with the legacy Ubuntu 16.04. I did update that original build to Ubuntu 18.04 and it worked OK but did have some issues with it. Had a few minutes here to type between this and that....
  8. ilchenko Evgeny

    Orangepi 3 h6 allwiner chip

    Hi guys! I'm still with my sore) Perhaps this log will enlighten the problem. ozz@orangepi3:~$ systemctl status systemd-modules-load.service * systemd-modules-load.service - Load Kernel Modules Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static; ven Drop-In: /lib/systemd/system/systemd-modules-load.service.d `-10-timeout.conf Active: failed (Result: exit-code) since Thu 2019-04-18 20:26:57 MSK; 3min 49 Docs: man:systemd-modules-load.service(8) man:modules-load.d(5) Process: 465 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status= Main PID: 465 (code=exited, status=1/FAILURE) Apr 18 20:26:57 orangepi3 systemd[1]: Starting Load Kernel Modules... Apr 18 20:26:57 orangepi3 systemd-modules-load[465]: Failed to find module 'lp' Apr 18 20:26:57 orangepi3 systemd-modules-load[465]: Failed to find module 'ppde Apr 18 20:26:57 orangepi3 systemd-modules-load[465]: Failed to find module 'parp Apr 18 20:26:57 orangepi3 systemd[1]: systemd-modules-load.service: Main process Apr 18 20:26:57 orangepi3 systemd[1]: systemd-modules-load.service: Failed with Apr 18 20:26:57 orangepi3 systemd[1]: Failed to start Load Kernel Modules. lines 1-17/17 (END)...skipping... * systemd-modules-load.service - Load Kernel Modules Loaded: loaded (/lib/systemd/system/systemd-modules-load.service; static; vendor preset: enabled) Drop-In: /lib/systemd/system/systemd-modules-load.service.d `-10-timeout.conf Active: failed (Result: exit-code) since Thu 2019-04-18 20:26:57 MSK; 3min 49s ago Docs: man:systemd-modules-load.service(8) man:modules-load.d(5) Process: 465 ExecStart=/lib/systemd/systemd-modules-load (code=exited, status=1/FAILURE) Main PID: 465 (code=exited, status=1/FAILURE) Apr 18 20:26:57 orangepi3 systemd[1]: Starting Load Kernel Modules... Apr 18 20:26:57 orangepi3 systemd-modules-load[465]: Failed to find module 'lp' Apr 18 20:26:57 orangepi3 systemd-modules-load[465]: Failed to find module 'ppdev' Apr 18 20:26:57 orangepi3 systemd-modules-load[465]: Failed to find module 'parport_pc' Apr 18 20:26:57 orangepi3 systemd[1]: systemd-modules-load.service: Main process exited, code=exited, status=1 Apr 18 20:26:57 orangepi3 systemd[1]: systemd-modules-load.service: Failed with result 'exit-code'. Apr 18 20:26:57 orangepi3 systemd[1]: Failed to start Load Kernel Modules.
  9. guidol

    Adding Debian buster

    my first extreme try was the NanoPi A64 (from Pine64) with Buster and as Dev-version, but this experiment was too far It did boot but unstable (reboot & freezes) with different cards... So - because you did post on twitter the picture of the NanoPi R1 mainline 4.19.35 login - I used my "old" Orange Pi R1 and compiled OPi R1 Buster Dev and this seem to run MUCH better than the first try on the NanoPi A64 Now I will try a normal mainline with the NanoPi A64 for Buster - like your NanoPi R1 build but (only dev?) buster hasnt wget fro armbia-config as standard onboard?: root@orangepi:/home/guido# armbian-config /usr/sbin/armbian-config: line 26: wget: command not found Warning: Configuration cannot work properly without a working internet connection. Press CTRL C to stop to stop or any key to ignore and continue. after apt get wget it was OK also ftpd doesnt seem to be onboard anymore - used now vsftpd as replacement
  10. martinayotte

    A64 date/time clock issue

    12h36 EST, Quebec ... I've tried again Armbian_5.79.190418_Pine64_Ubuntu_bionic_dev_5.0.7.img and network is working fine for me. Did you tried not using 3.3V and using your normal PSU, or a 5V attached to GPIO 4/6 pins ? (I'm leaving too, going to supermarket ...)
  11. Petee

    A64 date/time clock issue

    Not sure where you are at Martin. Here it is 1130 C time and will be back later on this afternoon....
  12. Petee

    A64 date/time clock issue

    So did the login in stuff and ... root@pine64:~# ifconfig lo: flags=73<UP,LOOPBACK,RUNNING> mtu 65536 inet 127.0.0.1 netmask 255.0.0.0 inet6 ::1 prefixlen 128 scopeid 0x10<host> loop txqueuelen 1000 (Local Loopback) RX packets 0 bytes 0 (0.0 B) RX errors 0 dropped 0 overruns 0 frame 0 TX packets 0 bytes 0 (0.0 B) TX errors 0 dropped 0 overruns 0 carrier 0 collisions 0 root@pine64:~# [ 344.021339] dwmac-sun8i 1c30000.ethernet eth0: Could not attach to PHY [ 344.027934] dwmac-sun8i 1c30000.ethernet eth0: stmmac_open: Cannot attach to PHY (error: -19) [ 344.067108] dwmac-sun8i 1c30000.ethernet eth0: Could not attach to PHY [ 344.073698] dwmac-sun8i 1c30000.ethernet eth0: stmmac_open: Cannot attach to PHY (error: -19) [ 344.110071] dwmac-sun8i 1c30000.ethernet eth0: Could not attach to PHY [ 344.116638] dwmac-sun8i 1c30000.ethernet eth0: stmmac_open: Cannot attach to PHY (error: -19) [ 344.145095] dwmac-sun8i 1c30000.ethernet eth0: Could not attach to PHY [ 344.151667] dwmac-sun8i 1c30000.ethernet eth0: stmmac_open: Cannot attach to PHY (error: -19) Got to leave in a little bit here for about 3 hours....do you need anything more for time bean?
  13. Petee

    A64 date/time clock issue

    See an error...using a little 8 port Gb switch (unmanaged) to test... ## Flattened Device Tree blob at 4fa00000 Booting using the fdt blob at 0x4fa00000 EHCI failed to shut down host controller. EHCI failed to shut down host controller. Loading Ramdisk to 497b4000, end 49fff3a9 ... OK reserving fdt memory region: addr=4fa00000 size=6e000 Loading Device Tree to 0000000049743000, end 00000000497b3fff ... OK Starting kernel ... [ 5.275317] asoc-simple-card sound: ASoC: codec-analog@1f015c0 not registered [ 43.843643] dwmac-sun8i 1c30000.ethernet eth0: Could not attach to PHY [ 43.850256] dwmac-sun8i 1c30000.ethernet eth0: stmmac_open: Cannot attach to PHY (error: -19) [ 43.953417] dwmac-sun8i 1c30000.ethernet eth0: Could not attach to PHY [ 43.960064] dwmac-sun8i 1c30000.ethernet eth0: stmmac_open: Cannot attach to PHY (error: -19) [ 43.998929] dwmac-sun8i 1c30000.ethernet eth0: Could not attach to PHY [ 44.005578] dwmac-sun8i 1c30000.ethernet eth0: stmmac_open: Cannot attach to PHY (error: -19) [ 44.045335] dwmac-sun8i 1c30000.ethernet eth0: Could not attach to PHY [ 44.051973] dwmac-sun8i 1c30000.ethernet eth0: stmmac_open: Cannot attach to PHY (error: -19) [ 44.091948] dwmac-sun8i 1c30000.ethernet eth0: Could not attach to PHY [ 44.098542] dwmac-sun8i 1c30000.ethernet eth0: stmmac_open: Cannot attach to PHY (error: -19) Ubuntu 18.04.2 LTS pine64 ttyS0
  14. martinayotte

    Orange Pi One Plus usability ?'

    You're right for Pine64, it is just in the hurry, when doing "cat /sys/kernel/debug/mmc0/ios" with no SDCard inserted (I've a USB-HDD as rootfs of my Pine64), it shows 1 bits ... But in the case of OPiOnePlus and OPiLite2, they are really absent ... EDIT : Sorry for the false alarms, Megous is right, and OPiOnePlus and OPiLite2 are created by Armbian scripts, not from his branch.
  15. Petee

    A64 date/time clock issue

    OK I hand typed the terminal command and it is working...wow...seeing it boot... U-Boot SPL 2018.11-rc3-armbian (Apr 18 2019 - 13:09:20 +0200) DRAM: 2048 MiB Trying to boot from MMC1 NOTICE: BL3-1: Running on A64/H64 (1689) in SRAM A2 (@0x44000) NOTICE: Configuring SPC Controller NOTICE: BL3-1: v1.0(debug):c9f55c0 NOTICE: BL3-1: Built : 13:09:12, Apr 18 2019 NOTICE: DT: sun50i-a64-pine64-plus INFO: Configuring AXP PMIC NOTICE: PMIC: fixing DRAM voltage from 1.24V to 1.36V INFO: PMIC: DRAM voltage: 1.36V INFO: PMIC: setup successful NOTICE: SCPI: dummy stub handler, implementation level: 000000 INFO: BL3-1: Initializing runtime services INFO: BL3-1: Preparing for EL3 exit to normal world INFO: BL3-1: Next image address: 0x4a000000, SPSR: 0x3c9 U-Boot 2018.11-rc3-armbian (Apr 18 2019 - 13:09:20 +0200) Allwinner Technology CPU: Allwinner A64 (SUN50I) Model: Pine64+ DRAM: 2 GiB MMC: SUNXI SD/MMC: 0 Loading Environment from FAT... Unable to use mmc 0:1... In: serial Out: serial Err: serial Net: phy interface7 eth0: ethernet@1c30000 230454 bytes read in 20 ms (11 MiB/s) starting USB... USB0: USB EHCI 1.00 USB1: USB OHCI 1.0 USB2: USB EHCI 1.00 USB3: USB OHCI 1.0 scanning bus 0 for devices... 1 USB Device(s) found scanning bus 2 for devices... 1 USB Device(s) found scanning usb for storage devices... 0 Storage Device(s) found Autoboot in 1 seconds, press <Space> to stop switch to partitions #0, OK mmc0 is current device Scanning mmc 0:1... Found U-Boot script /boot/boot.scr 3042 bytes read in 13 ms (228.5 KiB/s) ## Executing script at 4fc00000 U-boot loaded from SD
  16. megi

    Orange Pi One Plus usability ?'

    @martinayotte Pine64 has bus-width set to 4 in 5.1-rc#. There are no boards that don't set it mainline: You can check with: grep -L bus-width `grep -Rl '&mmc0'`
  17. Icenowy

    Orange Pi One Plus usability ?'

    @martinayotteI think many board DO explicitly provide the bus-width. Of course, I think many people haven't equipped ECC brain like me, so there could be some boards w/o bus-width. You can submit patches for mainline for those boards. The mainline doesn't agree to add bus-width to SoC DTSI because it's for the board's designer to decide the bus-width (of course it cannot go beyond the controller's maximum). For example, some board uses a SD card slot (which is bus-width = <4>) on a eMMC controller (which can be at most bus-width = <8>), and in this case the 4 remaining data lines can even be used as GPIO.
  18. Petee

    A64 date/time clock issue

    OK...so it seems to start with the 3.3VDC but minicom is set to 115200 8N1 and I do not see anything... Getting hash when booting and it looks like baud rate is incorrect when I use: picocom -b 115200 /dev/ttyUSB0 see this: root@ICS-IBM-T540P-1:/home/pete# picocom -b 11520 0 /dev/ttyUSB0 picocom v3.1 port is : /dev/ttyUSB0 flowcontrol : none baudrate is : 11520 parity is : none databits are : 8 stopbits are : 1 escape is : C-a local echo is : no noinit is : no noreset is : no hangup is : no nolock is : no send_cmd is : sz -vv receive_cmd is : rz -vv -E imap is : omap is : emap is : crcrlf,delbs, logfile is : none initstring : none exit_after is : not set exit is : no !! Settings mismatch !! Type [C-a] [C-v] to see actual port settings Type [C-a] [C-h] to see available commands Terminal ready �(����a|�(���'���c��!7 �(��q�o ��������q��{� ���������=5-�c0�(A!��)����q�m�8� � ���� H� H�����aŜ���aE�� ��(�)�s� �(���� k��(�8=9���ku��8(�8=9��(����%���s(�9�)s �)Q �s!�)����u!)�5�(������� �� �i%�('�'#q'�i����)
  19. martinayotte

    A64 date/time clock issue

    Personally, I hate minicom, so I use "picocom -b 115200 /dev/ttyUSB0" . Plug only GND/TX/RX (don't connect 3.3V) and use you usual external PSU ...
  20. martinayotte

    Orange Pi One Plus usability ?'

    Hi @Icenowy , glad of your presence ! What we have just catch now, is that all AllWinner SoC DTSI don't default it to 4bits, and since most boards DTS don't explicitly provide the bus-width, it is defaulted to 1bits. So I bet there are many boards in this situation ... I don't know how many, so that is why my own Armbian patches is forcing it directly on DTSI ...
  21. Petee

    A64 date/time clock issue

    OK all connected. Building a new SD card with firmware. Should I utilize minicom to watch serial port...what do I set baud rate to? Will it boot up with 3.3VDC from USB TTL device or do I have to connect external power supply?
  22. Icenowy

    Orange Pi One Plus usability ?'

    Maybe it's some early patch. In early development of Pine H64 support, I missed bus-width for Pine H64. (BTW do anyone of you here have the experience of installing an ECC-capable brain?) Then it gets fixed in commit d177c8b61d6b4ef360b1c2682e4d8e3bae01738b . If it's some early patch derived from Pine H64 patch in 4.19, it might suffer from this error.
  23. Petee

    A64 date/time clock issue

    Yes different revision and same pins...which ones are the RX-TX-Ground pins? Ahh found a Pine64 PDF...with connection pins
  24. martinayotte

    A64 date/time clock issue

    You need to verify with schematics, since there are several board revisions, mine seems to be different than your :
  25. Petee

    A64 date/time clock issue

    Can I just 1 - write the new image on an SD card 2 - boot up with that image 3 - pull the card out and look at the /var/logs kernel stuff to see what is happening there when it starts (won't it write to the kernel logs with errors?) Well found the USB TTL connector....just need to know what pins to use... Reading the forum looks like the "plan" was to add JTAG pins on future builds...having a close look at my board do not see anything marked that looks like JTAG Pins...
  26. martinayotte

    Orange Pi One Plus usability ?'

    Yes ! Thanks a lot to @GeraltOfTrivia for reporting !!! This seems to have slipped in all Kernel Devs faces, even @megous or @Icenowy ... I'm just adding 3 patches to Armbian : one for H3-H5, one for A64 and one for H6 ... EDIT : I've figured out that some boards have the bus-width directly into their own DTS, like OPiPrime, but some other don't like Pine64. So, my patches done on DTSI is more general and more safe. Committed : https://github.com/armbian/build/commit/2645877aa5d5c58ac792d74f1bdc751ede55fa8d
  27. chwe

    Orange Pi One Plus usability ?'

    hmm interesting https://github.com/torvalds/linux/blob/e53f31bffe1d552f496b674cd1733658a268e177/arch/arm64/boot/dts/allwinner/sun50i-h6-orangepi.dtsi#L58-L65 seems to be not default in mainline as well as in megous: https://github.com/megous/linux/blob/e22caec8c77183c5a54d332d55d9af53283ebb68/arch/arm64/boot/dts/allwinner/sun50i-h6-orangepi.dtsi#L58-L65 going quickly through our patches doesn't show an obvious one here as well.. Just add @martinayotte
  1. Load more activity