All Activity

This stream auto-updates     

  1. Past hour
  2. Anything is possible, but this is Armbian support forum, section Allwinner A20, support for a few boards that or the list. Your problem is off topic, moving to general section. U-boot could provide something like that, yes, but you can also look towards https://github.com/open-power/petitboot direction. Its on you to do the research, make a POC, develop and maintain this feature ...
  3. Today
  4. Hello, What does that mean? Is it related to ethernet of x96-air? I couldn't find fec.c in /lib/modules/5.7.7-arm-64/kernel/drivers/net
  5. Only looks This is based on WiFi management by systemd, and in Buster this is done by NetworkManager. How to setup / use AP in this case? (I want to setup AP on different channel from "main AP" for webcams, for troughtput reasons).
  6. Putting the .ignore_changes did work fine. The original title was a little bit wrong. What I wanted to do is to build a v20.05 image and to get its kernel source code (the actual version is 5.4.57 rather than 5.7.14). The correct way to do it is Clone the master (https://github.com/armbian/build.git) Run vagrant if necessary (cd ./config/templates; vagrant up; vagrant ssh; cd armbian) Run sudo git checkout origin/v20.05 Run sudo touch .ignore_changes Run ./compile.sh BOARD=tinkerboard RELEASE=buster BRANCH=current BUILD_DESKTOP=no KERNEL_ONLY=no KERNEL_CONFIGURE=no INSTALL_HEADERS=yes BUILD_MINIMAL=yes INSTALL_KSRC=yes And the following file was created under output/images. Armbian_20.05.7_Tinkerboard_buster_current_5.4.57_minimal.img The image file includes a src archive file on /usr/src. root@tinkerboard:~# ls /usr/src/ linux-headers-5.4.57-rockchip linux-rockchip-current_5.4.57_20.05.7_config.xz linux-source-5.4.57-rockchip.tar.xz Thanks guys.
  7. Yesterday
  8. I ran a 12 hour stress run last night without issues, other than forcing me to put a better fan on the heatsink! :-) I've been running memtester for about 10 hours now without issue.
  9. I don't want to hijack this one but what i mean is use the v4l2 commands to check for the camera, or use the command: dmesg|tail after you attach the USB camera. Moderator can delete this. no problem.
  10. That's like a smart people thread. I'm not one of those guys. They kind of hijacked the thread and the guy never tried the advice buried in there somewhere. Mine is that same orange pi camera though I think.
  11. Rollback to your 5.8 and try this tip with pulse-audio (learned myself the hard way) 1. Open a session (or cmd line) 1. Open a second session (or cmd line) 2. Run your MP3 to output to jack on the first session (or cmd line) 3. While the file is playing (silently as you say) on the first session, fire alsamixer (select audio-codec) on the second session and start unmuting the controls, upping the volume, etc. At some point, eventually you get the sound output to jack. Watch the kernel for some messages.
  12. I think you should read this thread to the end, you might need v4l2 and media to grab some image if you have a new kernel. This might be true to USB camera. (i have not tried using USB camera, just a guess.)
  13. enabled eldo1 cpvdd to codec-analog, but didnt help either codec-analog@1f015c0 { compatible = "allwinner,sun50i-a64-codec-analog"; reg = < 0x1f015c0 0x04 >; allwinner,codec = < 0x15 >; status = "okay"; cpvdd-supply = < 0xa7 >; phandle = < 0x12 >; }; codec@1c22e00 was on older kernel (5.6x?): compatible = "allwinner,sun8i-a33-codec"; now the dtb/dts has for codec@1c22e00: compatible = "allwinner,sun50i-a64-codec"; if changed back to allwinner,sun8i-a33-codec the npi a64 doenst boot anymore
  14. @ldiaz have you ever tried to get an rpi CSI camera to work with the camera interface? I have tried all of the stuff I could find on the forums sudo apt-get install v4l-utils and what I could understand from this thread: but still nothing, even from just sudo mplayer tv:// Going to try a USB camera now. I just happen to have a pile of those rpi cameras. #edit couldn't get USB camera to work either, but mplayer gave me a different error, and now I have /dev/video 0 1 and 2. #edit2 later found the service in the config script, enabled it, and it got a could not remove klipper service message, but the star was there when I went to check, so it apparently worked. but camera does not
  15. Yes, the heatsink could be warm. But as I said globally always around 82°C with all cpus at 100%, (and decrease quickly when I stop). I think the processor limit ~85 °C. I tested previously another solution with a little heatsink and a fan, the temperature was also around 50°C. It is a personal choice to change in order to have no noise, because I use it as pc and as media center.
  16. I soldered these to my PowerSupply, you could as well solder it to an USB-Connector... DC Power Plug Male Connector 4.0x1.7mm Male Socket With Cord Cable,DC pigtail 4.0/1.7mm /Free shipping/10PCS US $6.64 / lot (10 pieces) https://www.aliexpress.com/item/1927392841.html I didn't test them on "how many cycles" they last, but I like the sealed barrel. To solder the barrel was always the weak spot to me.
  17. Sorry, got error, gnome-disks can't be run from mounted system drive P34A80 NVMe has SLC buffer, so result shall be similar, may be except for buffer size.
  18. You can use the multitool to dd image files directly on the device: it has a fully functional bash shell to do such kind of maintenance tasks. Nonetheless you need to do know what you are doing. Maybe you can burn the "bad" backup you made and then burn the rootfs from the image @fabiobassa provided. You need to do some juggling with the original image, but if you are able to do so you can try. Your board is a new revision of the r329q family. In alternative you may have more luck tryingr other images for boards which are older r329q revisions (v2.0, v3.0, v7.0, ...)
  19. @Hannes Worst @kevinplatt Today I did try Kernel 5.80 with debian buster on the NPi A64. HDMI-audio does work, but analog audio doesnt work complete I can start audio on analog-audio port. It show that it would play but I dont get any sound. Also when I adjusted the mixer. The anmes for AIF1 has slightly changed. Also sound_hdmi is now hdmi_sound... Both are listed by "aplay -l" root@npi-a64(192.168.6.116):/home/guido/iradio# aplay -l **** Liste der Hardware-Geräte (PLAYBACK) **** Karte 0: sun50ia64audio [sun50i-a64-audio], Gerät 0: 1c22c00.dai-sun8i-codec-aif1 sun8i-codec-aif1-0 [1c22c00.dai-sun8i-codec-aif1 sun8i-codec-aif1-0] Sub-Geräte: 0/1 Sub-Gerät #0: subdevice #0 Karte 1: sun50ia64hdmi [sun50i-a64-hdmi], Gerät 0: 1c22800.i2s-i2s-hifi i2s-hifi-0 [1c22800.i2s-i2s-hifi i2s-hifi-0] Sub-Geräte: 1/1 Sub-Gerät #0: subdevice #0 root@npi-a64(192.168.6.116):/home/guido/iradio# uname -a Linux npi-a64 5.8.0-sunxi64 #trunk SMP Mon Aug 10 15:12:34 +03 2020 aarch64 GNU/Linux System diagnosis information has been uploaded to http://ix.io/2tUF
  20. https://github.com/armbian/build/pull/2129
  21. RockPi 4 Model C support will come in the near future?
  22. Hello Guys, I bought this box 2 years ago and practicaly never used. After home cleaning found it and fought "if it run Android, it can run any Linux". I alredy have RBpi B3+ and with this TV Box now I could have a small open source data center and practice with ngnx, MariaDB, Postgree, MySQL, NodeJS, PHP, Python etc. After research I found this web, and liked Armbian idea. Issues: 1. This box looks identical to MXQ-4K, however the image did not work. When I opened it, the procesor was Allwinner H3, PCB is AK-H3-MXQ4K-V1.1 (https://wikidevi.wi-cat.ru/GUANZHI_Android_TV_BOX_H3) 2. I have many SD/microSD (brand and non brand), however only Lexmark 8Gb SD worked, even same brand but with 16Gb did not worked. 3. I try many armbian images for Allwinner H2/H3, but only worked Orange pi PC image 4. WiFi does not work, it is XR819 chip. It is not important at this stage, since LAN work 5. Not possible to copy and boot from internal NAND/eMMC, only from SD card Everything else looks to be OK (LAN, HDMI, USBs) If some body can advise how to copy armbian to internal flash, will be good, since armbian-config does not show option. I guess there is some copy block and need to use UART port. Regards,
  23. Or you could simply add this patch to the patches folder and see if it works and give feedback https://cdn.kernel.org/pub/linux/kernel/v5.x/patch-5.8.1.xz
  24. Hi, There have been a couple of posts about this over time, but I was wondeing if somebody could please provide concrete example / sample code that uses DMA to TX out the GPIO pin(s)? I want to be able to TX outwards only from my Allwinner H3 device (Orange PI PC) to 16 pins in parallel (so 16 bit DMA in parallel) from a chunk of memory in RAM. Happy with a basic example if somebody has which just blasts out one GPIO pin even.
  25. will build tomorrow 5.8.1 for my h6 orangepioneplus ( if @megi ) has updated the megous branch and see about its status. thanks @martinayotte and others that contribute
  26. I notice similar freezes on some of my OrangePI One boards: Aug 11 04:01:10 kernel: [11045.901932] asix 3-1.4.1:1.0 asix: link up, 100Mbps, full-duplex, lpa 0x41E1 Aug 11 04:05:50 kernel: [11326.227650] INFO: rcu_sched detected stalls on CPUs/tasks: Aug 11 04:05:50 kernel: [11326.227679] 3-...: (1 ticks this GP) idle=992/1/0 softirq=363926/363926 fqs=1 Aug 11 04:05:50 kernel: [11326.227681] (detected by 2, t=41234 jiffies, g=193459, c=193458, q=5) Aug 11 04:05:50 kernel: [11326.227697] Sending NMI from CPU 2 to CPUs 3: Aug 11 04:05:50 kernel: [11326.227720] NMI backtrace for cpu 3 Aug 11 04:05:50 kernel: [11326.227728] CPU: 3 PID: 0 Comm: swapper/3 Tainted: G W O 4.13.15-sunxi #1 Aug 11 04:05:50 kernel: [11326.227730] Hardware name: Allwinner sun8i Family Aug 11 04:05:50 kernel: [11326.227734] task: df4f2f40 task.stack: df51e000 Aug 11 04:05:50 kernel: [11326.227747] PC is at expire_timers+0x8e/0xe0 Aug 11 04:05:50 kernel: [11326.227752] LR is at run_timer_softirq+0x103/0x138 Aug 11 04:05:50 kernel: [11326.227755] pc : [] lr : [] psr: 000e0133 Aug 11 04:05:50 kernel: [11326.227758] sp : df51fe80 ip : df51fea8 fp : 4000001f Aug 11 04:05:50 kernel: [11326.227761] r10: 1ee84000 r9 : c0dd3430 r8 : ffffe000 Aug 11 04:05:50 kernel: [11326.227763] r7 : c0d03f6c r6 : df51fea4 r5 : dfb33440 r4 : df76f8a0 Aug 11 04:05:50 kernel: [11326.227767] r3 : 000003df r2 : df76f808 r1 : c0604f21 r0 : dfb33440 Aug 11 04:05:50 kernel: [11326.227771] Flags: nzcv IRQs on FIQs on Mode SVC_32 ISA Thumb Segment none Aug 11 04:05:50 kernel: [11326.227775] Control: 50c5387d Table: 4a5bc06a DAC: 00000051 Aug 11 04:05:50 kernel: [11326.227779] CPU: 3 PID: 0 Comm: swapper/3 Tainted: G W O 4.13.15-sunxi #1 Aug 11 04:05:50 kernel: [11326.227781] Hardware name: Allwinner sun8i Family Aug 11 04:05:50 kernel: [11326.227801] [] (unwind_backtrace) from [] (show_stack+0x11/0x14) Aug 11 04:05:50 kernel: [11326.227811] [] (show_stack) from [] (dump_stack+0x69/0x78) Aug 11 04:05:50 kernel: [11326.227822] [] (dump_stack) from [] (nmi_cpu_backtrace+0x8b/0xd4) Aug 11 04:05:50 kernel: [11326.227831] [] (nmi_cpu_backtrace) from [] (handle_IPI+0x75/0x278) Aug 11 04:05:50 kernel: [11326.227840] [] (handle_IPI) from [] (gic_handle_irq+0x67/0x68) Aug 11 04:05:50 kernel: [11326.227847] [] (gic_handle_irq) from [] (__irq_svc+0x65/0x94) Aug 11 04:05:50 kernel: [11326.227851] Exception stack(0xdf51fe30 to 0xdf51fe78) Aug 11 04:05:50 kernel: [11326.227856] fe20: dfb33440 c0604f21 df76f808 000003df Aug 11 04:05:50 kernel: [11326.227863] fe40: df76f8a0 dfb33440 df51fea4 c0d03f6c ffffe000 c0dd3430 1ee84000 4000001f Aug 25 18:28:35 kernel: [11326.227869] fe60: df51fea8 df51fe80 c0168ca7 c0168b52 000e0133 ffffffff Aug 25 18:28:35 kernel: [11326.227877] [] (__irq_svc) from [] (expire_timers+0x8e/0xe0) Aug 25 18:28:35 kernel: [11326.227887] [] (expire_timers) from [] (run_timer_softirq+0x103/0x138) Aug 25 18:28:35 kernel: [11326.227899] [] (run_timer_softirq) from [] (__do_softirq+0xb9/0x25c) Aug 25 18:28:35 kernel: [11326.227908] [] (__do_softirq) from [] (irq_exit+0x93/0xe4) Aug 25 18:28:35 kernel: [11326.227919] [] (irq_exit) from [] (__handle_domain_irq+0x49/0x84) Aug 25 18:28:35 kernel: [11326.227928] [] (__handle_domain_irq) from [] (gic_handle_irq+0x39/0x68) Aug 25 18:28:35 kernel: [11326.227934] [] (gic_handle_irq) from [] (__irq_svc+0x65/0x94) Aug 25 18:28:35 kernel: [11326.227937] Exception stack(0xdf51ff78 to 0xdf51ffc0) Aug 25 18:28:35 kernel: [11326.227940] ff60: 00000001 00000000 Aug 25 18:28:35 kernel: [11326.227947] ff80: 00000000 c01165e1 ffffe000 c0d03fcc c0d03f6c c0cb33b8 c0dd2c3f 00000000 Aug 25 18:28:35 kernel: [11326.227953] ffa0: 00000000 00000000 01400000 df51ffc8 c0107087 c0107088 400e0033 ffffffff Aug 25 18:28:35 kernel: [11326.227962] [] (__irq_svc) from [] (arch_cpu_idle+0x28/0x2c) Aug 25 18:28:35 kernel: [11326.227973] [] (arch_cpu_idle) from [] (do_idle+0x115/0x16c) Aug 25 18:28:35 kernel: [11326.227982] [] (do_idle) from [] (cpu_startup_entry+0x19/0x1c) Aug 25 18:28:35 kernel: [11326.227990] [] (cpu_startup_entry) from [<40101491>] (0x40101491) Aug 25 18:28:35 kernel: [11326.228712] rcu_sched kthread starved for 41232 jiffies! g193459 c193458 f0x0 RCU_GP_WAIT_FQS(3) ->state=0x0 Aug 25 18:28:35 kernel: [11326.228717] rcu_sched R running task 0 8 2 0x00000000 Aug 25 18:28:35 kernel: [11326.228736] [] (__schedule) from [] (schedule+0x2f/0x68) Aug 25 18:28:35 kernel: [11326.228746] [] (schedule) from [] (schedule_timeout+0x75/0x2ec) Aug 25 18:28:35 kernel: [11326.228757] [] (schedule_timeout) from [] (rcu_gp_kthread+0x425/0x690) Aug 25 18:28:35 kernel: [11326.228769] [] (rcu_gp_kthread) from [] (kthread+0xfd/0x104) Aug 25 18:28:35 kernel: [11326.228780] [] (kthread) from [] (ret_from_fork+0x11/0x20) Aug 25 18:32:47 kernel: [12265.081326] hrtimer: interrupt took 8625 ns Without a reason, it freezes, but: 1. A web server that runs on this OPI is still somehow functional for about several hours. I have a root shell via this web so I can run some commands and get results. 2. System time changed to Apr 25 1979 . This also noticable from the log above. 3. systemctl is not working like I can't get a list of units. It just does not produce any output. The kernel is 4.13.15-sunxi #1 SMP Tue Nov 21 23:35:46 MSK 2017 armv7l armv7l armv7l GNU/Linux. At the same time /var/log/syslog has other errors like that: Aug 11 04:07:56 systemd[1]: systemd-logind.service: Watchdog timeout (limit 3min)! Aug 11 04:07:56 systemd[1]: systemd-logind.service: Main process exited, code=killed, status=6/ABRT Aug 11 04:07:56 systemd[1]: systemd-logind.service: Unit entered failed state. Aug 11 04:07:56 systemd[1]: systemd-logind.service: Failed with result 'signal'. Aug 11 04:07:56 systemd[1]: systemd-logind.service: Service has no hold-off time, scheduling restart. Aug 11 04:07:56 systemd[1]: Stopped Login Service. Aug 25 18:28:35 wpa_supplicant[2055]: wlx74da38f15c54: CTRL-EVENT-SCAN-FAILED ret=-16 retry=1 Aug 25 18:28:35 systemd[1]: Starting Login Service... Aug 25 18:28:36 systemd[1]: systemd-logind.service: Main process exited, code=exited, status=1/FAILURE Aug 25 18:28:36 systemd[1]: Failed to start Login Service. Aug 25 18:28:36 systemd[1]: systemd-logind.service: Unit entered failed state. Aug 25 18:28:36 systemd[1]: systemd-logind.service: Failed with result 'exit-code'. Aug 25 18:28:36 systemd[1]: Time has been changed Aug 25 18:32:51 wpa_supplicant[2055]: message repeated 3 times: [ wlx74da38f15c54: CTRL-EVENT-SCAN-FAILED ret=-16 retry=1] Aug 25 18:33:11 systemd-udevd[286]: seq 3700 '/devices/platform/soc/1c20800.pinctrl/gpiochip0/gpio/gpio20' killed Aug 25 18:33:11 systemd-udevd[286]: seq 3700 '/devices/platform/soc/1c20800.pinctrl/gpiochip0/gpio/gpio20' is taking a long time Aug 25 18:33:11 systemd-udevd[286]: worker [5282] terminated by signal 9 (Killed) Aug 25 18:33:11 systemd-udevd[286]: worker [5282] failed while handling '/devices/platform/soc/1c20800.pinctrl/gpiochip0/gpio/gpio20' It is weird because this OrangePI was running fine for about half a year or year.
  27. I always use a short barrel adapter cable to convert to a standard sized barrel plug (5.5mm x 2.1mm). I would throw these short cables away if when they wear out. It would also save wear and tear on the board connector.
  1. Load more activity