laurentppol

  • Posts

    108
  • Joined

  • Last visited

Everything posted by laurentppol

  1. Ok, if it is possible to build only kernel (I hope it will not download anything else...) thats GREAT, and I will try :) THX.
  2. The config You provided is for building whole Armbian? I need the one for kernel only (I have already kernel sources as I needed to compile "tmon" from there). Just to put it in kernel source root, "make menuconfig" to change optical drives on, and "make; make install", - how do I update initrd?)
  3. Ok, here it is: "# CONFIG_BLK_DEV_SR is not set" Not even =M (module)... So I'll try to build my own kernel.
  4. Ok, yesterday installed fan (sold on Ali as for "Raspberry Pi 3" but it fits even inside casing), temperature (no real load) even below 40*C. (@ 26*C ambient). Will look that is to be going on. "1 liner" to log temperature@date-time launched, so there will be possibility to make a graph of this.
  5. root@orangepi3:/var/motion# armbianmonitor -u System diagnosis information will now be uploaded to gzip: /var/log/armbian-hardware-monitor.log.1.gz: No such file or directory http://ix.io/2uld Please post the URL in the forum where you've been asked for. Here it is. Don't know why there is an error.
  6. I am trying to connect an SATA -> USB DVD-R drive to OPi3, but it fails, K3b complains about "no drive". Here is syslog: Aug 15 22:12:31 orangepi3 kernel: [34203.588120] usb 3-1.1: new high-speed USB device number 8 using xhci-hcd Aug 15 22:12:31 orangepi3 kernel: [34203.712687] usb 3-1.1: New USB device found, idVendor=13fd, idProduct=084 0, bcdDevice= 1.14 Aug 15 22:12:31 orangepi3 kernel: [34203.712695] usb 3-1.1: New USB device strings: Mfr=1, Product=2, SerialNu mber=3 Aug 15 22:12:31 orangepi3 kernel: [34203.712698] usb 3-1.1: Product: External Aug 15 22:12:31 orangepi3 kernel: [34203.712701] usb 3-1.1: Manufacturer: Generic Aug 15 22:12:31 orangepi3 kernel: [34203.712704] usb 3-1.1: SerialNumber: 333230383730332036363332 Aug 15 22:12:31 orangepi3 kernel: [34203.713441] usb-storage 3-1.1:1.0: USB Mass Storage device detected Aug 15 22:12:31 orangepi3 kernel: [34203.715594] scsi host0: usb-storage 3-1.1:1.0 Aug 15 22:12:31 orangepi3 mtp-probe: checking bus 3, device 8: "/sys/devices/platform/soc/5200000.dwc3/xhci-hc d.3.auto/usb3/3-1/3-1.1" Aug 15 22:12:31 orangepi3 mtp-probe: bus: 3, device: 8 was not an MTP device Aug 15 22:12:31 orangepi3 mtp-probe: checking bus 3, device 8: "/sys/devices/platform/soc/5200000.dwc3/xhci-hc d.3.auto/usb3/3-1/3-1.1" Aug 15 22:12:31 orangepi3 mtp-probe: bus: 3, device: 8 was not an MTP device Aug 15 22:12:32 orangepi3 kernel: [34204.737920] scsi 0:0:0:0: CD-ROM Slimtype DVD A DS8A9SH EAA 2 PQ: 0 ANSI: 0 Aug 15 22:12:32 orangepi3 kernel: [34204.738292] scsi 0:0:0:0: Attached scsi generic sg1 type 5 there is NO /dev/sr0 after plugging drive. At the same time SATA->USB HDD works w/o problem. What am I missing? What should I do? I want to record my motion recordings w/o need to transfer them to laptop.
  7. Ok, have to respond to myself :-( - I CAN create an AP using nm-connection-editor, - CAN see it in systray after installing "nm-tray", - CAN connect to new network (after restarting NetworkManager), - can't get DHCP address from this (on laptop), - IP is in 10.42.x.x range, - manually config laptop WiFi IP gives at least PING response. What I want: - make dhcp availavble on new AP, - change IP to 192.168.15.x - if channels on WiFi (AP / STA) are NOT linked together, set up an WiFi client too, but priority is AP on channel OTHER that I use for "normal" network (I suppose congestion with WiFi webcam). What should I do?
  8. OK, here it is: root@orangepi3:/var/motion# armbianmonitor -u System diagnosis information will now be uploaded to gzip: /var/log/armbian-hardware-monitor.log.1.gz: No such file or directory http://ix.io/2u7Y Please post the URL in the forum where you've been asked for.
  9. Looks it is NOT overheating issue: System load: 1.82 0.42 0.14 Up time: 0 min Memory usage: 21 % of 966MB IP: 192.168.1.100 192.168.2.100 192.168.1.101 192.168.2.101 CPU temp: 80°C Usage of /: 28% of 30G [ General system configuration (beta): armbian-config ] laurent@orangepipcplus:~$ su - Hasło: root@orangepipcplus:~# tail ~/self-ping.txt 2020-08-11T01:52+02:00 53637 2020-08-11T01:53+02:00 53637 2020-08-11T01:54+02:00 53273 2020-08-11T01:55+02:00 53515 2020-08-11T01:56+02:00 53758 root@orangepipcplus:~# head ~/self-ping.txt 2020-08-09T19:08+02:00 66715 2020-08-09T19:09+02:00 69137 2020-08-09T19:10+02:00 65020 2020-08-09T19:11+02:00 64778 2020-08-09T19:12+02:00 64293 root@orangepipcplus:~# Login is just after power off/on cycle, CPU is HOT. But this is while OpenHAB2 starting. But at then last moment it worked it had only ~53.5*C. What (how) to trace now? Replace SMPS (12V->5V 3A) powering device (& cable)? Remove case (temporairly)? Any ideas else?
  10. Ok, didn't remarked that it is a link, not a simple underline.
  11. YES, WiFi (client) works OK with NM. If I start hostapd manually from command line (default config) then AP appears but cant connect using def pass "12345678" :( When stopped it does NOT reastore original WiFi client. (wlan0 is not configured / attached to AP). Shoudl I provide (compressed) /var/log/messages from boot moment to "statble"? Or some outpout of journalctl (please advize on command syntax)?
  12. Only looks This is based on WiFi management by systemd, and in Buster this is done by NetworkManager. How to setup / use AP in this case? (I want to setup AP on different channel from "main AP" for webcams, for troughtput reasons).
  13. Most suspect is OpenHAB2 (Java), seems too heavy for OPiPC+. But looks ok on OPi3 (even together with motion).
  14. I will install a fan in the case this week (already got it from China). Then log temp/date and see if it hangs. I observed, that while hung, if I do a power cycle, temperature after boot is even 85*C. Then it (slowly) falls to 65-70*C. But I get temp about 70-75* in OPi3 in metal case, 4 heatsinks (1 "fake" -> a small metal tab on flash, but there is mPCIe connector) and fan. And it works rock-stable. I am curious, what will it be with OPi4 i plan to buy.
  15. So shouldn't some of admins change forum name? To include OPi4 chip?
  16. GREAT, thats what I may use in script :). As one of my OPiPC+ repeatedly hangs, despite heatsinks, but it is in plastic enclosure, so I may suspect overheating. Now I will add not only date/time but temperature too to a "logfile". Changed uSD card from Toshiba to Samsung (A1) same. System is not the "old upgraded one" with whitch I had problems, but a clone of working OPi. Last thing is power, but there is SMPS 5V 3A + UltraCap 1F/5.5V, but who knows, cable is short (10-15cm) but poor quality (more than 1ohm @ 1m). But a bit strange, other one, w/o heatisinks, shows temp 74950 (I guess it is miliK) but runs (for now) for 8 days w/o problem.
  17. This one: https://raspberrypi.stackexchange.com/questions/89803/access-point-as-wifi-router-repeater-optional-with-bridge/89804?newreg=e46b9f0f237d4913b4b807b2369df10c looks promising as it covers AP AND STA setup, don't know about WDS.
  18. root@orangepi3:~# sensors No sensors found! Make sure you loaded all the kernel drivers you need. Try sensors-detect to find out which these are. :(
  19. Ooops, installed but sensors-detect finds nothing. It suggests to verify if all needed kernel modules are loaded. ?
  20. Got to the readme finally. Installed linux-source, then libncurses-dev, then compiled. Works. A bit too complicated (not suitable for script use, IMO). Do You know anything better suited for scripts? Eg 1 line per temp? Or just do a grep on tmon output?
  21. Just checked: So hostapd IS there, "only" need to know how ("manually") configure it, OR enable it in menu-driven armbian-config.
  22. An for me, Armbian works, "root@orangepi3:/var/motion# uname -a Linux orangepi3 5.4.43-sunxi64 #20.05.2 SMP Tue Jun 2 17:20:17 CEST 2020 aarch64 GNU/Linux" Image: "-rw-r--r-- 1 laurent laurent 1484783616 05-22 14:58 Armbian_20.02.1_Orangepi3_buster_current_5.4.20.img" Maybe You used later (broken?) image?
  23. Martin, do You remember, how "we" divide people? - those that DO backups, - those that WILL DO backups :) So it would be better to first save what You want to clear. Regards ;p
  24. Is this "simple Makefile" project? Can be found by google?
  25. Are there somewhere "howto's" on setting hostapd config "manually"? Directly editing needed config files? I didn't say "hostapd does not work", I just said "there is NO 'menu entry' for this on OPi3 armbian-config".