Search the Community

Showing results for tags 'screen'.

  • Search By Tags

    Type tags separated by commas.
  • Search By Author

Content Type


Forums

  • Announcements
    • Announcements
  • Community/Newbie forums
    • Board does not start
    • Off-topic
    • Reviews, Tutorials, Hardware hacks
    • Help wanted
    • TV boxes
  • Hobbyists forums
    • P2P help
    • Feature Requests
  • Bug tracker - supported boards and images only
    • Allwinner A20
    • Allwinner H2 & H3
    • Allwinner A64, H5, H6 and H616
    • Armada A388, A3700
    • Amlogic S905(x), S922X
    • NXP (Freescale)
    • Rockchip 3288 & 3328
    • Rockchip 3399
    • Other supported boards
  • Development
    • Board Bring Up
    • Armbian Project Administration
    • Development
  • TV Boxes's General Chat
  • TV Boxes's Reviews/Tutorials
  • TV Boxes's FAQ
  • TV Boxes's TV Boxes running Armbian
  • TV Boxes's Rockchip CPU Boxes
  • TV Boxes's Amlogic CPU Boxes
  • TV Boxes's Allwinner CPU Boxes
  • Android fanboys's Forums
  • Gaming on ARM's Reviews
  • Gaming on ARM's Issues
  • Kobol Forum's Helios4
  • Kobol Forum's Helios64

Find results in...

Find results that contain...


Date Created

  • Start

    End


Last Updated

  • Start

    End


Filter by number of...

Joined

  • Start

    End


Group


Matrix


Mastodon


IRC


Website URL


XMPP


Skype


Github


Location


Interests

Found 1 result

  1. Hi there, I have a little problem with my i2c-screen on the Helios4. It was setup according to the Kobol-Wiki and was working right from the start. However after running for some time (in this example it took around 6 hours) the screen is black and empty. Once I SSH back into the helios and restart the systemd sys-oled.service, it works again for some time... "journalctl -u sys-oled.service" gives the following: Sep 13 10:18:38 helios4 systemd[1]: Started System Starting on OLED Display. Sep 13 16:46:01 helios4 python3[23009]: Traceback (most recent call last): Sep 13 16:46:01 helios4 python3[23009]: File "/usr/local/bin/sys-oled", line 158, in <module> Sep 13 16:46:01 helios4 python3[23009]: main() Sep 13 16:46:01 helios4 python3[23009]: File "/usr/local/bin/sys-oled", line 148, in main Sep 13 16:46:01 helios4 python3[23009]: display_info(device) Sep 13 16:46:01 helios4 python3[23009]: File "/usr/local/bin/sys-oled", line 130, in display_info Sep 13 16:46:01 helios4 python3[23009]: draw.text((0, 27), network(net_name), font=font, fill="white") Sep 13 16:46:01 helios4 python3[23009]: File "/usr/local/lib/python3.7/dist-packages/luma/core/render.py", line 43, in __exit__ Sep 13 16:46:01 helios4 python3[23009]: self.device.display(self.image) Sep 13 16:46:01 helios4 python3[23009]: File "/usr/local/lib/python3.7/dist-packages/luma/oled/device/__init__.py", line 114, in display Sep 13 16:46:01 helios4 python3[23009]: self.command(set_page_address, 0x02, 0x10) Sep 13 16:46:01 helios4 python3[23009]: File "/usr/local/lib/python3.7/dist-packages/luma/core/device.py", line 48, in command Sep 13 16:46:01 helios4 python3[23009]: self._serial_interface.command(*cmd) Sep 13 16:46:01 helios4 python3[23009]: File "/usr/local/lib/python3.7/dist-packages/luma/core/interface/serial.py", line 91, in command Sep 13 16:46:01 helios4 python3[23009]: list(cmd)) Sep 13 16:46:01 helios4 python3[23009]: File "/usr/local/lib/python3.7/dist-packages/smbus2/smbus2.py", line 643, in write_i2c_block_data Sep 13 16:46:01 helios4 python3[23009]: ioctl(self.fd, I2C_SMBUS, msg) Sep 13 16:46:01 helios4 python3[23009]: TimeoutError: [Errno 110] Connection timed out Sep 13 16:46:01 helios4 systemd[1]: sys-oled.service: Main process exited, code=exited, status=1/FAILURE Sep 13 16:46:01 helios4 systemd[1]: sys-oled.service: Failed with result 'exit-code'. Any hint / idea is highly appreciated.