1 1
Baos

cubox will not boot

Recommended Posts

Maybe I missed something, it's been a few weeks since I needed to install an image.  cubox with hdmi does not boot.  There is no serial port, so I can not even try to figure it out.  Also it never requests an ip address from the router.  Tried with trusty legacy and vanilla.  Used the link specifically labeled cubox-i  http://www.armbian.com/cubox-i/ 

Share this post


Link to post
Share on other sites

You don't get anything at boot? Stock u-boot, which we use, prompts Solidrun logo. If you got nothing, than this means uboot is not loaded. We are doing major images rebuild very soon and I'll double check if problem is on our side.

 

btw. my Cubox has serial port - via micro usb. Isn't this default on all?

Share this post


Link to post
Share on other sites

I'm also having trouble with the latest image on my Cubox-i4pro. My

Cubox is booting, but it can't output 1920x1080 on HDMI on my 1080p

display. I can adjust the bootcmd to output 1366x768. This works OK.

 

The network and wifi come up just fine. The display also works

perfectly fine on another computer.

 

Anyone else having similar issues?

Share this post


Link to post
Share on other sites

You don't get anything at boot? Stock u-boot, which we use, prompts Solidrun logo. If you got nothing, than this means uboot is not loaded. We are doing major images rebuild very soon and I'll double check if problem is on our side.

 

btw. my Cubox has serial port - via micro usb. Isn't this default on all?

This is a first gen cubox, half did not have a serial port. I would need a pinout to connect to what might be a serial port.  I could not find an archive image from months/years ago to try. 

And yes, nothing at all, no hdmi signal. 

Share this post


Link to post
Share on other sites

Discovered it already had a serial device built-in.  What a nifty device. 

 

elcome to minicom 2.7

OPTIONS: I18n                                                                
Compiled on Feb  7 2016, 13:37:27.                                           
Port /dev/ttyUSB1, 21:04:50                                                  
                                                                             
Press CTRL-A Z for help on special keys                                      
                                                                             
T T CuBox                                                                    
 ** LOADER **                                                                
                                                                             
                                                                             
U-Boot 2009.08 (Sep 20 2012 - 02:30:22) Marvell version: 5.4.4 NQ SR1        
                                        
BootROM:                                
       Version on chip: 2.33            
       Status: OK                       
       Retries #: 0                     
Board: CuBox                            
SoC:   88AP510 (A1)
CPU:   Marvell Sheeva (Rev 5)
       CPU @ 800Mhz, L2 @ 400Mhz
       DDR3 @ 400Mhz, TClock @ 166Mhz                                           
PEX 0: interface detected no Link.                                              
PEX 1: interface detected no Link.                                              
DRAM:   1 GB                                                                    
       CS 0: base 0x00000000 size 512 MB                                        
       CS 1: base 0x20000000 size 512 MB                                        
       Addresses 60M - 0M are saved for the U-Boot usage.                       
SF: Detected M25P32 with page size 64 kB, total  4 MB                           
                                                                                
Streaming disabled                                                              
L2 Cache Prefetch disabled                                                      
L2 Cache ECC disabled                                                           
Modifying CPU/CORE/DDR power rails to 1.0(-2.5%) / 1.0(-5%) / 1.5(-5%)          
USB 0: Host Mode                                                                
USB 1: Host Mode                                                                
Setting VPU power OFF.                                                          
Setting GPU power ON.                                                           
MMC:   MV_SDHCI: 0, MV_SDHCI: 1                                                 
Net:   egiga0 [PRIME]                                                           
Hit any key to stop autoboot:  0                                                
===> Executing ext4load usb 0:1 0x02000000 /boot.scr                            
(Re)start USB...                                                                
USB:   Register 10011 NbrPorts 1                                                
USB EHCI 1.00                                                                   
scanning bus for devices... 2 USB Device(s) found                               
Waiting for storage device(s) to settle before scanning...                      
       scanning bus for storage devices... 0 Storage Device(s) found            
** Bad partition 1 **                                                           
===> Executing ext4load usb 1:1 0x02000000 /boot.scr                            
** Bad partition 1 **                                                           
===> Executing fatload usb 0:1 0x02000000 /boot.scr                             
** Can't read from device 0 **                                                  
                                                                                
** Unable to use usb 0:1 for fatload **                                         
===> Executing fatload usb 1:1 0x02000000 /boot.scr                             
** Can't read from device 1 **                                                  
                                                                                
** Unable to use usb 1:1 for fatload **                                         
===> Executing ext4load usb 0:1 0x02000000 /boot/boot.scr                       
** Bad partition 1 **                                                           
===> Executing ext4load usb 1:1 0x02000000 /boot/boot.scr                       
** Bad partition 1 **                                                           
===> Executing fatload usb 0:1 0x02000000 /boot/boot.scr                        
** Can't read from device 0 **                                                  
                                                                                
** Unable to use usb 0:1 for fatload **                                         
===> Executing fatload usb 1:1 0x02000000 /boot/boot.scr                        
** Can't read from device 1 **                                                  
                                                                                
** Unable to use usb 1:1 for fatload **                                         
===> Executing ext4load usb 0:2 0x02000000 /boot.scr                            
** Bad partition 2 **                                                           
===> Executing ext4load usb 1:2 0x02000000 /boot.scr                            
** Bad partition 2 **                                                           
===> Executing fatload usb 0:2 0x02000000 /boot.scr                             
** Can't read from device 0 **                                                  
                                                                                
** Unable to use usb 0:2 for fatload **                                         
===> Executing fatload usb 1:2 0x02000000 /boot.scr                             
** Can't read from device 1 **                                                  
                                                                                
** Unable to use usb 1:2 for fatload **                                         
===> Executing ext4load usb 0:2 0x02000000 /boot/boot.scr                       
** Bad partition 2 **                                                           
===> Executing ext4load usb 1:2 0x02000000 /boot/boot.scr                       
** Bad partition 2 **                                                           
===> Executing fatload usb 0:2 0x02000000 /boot/boot.scr                        
** Can't read from device 0 **                                                  
                                                                                
** Unable to use usb 0:2 for fatload **                                         
===> Executing fatload usb 1:2 0x02000000 /boot/boot.scr                        
** Can't read from device 1 **                                                  
                                                                                
** Unable to use usb 1:2 for fatload **                                         
===> Executing ext4load mmc 0:1 0x02000000 /boot.scr                            
Device: MV_SDHCI                                                                
Manufacturer ID: 3                                                              
OEM: 5344                                                                       
Name: SL32G                                                                     
Tran Speed: 25000000                                                            
Rd Block Len: 512                                                               
SD version 2.0                                                                  
High Capacity: Yes                                                              
Capacity: 31914983424                                                           
Bus Width: 4-bit                                                                
Loading file "/boot.scr" from mmc device 0:1 mmcda1                             
** File not found /boot.scr                                                     
===> Executing fatload mmc 0:1 0x02000000 /boot.scr                             
reading /boot.scr                                                               
                                                                                
** Unable to read "/boot.scr" from mmc 0:1 **                                   
===> Executing ext4load mmc 0:1 0x02000000 /boot/boot.scr                       
Loading file "/boot/boot.scr" from mmc device 0:1 mmcda1                        
747 bytes read                                                                  
## Executing script at 02000000                                                 
## Error: "autodetectfdt" not defined                                           
** No boot file defined **                                                      
usage: fatload <interface> <dev[:part]> <addr> <filename> [bytes]               
** No boot file defined **                                                      
Loading file "/boot/zImage" from mmc device 0:1 (mmcda1)                        
** File not found /boot/zImage                                                  
reading zImage                                                                  
                                                                                
** Unable to read "zImage" from mmc 0:1 **                                      
Loading file "zImage" from mmc device 0:1 mmcda1                                
** File not found zImage                                                        
Unknown command 'bootz' - try 'help'                                            
===> Executing fatload mmc 0:1 0x02000000 /boot/boot.scr                        
reading /boot/boot.scr                                                          
                                                                                
** Unable to read "/boot/boot.scr" from mmc 0:1 **                              
===> Executing ext4load mmc 0:2 0x02000000 /boot.scr                            
** Bad partition 2 **                                                           
===> Executing fatload mmc 0:2 0x02000000 /boot.scr                             
** Partition 2 not valid on device 0 **                                         
                                                                                
** Unable to use mmc 0:2 for fatload **                                         
===> Executing ext4load mmc 0:2 0x02000000 /boot/boot.scr                       
** Bad partition 2 **                                                           
===> Executing fatload mmc 0:2 0x02000000 /boot/boot.scr                        
** Partition 2 not valid on device 0 **                                         
                                                                                
** Unable to use mmc 0:2 for fatload **                                         
===> Executing ext4load ide 0:1 0x02000000 /boot.scr                            
                                                                                
Reset IDE:                                                                      
Marvell Serial ATA Adapter                                                      
Integrated Sata device found                                                    
                                                                                
** Bad partition 1 **                                                           
===> Executing fatload ide 0:1 0x02000000 /boot.scr                             
Error No HD connection                                                          
** Can't read from device 0 **                                                  
                                                                                
** Unable to use ide 0:1 for fatload **                                         
===> Executing ext4load ide 0:1 0x02000000 /boot/boot.scr                       
** Bad partition 1 **                                                           
===> Executing fatload ide 0:1 0x02000000 /boot/boot.scr                        
Error No HD connection                                                          
** Can't read from device 0 **                                                  
                                                                                
** Unable to use ide 0:1 for fatload **                                         
===> Executing ext4load ide 0:2 0x02000000 /boot.scr                            
** Bad partition 2 **                                                           
===> Executing fatload ide 0:2 0x02000000 /boot.scr                             
Error No HD connection                                                          
** Can't read from device 0 **                                                  
                                                                                
** Unable to use ide 0:2 for fatload **                                         
===> Executing ext4load ide 0:2 0x02000000 /boot/boot.scr                       
** Bad partition 2 **                                                           
===> Executing fatload ide 0:2 0x02000000 /boot/boot.scr                        
Error No HD connection                                                          
** Can't read from device 0 **                                                  
                                                                                
** Unable to use ide 0:2 for fatload **                                         
Using egiga0 device                                                             
TFTP from server 192.168.15.100; our IP address is 192.168.15.223               
Filename 'boot.scr'.                                                            
Load address: 0x2000000                                                         
Loading: T T T T T T T T T T                                                    
Retry count exceeded; starting again                                            
Using egiga0 device                                                             
TFTP from server 192.168.15.100; our IP address is 192.168.15.223               
Filename 'boot.scr'.                                                            
Load address: 0x2000000                                                         
Loading: T T T T T
 

Share this post


Link to post
Share on other sites

Ahaa, you are using old 1st generation Marvel based Cubox. This won't work, sorry ... we cover only Freescale imx6 based models. I don't have any of those boards. Perhaps you could try to build mainline uboot with kernel 4.4+ for this? No idea if it's supported.

Share this post


Link to post
Share on other sites

For anyone who searches this thread.   Here is the most up to date bootable image I could find.
uname -a                                                                                 
Linux alarm 3.5.7-14-ARCH #1 PREEMPT Mon Jun 30 13:06:45 MDT 2014 armv7l GNU/Linux   
https://archlinuxarm.org/about/downloads

 

Here is the only ubuntu I could find.  I would not recommend as it is no longer supported.

https://www.solid-run.com/download/pub/solidrun/cubox/distros/ubuntu/cubox-ubuntu-core-12.10-core-armhf-r1.tar.xz

Share this post


Link to post
Share on other sites
On 23.4.2016 at 9:34 PM, Baos said:

For anyone who searches this thread.   Here is the most up to date bootable image I could find.
uname -a                                                                                 
Linux alarm 3.5.7-14-ARCH #1 PREEMPT Mon Jun 30 13:06:45 MDT 2014 armv7l GNU/Linux   
https://archlinuxarm.org/about/downloads

digging out this old thread  for anyone who will use the frist generation CuBox (Armada 510 CPU)-  like I found my today in a old box :)

Here is something newer than the 3.5.7 above:

https://docs.kali.org/kali-on-arm/install-kali-arm-on-a-cubox

https://images.offensive-security.com/arm-images/kali-2017.3-cubox.img.xz

Linux kali 3.6.9 #1 PREEMPT Wed Nov 15 13:40:13 CST 2017 armv7l GNU/Linux

 

or GeexBox (Kodi 16.1 compiled in Dec 2017) for CuBox:
http://download.geexbox.org/snapshots/geexbox-kodi-armada5xx-cubox/
http://download.geexbox.org/snapshots/geexbox-kodi-armada5xx-cubox/20171202/binaries.cubox/geexbox-devel-20171202-r8599994.cubox.img.xz

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
1 1