0
Android3000

Disable Autologon in GUI for RDP Access

Recommended Posts

Hi,

 

Following advice regarding the Ubunto 18.04 issue where RDP throws you back to the login window if an account is already logged into the console, I'd like to disable autologon to the GUI on my Armbian_5.75_Orangepilite_Ubuntu_bionic_next_4.19.20 installation.  I've looked up a couple of similar questions on this issue on the forum already but I think the others describe disabling the GUI altogether, which I don't want to do.  Is it just a case of setting the variable NODM_USER in /etc/default/nodm to equal nothing or 0 or something else?

 

Thanks!

Share this post


Link to post
Share on other sites

Hi,

 

is anyone able to help on my question above - I can't imagine it's that difficult for an experienced Linux person. 

 

I found advice regarding the contents of the nodm file in  https://forum.armbian.com/topic/5372-activate-auto-login-on-boot-for-nightly-build/ but I don't seem to have the file in /etc/default/nodm and if I do sudo find / -name nodm nothing is found.  Am I right in believe nodm is installed ans used for the autologon to the GUI in the Armbian_5.75_Orangepilite_Ubuntu_bionic_next_4.19.20 installation?

 

Thanks

Share this post


Link to post
Share on other sites
5 hours ago, Android3000 said:

Am I right in believe nodm is installed ans used for the autologon to the GUI in the Armbian_5.75_Orangepilite_Ubuntu_bionic_next_4.19.20 installation?


Desktop images come with nodm but if you install it on top of the CLI there will be lightdm ... which can have auto or manual login. This will also be in the future desktop images.

Use armbian-config way of switching or see how it is made.

Share this post


Link to post
Share on other sites

Thanks Igor.  I think I worked out that I don't appear to have nodm but that lightdm is handling the autologin.  I thin my next step is to find /usr/share/lightdm/lightdm.conf to see if i can edit this file to disable the autologin.   Alternatively, I may use X11 to control the console session rather than the using  aforementioned RDP session solution.  I tried installing TightVNC on the Opi Lite, which worked, but I still couldn't connect to the console session, only an additional session.  

Share this post


Link to post
Share on other sites

Okay, so ultimately I discovered that XFCE can be configured to auto-start x11vnc and the procedure is described here https://www.megaleecher.net/Raspberry_Pi_VNC_Setup, although the /boot/config.txt doesn't exist on my OPiLite in which comment out hdmi_force_hotplug=1.  the downside to this approach is the service doesn't automatically restart if it fails, which it seems prone to quite often.  The answer to this is I believe to follow the advice in the following link:

 

 https://tecadmin.net/setup-x11vnc-server-on-ubuntu-linuxmint/

 

Comments welcome...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0