How to disable the serial console on GPIO32


Roland G
 Share

0

Recommended Posts

Armbianmonitor:

We are looking at replacing the raspi3b+ with the tinkerboardS (rockchip 3288) in an embedded system, running armbian (bionic-4.19). Initial tests show that OS stability, board performance and form factor make the tinkerboardS a good substitute for the raspi. 

 

However, one issue we have run into is a conflict with pin 32 of the GPIO which is used by the hostboard for managing output devices. We have tried to turn off serial2 by removing the UART2 overlay and adding 'console=display' in /boot/armbianEnv.txt and also disabling & masking serial-getty@ttyS2.service but that hasn't stopped pin 32 from being chatty when connected to the hostboard.

 

Is this possible that u-boot keeps writing/reading to and from ttyS2 (pin 32/33) regardless of the set kernel parameters? If so, how do we disable that?   

 

Link to post
Share on other sites

Donate and support the project!

Afaik there is no specific documentation for something like that., but source code research can reveal you something. Peek into u-boot source, namely into arch/arm/boot/dts/"tinkerboard.dts", board configurations /configs/"tinkerboard_defconfig" and rk3288 related files ... even I would need few hours (which I don't have) since I forgot a bit how and where.

Link to post
Share on other sites

ok. so it looks like /sources/linux-mainline/linux-4.19.y/arch/arm/boot/dts/rk3288-tinker.dts sets stdout to serial2 (see below). I have changed it to serial1, then tried to recompile armbian with "compile.sh" but the dts reverts back to original during the process. How do I stop the automatic update of this file? 

 

chosen {
                stdout-path = "serial2:115200n8";
};

Link to post
Share on other sites

Guest
This topic is now closed to further replies.
 Share

0