Jump to content
  • 0

Config or disable ddrfreq throttling


prates
 Share

Question

Armbianmonitor:

Hello!

 

Is there any way to config the frequency used by the DRAM driver when throttling takes place, or even better, disable the DRAM throttling at all?

 

First of all, I have to say that that I'm pushing my Orange Pi Zero H3 board to run at very hot temperatures due to my CPU throttling settings so I can play some retro arcade games (I know I may burn it).  But it seems the DRAM driver has its own throttling settings, and it takes place reducing DRAM frequency to 132Mhz. At such DRAM frequency there is flickering at HDMI output.

May 13 18:30:31 inova-casa kernel: [15484.645810] [hotplug]: cpu(0) try to kill cpu(2)
May 13 18:30:31 inova-casa kernel: [15484.645873] [hotplug]: cpu2 is killed! .
May 13 18:30:31 inova-casa kernel: [15484.647486] [ddrfreq] DDR: 408000KHz->132000KHz start
May 13 18:30:31 inova-casa kernel: [15484.647500] [ddrfreq] current cpu is cpu0
May 13 18:30:31 inova-casa kernel: [15484.648753] [ddrfreq] elapsed: 1087us
May 13 18:30:31 inova-casa kernel: [15484.648773] [ddrfreq] DDR: 408000KHz->132000KHz ok!

Unfortunately,  manually setting the DRAM frequency don't work either. I mean, when I send the command, the frequency don't change.

sudo echo 480000 >/sys/devices/platform/sunxi-ddrfreq/devfreq/sunxi-ddrfreq/cur_freq

 

Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

I've changed the parameter ths_used to "0", now no CPU throttling and DDR frequency reduction occurs anymore. Yes, it's hot as hell.

 

I shouldn't answer my own post, by maybe someone is also interested in this

Link to comment
Share on other sites

Search Before Posting!

  • 0

Good you've found a solution. All tho I can't advice anyone doing this.


You could also try to cool the board better. Bigger heatsink, a fan. The H3 isn't that hard to tame.
Do you play those games with Armbian? May I ask what you use? RetroArch I guess?
Have fun

Link to comment
Share on other sites

  • 0
On 5/29/2019 at 6:01 PM, prates said:

 

I shouldn't answer my own post, by maybe someone is also interested in this

why not? Better for everyone interested in it..

 

Throtteling happens for a reason.. and gambling here might not be the smartest thing.. E.g.

On 5/14/2019 at 2:15 PM, prates said:

May 13 18:30:31 inova-casa kernel: [15484.645810] [hotplug]: cpu(0) try to kill cpu(2)
May 13 18:30:31 inova-casa kernel: [15484.645873] [hotplug]: cpu2 is killed! .

 

 

this happens when things get to hot.. and I'm not sure if you really want this behavior in case of performance.. :P Asides from the SoC of this board is quite near to your SD-Card and might help to slowly toast it to a corrupt level... :lol: Flash media doesn't like heat at all.. ;) 

 

Link to comment
Share on other sites

  • 0
On 5/30/2019 at 12:18 PM, NicoD said:

Do you play those games with Armbian? May I ask what you use? RetroArch I guess?

I'm using RetrOrangePi, which was built upon Armbian Jessie and is RetroArch based.

 

On 6/3/2019 at 7:00 PM, chwe said:

Throtteling happens for a reason.

Asides from the SoC of this board is quite near to your SD-Card and might help to slowly toast it to a corrupt level..

Let's say, I can tolerate some eventual crashes, and also prepared if my board burns in the future ... But now you get me concerned about the SD:P, thanks for advising...

 

Actually my initial idea was to not completely disable throttling, just the DRAM throttling, but couldn't figure out how to do it. 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...