Wicd Network Manager doesn't get IP Address


maesstrissimo
 Share

0

Recommended Posts

Good evening.

 

I've just installed Armbian in a OPI +2, in a 32 Gb card.

The OPI is connected by LAN to my router, in the same way the PC I am using to write this message is.

But "Wicd Entwork Manager" says :

 -  "not connected" after "Obtaining IP address" if using wire-default profile.

 -  "done connecting" after "setting IP address " id using a fix IP address setting profile, but in fact, there is no connection.

 

Has anybody faced something like this ? Any idea ?

 

Best regards.

 

maesstrissimo

Link to post
Share on other sites

Donate and support the project!

Hi, Igor, and thanks for your answer.

 

Concerning wifi, I have checked that if I open mi home wireless lan, OP+2 connects and gets IP address.  But using wpa2 protocol, OPI+2 and router don't understand themselves.

 

But my original question as about Ethernet. I plug the wire in the OPI+2, but it doesn't get IP address.

 

Best regards.

Link to post
Share on other sites

I made an driver update and change one wicd settings. Now it works fine, also to WPA2 AP ... but we need some real world testing to be sure.

 

https://github.com/igorpecovnik/lib/commit/303ace0b48f2f956ba70431cf27f65b990bb0be8

https://github.com/igorpecovnik/lib/commit/dec2e54b062ac9086d8bcd073508183372d3c990

But my original question as about Ethernet. I plug the wire in the OPI+2, but it doesn't get IP address

Default settings does not allow this - IP is obtained when adapter goes up @boot time or manually. You need to either use a network manager or so called Laptop-Mode:

https://wiki.debian.org/Bonding

Link to post
Share on other sites

Hi Igor.
 
First of all, thank you for your answer, and thanks for the modifications added to wicd settings as well. I hope test will be satisfying and they will be available soon.
 
Regarding my ethernet issue, OPI+2 doesn't get IP Address neither if LAN wire plugged before boot not if I demand wicd to connect to the wired network once the system launched. :unsure:
 
Best regards
 
Maesstrissimo

Link to post
Share on other sites

I actually removed wicd (and associated packages) and installed network-manager and network-manager-gnome...   Not a big fan of wicd...

 

I just keep connection entries in /etc/NetworkManager/system-connections/ for the various Networks I join...   e.g. One for a Corporate / Enterprise SSID - couldn't connect to it using wicd (file originally created on an amd64 Ubuntu 15.10 machine) - wasn't able to generate the file using either wicd or NetworkManager - but I had the file handy...  Just had to remove the MAC address (as seems to get a different MAC address on boot each time - on wlan0, OPi+ 2E).

Link to post
Share on other sites

Guest
This topic is now closed to further replies.
 Share

0