0
razum2um

NanoPi M4 success and further development

Recommended Posts

Thanks for work on armbian!

 

I've got nanopim4 recently, stable build worked like a charm out of the box (maybe w/o bluetooth)

I digged into all build scripts, tried out the dev and even got a step forward.

 

I'm actually ready to support further development with this board :)

See my reports, attempts and links here: https://gist.github.com/razum2um/8e2bfbcffdcdb3a832a4862339330867

Would be glad if @Igor , @chwe or someone else helps with the wifi question there :)

 

p.s. sorry for posting here, but I'm unable to post into `development` forum section for rk3399

Share this post


Link to post
Share on other sites

I am glad you got things working as is but we are sadly years away from providing a (commercial only) service called: solving problems on request. Actually I do not have any intention to do anything like that even there are a dozens of similar requests every day which means we would need 10-50x more people around. Not possible. All people that contribute are booked with project tasks for 300% and there are far greater chances for not doing anything at all related to this project then dealing with yet another problem.
 

6 hours ago, razum2um said:

p.s. sorry for posting here, but I'm unable to post into `development` forum section for rk3399


Starts with solving small common problems, not by requesting overloaded people to solve problems you have. Answer three(3) question to other people (contribute to general problems) that struggle and you will be able to post in development section automatically. While doing this read study this document

Share this post


Link to post
Share on other sites

I really appreciate your work and understand the current situation, thanks for such quick replies as well.

But I feel like it's an autoreply after grep for /help/, I mentioned branches and I'd like to help you, to contribute, *not* asking solving problems *on request*

 

Really, right now I can do pull request which advances nightly rockchip from 5.0 to 5.1

And this is *not* a trivial bump, since mainline kernel dts files for rockchip have been changed and the board won't boot just after bump.

My branch boots it at least.

 

Just now not doing pull request, because I'd like to push either a ready version with wifi or ensure that it's not possible.

In my previous experience with linux during several years on gentoo - I do understand the process,

but at that times I just needed and compile the proper module to get networking, now I'm a bit stuck.

 

p.s. I also *read* the rules and understand why I cannot post into development, still preferred to start a topic instead of pushing this into replies, is something wrong with that?

 

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0