0
gahabana

build for Odroid-N2 fails due to kernel build failing

Recommended Posts

hi, i have a problem not being able to build for Odroid-N2.

To isolate the issue i created new copy of git ... it fails on kernel build. all defaults.

zh@acus:~/git$ git clone https://github.com/armbian/build.git armbian
Cloning into 'armbian'...
remote: Enumerating objects: 151, done.
remote: Counting objects: 100% (151/151), done.
remote: Compressing objects: 100% (121/121), done.
remote: Total 49101 (delta 83), reused 65 (delta 30), pack-reused 48950
Receiving objects: 100% (49101/49101), 325.95 MiB | 8.33 MiB/s, done.
Resolving deltas: 100% (32873/32873), done.
Checking out files: 100% (2951/2951), done.
zh@acus:~/git$ cd armbian
zh@acus:~/git/armbian$ ./compile.sh docker BOARD=odroidn2 KERNEL_ONLY=yes KERNEL_CONFIGURE=no  BRANCH=default > ~/armbian.odroidn2-deefault-kernel-only.txt

and last few lines of the build output look like this:

 

  CC [M]  drivers/net/wireless/rtl8812au/hal/phydm/halrf/rtl8814a/halrf_8814a_ce.o
  CC [M]  drivers/net/wireless/rtl8812au/hal/phydm/rtl8814a/phydm_rtl8814a.o
  CC [M]  drivers/net/wireless/rtl8812au/hal/phydm/txbf/haltxbf8814a.o
  CC [M]  drivers/net/wireless/rtl8812au/hal/btc/halbtc8723bwifionly.o
  CC [M]  drivers/net/wireless/rtl8812au/hal/btc/halbtc8822bwifionly.o
  CC [M]  drivers/net/wireless/rtl8812au/hal/btc/halbtc8821cwifionly.o
  CC [M]  drivers/net/wireless/rtl8812au/core/rtw_mp.o
  LD [M]  drivers/net/wireless/rtl8812au/88XXau.o
  LD      drivers/net/wireless/built-in.o
  LD      drivers/net/built-in.o
  LD      drivers/built-in.o
  GEN     .version
  LD      vmlinux.o
  MODPOST vmlinux.o
  CHK     include/generated/compile.h
  UPD     include/generated/compile.h
  CC      init/version.o
  LD      init/built-in.o
  KSYM    .tmp_kallsyms1.o
  KSYM    .tmp_kallsyms2.o
  LD      vmlinux
  SORTEX  vmlinux
  SYSMAP  System.map
  OBJCOPY arch/arm64/boot/Image
  Building modules, stage 2.
  MODPOST 1431 modules
scripts/Makefile.modpost:107: recipe for target '__modpost' failed
Makefile:1329: recipe for target 'modules' failed
[ error ] ERROR in function compile_kernel [ compilation.sh:407 ]
[ error ] Kernel was not built [ @host ]
[ o.k. ] Process terminated

All other boards i can build well. -Build host is Ubuntu 18.04, i tried native (above is in docker container) but in that case download of linaro fails for some reason ... but that is not the issue in docker container.

My guess is it is very easy to reproduce. would appreciate if someone could check it out ?

 .... ] downloading using http(s) network [ gcc-linaro-aarch64-none-elf-4.8-2013.11_linux.tar.xz ]
[#5fb5ad 4.6MiB/24MiB(18%) CN:1 DL:6.3MiB ETA:3s]
[#5fb5ad 13MiB/24MiB(53%) CN:1 DL:7.7MiB ETA:1s]
[#5fb5ad 22MiB/24MiB(90%) CN:1 DL:8.3MiB]

[ error ] ERROR in function download_and_verify [ general.sh:869 ]
[ error ] verification failed

thank you !

 

Share this post


Link to post
Share on other sites

Can you provide some info from output/debug folder ... on my test KVM virtual x64 machine running Bionic it builds fine. Under Docker, native as well.

- removing Docker image?

- removing build directory and start from scratch?

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0