0
Jedi Master

Where to download old image builds

Recommended Posts

Hi,

I have been looking to download "Armbian_5.52_Olinuxino-a20_Debian_stretch_next_4.17.19.img".  Torrent that I have is not seed, it been stuck for all day. Can anyone please provide me with downloadable link or please seed the torrent?

 

Thank you

Jedi

Share this post


Link to post
Share on other sites

Those are unofficial builds that Olimex make on their own. Why do you need that particular build? Is most recent from our download section not working properly?

Share this post


Link to post
Share on other sites
8 hours ago, Igor said:

Those are unofficial builds that Olimex make on their own. Why do you need that particular build? Is most recent from our download section not working properly?

Yes, I cannot make A20-Lime2 work with latest build. I'm using mini-usb ethernet adapter and it is not being recognized. `[    4.180658] usb0-vbus: disabling`

 

I read olimex forum and found out Armbian 5.52 works fine with mini-usb ethernet adapter. Even with night build, beta packages it's not working. Also, tried dtb enable usb host, didn't work at all.

uname -a: `Linux lime2 5.1.16-sunxi #5.91.190707 SMP Mon Jul 8 00:07:38 CEST 2019 armv7l GNU/Linux`

 

Any help is appreciated.

Share this post


Link to post
Share on other sites

why do you use the mini-usb (near the HDMI port) and not a normal-size usb-port?

the mini-usb-port is a otg port

 

did you enable usb only via dtb-file or also via armbian-config -> system -> hardware?

 

you could try your mini-usb-ethernet adapter via mini2USB converter on the normal usb-port.

Share this post


Link to post
Share on other sites
2 minutes ago, guidol said:

why do you use the mini-usb (near the HDMI port) and not a normal-size usb-port?

the mini-usb-port is a otg port

 

did you enable usb only via dtb-file or also via armbian-config -> system -> hardware?

 

you could try your mini-usb-ethernet adapter via mini2USB converter on the normal usb-port.

I tried armbian-config, I options like can, i2c1 i2c2 etc but not anything related to usb.

 

I'm using mini-usb because it's DIY firewall, which is enclosed in a box, only exposing mini-usb and hdmi. That's why I'm limited here.

 

BTW 5.72 build worked fine. 

Linux olinuxino 4.19.17-sunxi #5.72.1 SMP Thu Jan 24 13:30:13 EET 2019 armv7l GNU/Linux


# Both eth0 and eth1 is shown now.

enx405d8213b89a: flags=4099<UP,BROADCAST,MULTICAST>  mtu 1500
        ether 40:5d:82:13:b8:9a  txqueuelen 1000  (Ethernet)
        RX packets 0  bytes 0 (0.0 B)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 0  bytes 0 (0.0 B)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0

eth0: flags=4163<UP,BROADCAST,RUNNING,MULTICAST>  mtu 1500
        inet 192.168.x.x  netmask 255.255.255.0  broadcast 192.168.43.255
        inet6 fe80::aeb2:1dfe:c406:cacc  prefixlen 64  scopeid 0x20<link>
        ether 30:1f:9a:d0:11:e2  txqueuelen 1000  (Ethernet)
        RX packets 88077  bytes 121325510 (115.7 MiB)
        RX errors 0  dropped 0  overruns 0  frame 0
        TX packets 12098  bytes 901542 (880.4 KiB)
        TX errors 0  dropped 0 overruns 0  carrier 0  collisions 0
        device interrupt 62  

It worked. I'm interested why it didn't work on latest build.

Jedi.

Share this post


Link to post
Share on other sites
1 hour ago, Jedi Master said:

I cannot make A20-Lime2 work with latest build


You obviously can ;) That's not a major failure - for your use case I can imagine, but in general not.
 

1 hour ago, Jedi Master said:

Even with night build, beta packages it's not working.


Since nobody knows that there is a regression in this particular function (which we don't test), it can't be fixed. Now its known ... deep investigation and fixing when possible.

Share this post


Link to post
Share on other sites

@Jedi Master

you can check with lsmod for g_serial or g_ether modules which can occupy the mini-usb port

 

g_serial is a tty-terminal via the otg-port

g_ether is a virtual ethernet-port via the otg-port

but you need a "normal" usb-port on the mini-usb

 

if you got g_serial or g_ether then you could try to rmmod the module?

but I dont know if then it would be automatically a normal usb-port or you have to insmod another

module for this purpose...

Share this post


Link to post
Share on other sites

@guidol

I see g_serial while doing lsmod.

For now it's working for me. I'm using 5.72 build.

 

The only thing that doesn't work now is reboot or shutdown -r now. It system does to shutdown state even with reboot or shutdown -r now.

 

Share this post


Link to post
Share on other sites
24 minutes ago, Jedi Master said:

The only thing that doesn't work now is reboot or shutdown -r now. It system does to shutdown state even with reboot or shutdown -r now.

 

That is why we recommend you to stay with latest build ... and try to fix the issue with otg USB. We have fixed many others in the mean time.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0