1 1
JnrJedi

OMV doesn't work

Recommended Posts

I'm getting some strange behavior with the new image when trying to enable OMV on my T4.  Its always installed no problem, but now when I try to do a clean install Im getting the below info. 

 

Although after reboot the box is checked in softy to suggest OMV has installed ok, I haven't gone far enough in configuration to see if anything isn't working.

 

Can anyone tell if Im doing something wrong?

(I also experienced similar behaviour in Buster but I had no prior working installation's to suggest its a bug or me) 

 

---------------------------------

 

Executing: /tmp/apt-key-gpghome.wBAnSaHxyZ/gpg.1.sh --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 7AA630A1EDEE7D73
gpg: key 7AA630A1EDEE7D73: public key "OpenMediaVault Plugin Developers <plugins@omv-extras.org>" imported
gpg: Total number processed: 1
gpg:               imported: 1
Now installing OMV packages. Be patient please
Selecting previously unselected package openmediavault-omvextrasorg.
(Reading database ... 48386 files and directories currently installed.)
Preparing to unpack .../tmp.5QVTzBI5h2/omv_extras.deb ...
Unpacking openmediavault-omvextrasorg (4.1.15) ...
dpkg: dependency problems prevent configuration of openmediavault-omvextrasorg:
 openmediavault-omvextrasorg depends on openmediavault (>= 4.0.4); however:
  Package openmediavault is not configured yet.

dpkg: error processing package openmediavault-omvextrasorg (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 openmediavault-omvextrasorg
/usr/share/openmediavault/scripts/helper-functions: line 20: /etc/default/openmediavault: No such file or directory
--2019-07-09 13:27:06-- https://packages.openmediavault.org/public/archive.key
Resolving packages.openmediavault.org (packages.openmediavault.org)... 178.254.11.33
Connecting to packages.openmediavault.org (packages.openmediavault.org)|178.254.11.33|:443... connected.
HTTP request sent, awaiting response... 200 OK
Length: 3134 (3.1K) [application/pgp-keys]
Saving to: '/etc/apt/trusted.gpg.d/openmediavault-archive-keyring.asc'

/etc/apt/trusted.gp 100%[===================>]   3.06K  --.-KB/s    in 0s

2019-07-09 13:27:07 (34.1 MB/s) - '/etc/apt/trusted.gpg.d/openmediavault-archive-keyring.asc' saved [3134/3134]

OK
Executing: /tmp/apt-key-gpghome.wBAnSaHxyZ/gpg.1.sh --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 7AA630A1EDEE7D73
gpg: key 7AA630A1EDEE7D73: public key "OpenMediaVault Plugin Developers <plugins@omv-extras.org>" imported
gpg: Total number processed: 1
gpg:               imported: 1
Now installing OMV packages. Be patient please
Selecting previously unselected package openmediavault-omvextrasorg.
(Reading database ... 48386 files and directories currently installed.)
Preparing to unpack .../tmp.5QVTzBI5h2/omv_extras.deb ...
Unpacking openmediavault-omvextrasorg (4.1.15) ...
dpkg: dependency problems prevent configuration of openmediavault-omvextrasorg:
 openmediavault-omvextrasorg depends on openmediavault (>= 4.0.4); however:
  Package openmediavault is not configured yet.

dpkg: error processing package openmediavault-omvextrasorg (--install):
 dependency problems - leaving unconfigured
Errors were encountered while processing:
 openmediavault-omvextrasorg
/usr/share/openmediavault/scripts/helper-functions: line 20: /etc/default/openmediavault: No such file or directory

 

Share this post


Link to post
Share on other sites

Ok will do, I just found it strange that the error occurred exactly when the image changed to 5.9.

 

Are the historical Armbian images available anywhere?

 

*I found the archive and rolled back to 5.75. OMV installed perfectly 1st time.*

 

 

Sent from my iPad using Tapatalk

 

Share this post


Link to post
Share on other sites
2 hours ago, JnrJedi said:

Are the historical Armbian images available anywhere?


They are, but almost certainly that will not help. They changed something ...

Share this post


Link to post
Share on other sites

See the bottom line of my comment. It worked perfectly


Sent from my iPad using Tapatalk

Share this post


Link to post
Share on other sites

I think I’m getting the same error. Just trying out buster on my rockpi 4b and getting errors at omv as well.

Are there many problems with softy due to buster being released ?

 

Omv error

 

Best to just wait a couple of days i guess ?

I’m getting errors that i need to reinstall OMV, but have no idea how to do that with this.

 

Update error

Share this post


Link to post
Share on other sites

Igor confirmed OMV won’t work on Buster.

However I have been able to get it all working by using the image before 5.9 from the archives.

Link can be found higher up this thread


Sent from my iPad using Tapatalk

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
1 1