0
p1x3l3d

[Mostly solved] PineA64-LTS: Unable to get Pine64 LCD screen working

Recommended Posts

Armbianmonitor:

Hi!

 

I'm using the Sopine A64 Armbian Buster image version 5.91 in combination with my PineA64-LTS SBC. First off I'd like to say that it runs great, thank you guys very much for providing this fully featured image and thereby keeping this SBC up to date! :D

 

For the last few weeks I've been trying to get the Pine 64 7" LCD screen to work with it, but so far unfortunately I haven't been able to.

 

What I've tried:

 

  • Follow instructions to get LCD working as stated on the older brother's PineA64 page: add 'pine64_lcd=on' to /boot/armbianEnv.txt, and add 'gt9xxf_ts' to /etc/modules, then reboot. No luck.
  • Read about the Allwinner Overlays and try to understand how they work. Decompile both 'sun50i-a64-pine64.dtb' and 'sun50i-a64-pine64-lts.dtb' (found in /boot/dtb/allwinner/), search for 'lcd' in both .dts files and compare. I noticed some differences in addresses but wouldn't know which of those are correct or incorrect.
  • Add the decompiled 'sun50i-a64-pine64.dts' as user-overlay through 'sudo armbian-add-overlay sun50i-a64-pine64.dts', then reboot. System still booted, but no working LCD screen.

 

and that's about how far my knowledge goes, without really just going into the realm of trying random things :)

 

Is there anyone that managed to got the aforementioned combination of hardware to work? Or anyone that could give me any pointers on what to try next? I'm very much willing to put time and effort into this, I just don't know where to start/what to try next.

 

Thanks a lot in advance for any assistance.

Share this post


Link to post
Share on other sites

Okay, so to answer my own question: thanks to psychedup74's response in the Pine64 thread in this sub-forum I found that the latest image (running kernel 4.19.x) simply does not support the LCD yet (Not yet configured correctly in device tree? I don't know precisely).

 

To get the Pine64 LCD-screen working with the PineA64-LTS simply use the legacy image running kernel 3.10.x (torrent link). The PineA64-LTS runs butter smooth on it, with working LCD screen, wifi, sound, USB ports, etc. Again, thanks heaps to the Armbian team for making this work so well! You guys rock :)

 

Of course, If anyone knows how to get the LCD screen to work on the latest image or if I can assist how to make that happen that would be awesome, but for now I'll mark this thread as 'solved'.

 

Best wishes,

Thomas

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0