0
arturito

gpio readall (wiringPiSetup: Unknown model)

Recommended Posts

hello everyone, I am new in this forum, I am from Chile nd recently bought a nanopi m4 and installed Armbian 64 bits,

here is my problem: 

my board nanopi m4 

OS: latest armbian (64-bits)

Installed following all instructions  and sequence shown in https://github.com/Pavelectric/WiringPi_M4

all steps of the installation were successful ...

but gpio readall (and other gpio functions) returns wiringPiSetup: Unknown model

beside that I have no issues with this board (currently outperform my RPI 4B) and

all my apps (32 and 64 bits) except wiringpi

any clues to solve this issue? 

greetings

Arturo

 

example:

cat /proc/cpuinfo

.....

processor    : 5
BogoMIPS    : 48.00
Features    : fp asimd evtstrm aes pmull sha1 sha2 crc32
CPU implementer    : 0x41
CPU architecture: 8
CPU variant    : 0x0
CPU part    : 0xd08
CPU revision    : 2

Serial        : 9844f9cc95eb99f8
root@nanopim4:/home/arturo/software/WiringPi_M4-master# uname -a 
Linux nanopim4 4.4.188-rk3399 #13 SMP Thu Aug 8 15:50:19 CEST 2019 aarch64 GNU/Linux
root@nanopim4:/home/arturo/software/WiringPi_M4-master# gpio readall
wiringPiSetup: Unknown model
root@nanopim4:/home/arturo/software/WiringPi_M4-master#

 

Share this post


Link to post
Share on other sites

solved, deinstalled prior packages, did it all again and it worked !

the problem was I did the first installation as sudo su and then dpkg -i wiringpi-v2.44-friendlyelec-rk3399.deb

instead of sudo dpkg -i wiringpi-v2.44-friendlyelec-rk3399.deb

so It seems this thread is over

greetings

Arturo

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0