1 1
meetyg

R1 SATA working with old Kernel 3.4.112 but with new Kernel 4.5.2

Recommended Posts

Hello,

First I would like to thank Igor for his amazing work on Armbian!

I know that the Lamobo/BPI R1 is very problematic with power and SATA, but when I installed Armbian 5.1 jessie with the legacy kernel, it seems that the SATA is working fine. But when I tried the same Armbian 5.1 with vanilla kernel it wasn't able to boot and the hard drive made knocking noises. Just to make sure, I disconnected the HD and it booted fine.

I think that this is a software problem (maybe uboot?) because as I mentioned it works with the older kernel.

I tried installing the uboot package bananapro-next as Igor adviced someone with a banana pro but it didn't help.

I'm using a good 2A power adapter and a quality cable so I guess that solves the hardware side of the problem.

 

I would really like to have the newer kernel with Docker support because I want to be able to run Docker containers.

 

Any ideas about the software side?

Thank in advance.

Share this post


Link to post
Share on other sites
Hi

I have the Routerboard with HDD, power the battery is connection.

I had problems with the normal connection.

Sorry my English

Share this post


Link to post
Share on other sites

Thank you Wolf, but as I said the problem seems to be software related, specifically with the newer kernel.

Share this post


Link to post
Share on other sites

It must be u-boot related. We had this issue in the past ... try downloading latest mainline u-boot, compile it and write to SD card. We are not using latest u-boot since there are other serious problems (perhaps already fixed) on some boards.

 

... until we don't find time and check / provide an update.

Share this post


Link to post
Share on other sites

OK... Do you have any HowTo that explains this how to compile and then load u-boot on the SD ?

I'm sorry for the ignorance, but I'm a bit of a newbie  :huh:

Share this post


Link to post
Share on other sites

Hi, I found this: http://linux-sunxi.org/Mainline_U-boot#Compile_U-Boot ,I guess this is what I needed.

Seems a bit complicated, I think I will work a bit without the SATA drive, to see if it worth the effort (Armbian is great, I'm just not sure its the best image for my needs).

If I'll get to it, I'll update here if I was successful or not.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
1 1