Jump to content

armbian-config: install bootloader to SPI flash not working


hallo1
 Share

Recommended Posts

I am using an Orange pi win plus (Allwinner A64, 2GB ram), running Armbian Bionic with Linux 5.3.9-sunxi64

 

The board has an 2MB on-board spi flash and I want to flash bootloader in it.

The spi flash can be correctly detected in the system (showing /dev/mtdblock0).

But the "install" tool in armbian-config can't install the bootloader into the flash.

When I selected "Install/Update the bootloader on SPI Flash" and confirmed the warning notice, the tool printed "OK" immidiately and there is actually nothing written to the flash.

 

After using "sudo bash -x armbian-config", I found the tool executed a command:

dd if=/usr/lib/linux-u-boot-dev-orangepiwin_19.11.3_arm64/u-boot.flash of=/dev/mtdblock0 status=noxfer

But there isn't a file named "u-boot.flash" in the directory.

Inside the directory "/usr/lib/linux-u-boot-dev-orangepiwin_19.11.3_arm64/", there are only two files named "sunxi-spl.bin" and "u-boot.itb".

 

So..

If it is a bug in armbian-config or flashing bootloader to flash is simply not supported?

If supported, Where can I find the u-boot.flash image?

 

(armbianconfig -u give me this URL: http://ix.io/237r , may be useful for debugging)

 

Link to comment
Share on other sites

Help Armbian team helping you

1 hour ago, hallo1 said:

If supported, Where can I find the u-boot.flash image?

You should do the following :

cat /usr/lib/linux-u-boot-dev-orangepiwin_19.11.3_arm64/sunxi-spl.bin > /usr/lib/linux-u-boot-dev-orangepiwin_19.11.3_arm64/u-boot-with-spl.bin
cat /usr/lib/linux-u-boot-dev-orangepiwin_19.11.3_arm64/u-boot.itb >> /usr/lib/linux-u-boot-dev-orangepiwin_19.11.3_arm64/u-boot-with-spl.bin
flashcp /usr/lib/linux-u-boot-dev-orangepiwin_19.11.3_arm64/u-boot-with-spl.bin /dev/mtd0

 

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...