Jump to content
  • 0

OPI LITE wireless device not working


jehutywong
 Share

Question

I got my lite days ago, and have tried lots of images, none of them can recognize the build-in wifi :(  Instead, a eth0 device is presented. is it the actual wlan?

 

Armbian gives me the best compatibility so far (in terms of usb support)

 

I can read the chip module is printed realtek 8189FTV, but lsmod shows me a 8189es module loaded. By google around, no luck for the FTV version driver.

 

I also played with the script.bin, but still no luck. Anyone can give me some hints.

 

Thanks.

Link to comment
Share on other sites

Recommended Posts

  • 0

enable 8189fs in /etc/modules-load.d/modules.conf

 

This has already been done in board.conf so on existing images this step has to be done by hand I would assume. Disabling eth0 is a good idea (@Igor: I'll send a PR later regarding firstrun since some things might now not work any more, can then adjust the fex file too if you want).

 

@rodolfo: Could you have a look regarding AP and monitoring mode as asked/outlined (by jernej) here: http://forum.armbian.com/index.php/topic/942-rebuild-rtl8189es-from-git-for-opi/?view=getlastpost ?

Link to comment
Share on other sites

Search Before Posting!

  • 0

@tkaiser, @igor, @jernej

 

 

AP (master) mode and monitor mode both work

 

Working tested AP mode

 

sudo nano /etc/default/hostapd
--------------------------------

DAEMON_CONF="/etc/hostapd.conf"
--------------------------------

 

sudo nano /etc/hostapd.conf
-------------------------------------------------------

ssid=xx_opilite1_xx
interface=wlan0
hw_mode=g
channel=5
driver=nl80211
logger_syslog=0
logger_syslog_level=0
wmm_enabled=1
ieee80211n=1
wpa=3
preamble=1
#wpa_psk=66eb31d2b48d19ba216f2e50c6831ee11be98e2fa3a8075e30b866f4a5ccda27
wpa_passphrase='12345678'
wpa_key_mgmt=WPA-PSK
wpa_pairwise=TKIP
rsn_pairwise=CCMP
auth_algs=1
macaddr_acl=0
noscan=1
#ht_capab=[HT40-][sHORT-GI-40][sHORT-GI-40][DSSS_CCK-40]
country_code=CH
#ieee80211d=1
--------------------------------

 

sudo nano /etc/network/interfaces
--------------------------------

allow-hotplug wlan0
   iface wlan0 inet static
        address 192.168.4.171
        netmask 255.255.255.0
        network 192.168.4.0
--------------------------------

 

 

Testing monitor mode

 

A new virtual interface needs to be created for monitor mode

 

sudo iw phy phy0 interface add wlan1 type monitor
 

sudo ifconfig wlan1 192.168.5.171
 

sudo iwlist wlan1 scan
 

( ---> list of scanned SSIDs, just to show interface is up )

 

 

 

:) enjoy

Link to comment
Share on other sites

  • 0

@igor

 

The MAC still seems to be newly created on each restart and udev-rules force a change in interface name ( wlan1 instead of wlan0 )

 

Quick and dirty workaround :

 

sudo rm /etc/udev/rules.d/70-persistent-net.rules

sudo echo # >/etc/udev/rules.d/75-persistent-net-generator.rules
 

Link to comment
Share on other sites

  • 0

Now for 8189es - is it best to use this source - with config change of course

 

You can't. Driver has some generic code but chip dependant code is only for 8189fs. AFAIK, 8189es driver, which you added today, is the latest one.

Link to comment
Share on other sites

  • 0

What an amazing team! Thank all of you so much for all the work... I did a fresh install on one of my OPi Lites and wireless is up and running in no time - and it works pretty damn good, much better than a RPi3 sitting in the exact same spot on my bench!

Link to comment
Share on other sites

  • 0

I have OPI lite wifi. I flashes with last image 5.14 and can only get wifi using no authentication method. No WEP, no WPA. I tried differents images but no luck. I tested server and desktop version with same result: can only be associated when the router has no encryption at all, i.e. open wifi. My OPI show rtl8189fs driver.

 

regards,

Link to comment
Share on other sites

  • 0

I have OPI lite wifi. I flashes with last image 5.14 and can only get wifi using no authentication method. No WEP, no WPA. I tried differents images but no luck. I tested server and desktop version with same result: can only be associated when the router has no encryption at all, i.e. open wifi. My OPI show rtl8189fs driver.

 

regards,

 

It connects to WPA for sure. I don't have any other network and it connects fine. If you are using WICD, make sure you change:

wpa_driver = none

in settings. 

 

We are working on to change network manager.

Link to comment
Share on other sites

  • 0

It connects to WPA for sure. I don't have any other network and it connects fine. If you are using WICD, make sure you change:

wpa_driver = none

in settings. 

 

We are working on to change network manager.

Thank you for your answer, also "none" did the job.

 

regards, 

Link to comment
Share on other sites

  • 0

hi. I have a similar problem

 

I have OPI lite wifi. I flashes with last image 5.14 and can only get wifi using no authentication method. No WEP, no WPA. I tried differents images but no luck. I tested server and desktop version with same result: can only be associated when the router has no encryption at all, i.e. open wifi. My OPI show rtl8189fs driver.

 

with wifi on OPI Lite. the device sees the SSID, but cannot connect to the router. by trial and error found that by substituting in the settings of Wicd WPA suplicant driwer = none working network connection wpa-psk only encryption method WPA. network connection with WPA2 encryption, or no encryption ends with the message "bad password". is [Armbian_5.14_Orangepilite_Debian_jessie_3.4.112_desktop] , string [wpa_driver = none] the config Wicd is already there.

with android image i can connect to same router (wpa2-psk) with no problem.

Link to comment
Share on other sites

  • 0

Hi All.

I confirm that hostapd master work with internal wifi of Orangepi Lite and rodolfo configuration.

Just a point of attention if you want try with 12345678 password you need to put :

wpa_passphrase=12345678

in place of

wpa_passphrase='12345678'

If not you will lose many time to undestand why it doesn't works :P

 
Link to comment
Share on other sites

  • 0

Can anyone comment on the range of an OPi Lite with the onboard wireless in Access Point mode?  Some of the small external-antenna-less RTL8188CUS chipset USB WiFi adapaters only have a 10-20 meter range for acceptable speeds.  Since the OPi Lite has the physical external antenna, has anyone done any tests on throughput at various distances on the Lite (barring excessive interferenence or excessive number of obstacles)?  

Link to comment
Share on other sites

  • 0

Hello @ll,

 

i am now trying to get this 8189ftv to work in hostapd with 150mbps brutto. Did anyone of you get this device to worj with that speed? According to my other post here in the forum i am only getting 72.2 mbps even with a patched hostapd version where the neighbor scan is disabled.

 

In this case the opi tells me that hostapd is running with 150mbps but clients are also only connecting with 72.2mbps.

 

my question to you guys also did these tests: did anyone get more speed than 72.2 mbps in brutto?

 

The range is also not really good with the standard antenna. Only getting 6mbps brutto after 2 walls indoor and 10 meters distance.

 

This belongs to the orange pi pc plus, but it is using the same 8189ftv.

 

THX

Link to comment
Share on other sites

Guest
This topic is now closed to further replies.
 Share

×
×
  • Create New...