Jump to content

CSC Armbian for RK322X TV Boxes


Recommended Posts

@Eliel Prado

Taking a look at the log, it looks to me that your board freezes exactly after 60 seconds of operativity.

it is highly suspicious, this kind of behaviour was often found when a wrong Trust OS (TEE) was in use, causing some kind of watchdog to trigger after a predetermined amount of time resetting or freezing the machine. The few garbage bytes on the serial just before rebooting were also typical about the Trust reboot thing.

What is way more interesting is that the trust in use has been widely tested with a lot of boards and seems to work fine, but as long as it is proprietary binary code we don't know what does it do.


I could provide you a special image with an opensource Trust and see if it works, but you have to wait  a week or so for that (I'm on vacation right now...)

Also it looks to me that you're using an outdated version of multitool, please try with latest version.

Link to comment
Share on other sites

Help us fund some #badass gear for our continuous integration build framework

@fukowaka You did not need to burn them on eMMC to test the mainline kernel images.

Once armbian (any version) is installed on internal eMMC, it enables full boot from sdcard and USB stick too, so it is sufficient to burn the image to test directly on sdcard and plug the sdcard in the slot.

Anyway you can increase the boot logging level changing verbosity=1 to verbosity=7 in /boot/armbianEnv.txt; this way the kernel w ill log much more informations and maybe will tell something intersting about the issue.

Also you may add cpu-stability to overlays= line in /boot/armbianEnv.txt to see if the board boots.


Also i have a question: do the mainline kernel images never boot, or they refuse to boot after you run rk322x-config?


Edited by jock
fixed armbianEnv.txt location
Link to comment
Share on other sites



I was really imagining that the problem could be the "Trust OS", because I saw on the forum that someone had a similar problem.
I would like to test your opensource version when you get back from vacation.
About multitool, the latest version I found and tested was multitool build 6c83f46 - 6 feb 2022.


Thank you very much for your attention!


Enjoy your holidays.

Link to comment
Share on other sites

2 hours ago, fukowaka said:

I´ll try another sd card, maybe is broken.

Looking at kernel dmesg I think it definitely has a problem:

Sep 07 18:56:18 rk322x-box kernel: mmcblk0: error -110 transferring data, sector 520, nr 504, cmd response 0x900, card status 0x0


Link to comment
Share on other sites

I tried another sd card. Start the boot process then reboots. I change versosity to 7 and cpu-stability. armbianEnv.txt is not in /etc/ is in /boot.

I cant found a boot log, there is no files in /var/log/journal so i got a picture. Let me now if you can read something unusual. thx



Edited by fukowaka
Link to comment
Share on other sites

I installed ARMBIAN on my TVBOX that has the RK3228A processor and SV6256P wifi.
It worked great, but after a while, the wifi connection stops responding.
If I run the command "iwconfig" it shows that it is connected.
But if I try a "ping" it doesn't work.
I also tried using a USB Wifi Adapter, and the problem continued.
If I turn off the device, using the command "ifconfig wlan0 down" and turn it on again using the command "ifconfig wlan0 up", it works normally again.
Has anyone else gone through this?
Is there any solution?

Link to comment
Share on other sites

@jock, first of all, congratulations for the work and commitment! A lot of work has already been done here (I still haven't been able to read all the content).

I have some questions, if you can help me...

I have an old box and I decided to install Armbian in it to use it with Octoprint for my 3d printer. I have faced some problems, some I managed to solve by reading here, others I didn't. If it is possible for you to clear some of the doubts that have arisen, I would appreciate it.

1. My board is an R29 with rk3228a processor. I read that there is a problem with the HDMI, I couldn't see if they already found a solution.

2. I'm installing via multitool, the problem is that, sometimes, after multitool installs the rom (I install via SSH, because HDMI doesn't work), I can't access it anymore, as if the boot process is stuck. Other times it manages to start, but randomly it crashes. What could this turn out to be?

3. Once I was able to install, but when accessing armbian-config or rk322x-config, it also crashes randomly.

4. When I go to use an apt command, I also have problems with freezing. Sorry if I'm asking something that has already been resolved, but as I mentioned, I still haven't been able to read all the pages.

5. I read on some of the pages that you didn't have R29 cards to study HDMI errors. If you still have problems installing, I'm thinking about getting a box with other hardware. If there is still interest, if I really buy another one, I can be sending this one to you.

Once again, congratulations for the beautiful work and I thank you in advance for any help that appears.

(translated by google, if there are errors, I'm sorry! hehehe)


This is my board model:


Link to comment
Share on other sites

Hello @rafaeldavid, thanks a lot, you're very kind!


About the r29 board, yes as you noticed there are issues with that board.

The HDMI problem is very well known and it is quite obscure, maybe some gpio has to be set to the right state but I wasn't able to find useful hints inspecting the device tree.

The stability issues are very new to me, but looking at the board photos I see a bit of different design for the power section than usual boards. These differences may have some stability implications, but I'm just guessing.

Another potential problem can be related with the Trust OS binary: during early development we noticed that the wront Trust binary could freeze the device after a predefined amount of time because it was triggering a sort of "sleep" mode, but the Trust (proprietary) binary now is working pretty fine for the vast majority of boards, so it would be quite strange that this is the offender.


As you read in the other posts, this R29 board seems to be one of the bad ones and unfortunately I have no sample to study, so I'm very open to receive one sample.

Recently I received a couple of rk322x boards from @Jason Duhamell and those were terribly useful to fix eMCP issues and support esp8089 wifi; having such R29 board on my desk to work with obviosuly increases a lot the chances to understand and fix those issues.


edit: in the past we have encountered R29_MXQ boards, those may be a bit different than yours but the HDMI problem looks like is the same. You may try to apply led-conf7 from rk322x-config to see if stability problems goes away, but I'm afraid it won't really chance anything.

Link to comment
Share on other sites



that looks like a MXQ box, if you actually having random locking up issue, I highly suggest changing your power supply to something more reliable like your 5V 2A smartphone usb charger. I have seen this box really have crappy power supply.

Link to comment
Share on other sites

7 hours ago, rafaeldavid said:

@jock I ended up giving up. I bought a better tv box and installed it on the first try...

I understand; the problem is that those boards have some minor changes that makes them different than established boards.

Maybe it is just a matter of tuning some little bits to get things perfectly working...


I never stress enough that if you need something more serious, proper SBCs are the way, tv boxes are just for toying around and for those people that know perfectly how to work around in case they suddenly break because of the faulty components often they mount.

Link to comment
Share on other sites

@jock hello guys, i have a mxq 4k 5g 8GB 128GB (eMMC)  with RK3228A, 28nm Quad core Cortex A7 and i want to make a server with it, can someone help me to understand the process and what image to download? i want a bullsye desktop image and i can't find it 😜


I'm so sorry guys for the disturb! 🙏

Link to comment
Share on other sites

20 hours ago, rafaeldavid said:

I can even check if I have a source with these specifications here to use, but I confess that I got discouraged with it after so many problems in a row...


yeah I can relate to that since ive been dealing with this a couple times, but after installing 20 MXQ boxes with armbian on it, I basically just see this a very common issue on this boxes and if you have some sort of box randomly crashing/hanging, I always point the fault with the power adapter that came with it, and so far, that fixed it for me all the time.


so when I buy new mxq boxes, i basically just threw that power adapter (though snip the barrel dc jack wire and repurpose it by soldering a USB A male connector) and just use reliable USB phone charger I had in the house.

Link to comment
Share on other sites

6 hours ago, Max Sterg said:

 so i must install Armbian first and then run the commants in the cmd? ... or i must download an app from the play store like a cmd app and run those commands there?


you can just burn the armbian image to SD card, and let it boot.


checking the RAM using free command, youll be looking at the mem part here (ignore the swap) and check the value of the total, this value is in megabyte, not mebibyte so that 1gig RAM is more likely to appear as <1GB unlike in x86 Computers.


checking the emmec/nand storage can be done using fdisk -l command and look for the /dev/rknand or/dev/mmcblx

Link to comment
Share on other sites

@Max Sterg


May I ask if you have any experience with Linux in general ?

Because if you cannot choose by yourself an image with xfce desktop , that Is one of the severals desktop laying around, I guess you Will experiment many other problems in this experience with armbian and you Will come back here to ask even obvious things 

Link to comment
Share on other sites

be warned guys that the nightly image have ethernet issues, you basically loose your wired network connection and flood the dmesg with rk_gmac-dwmac up 100mbit and shortly follow with rk_gmac-dwmac link down


reflashing it with older image doesnt fix it, even with the 5.15.25 images, the only solution to fix this is reflash the android image and reflash stable armbian_22.02 image.


they probably effed up something on the u-boot when i flashed the latest nightly.

Link to comment
Share on other sites

@fabiobassa Yes i have some experience with Ubuntu and Kali 😅but I never done this before, I want to drain more knowledge 🤓and learn more in Linux and i saw that the TV Box i have can be a server and i said "Why not, let's try it!", it will have only a Pi hole inside and a little web server to host my Portofolio and a Totally Custom Theme that i will make for Wordpress. 😄


I'm so sorry for the trouble guys, like i said I'm never done this before, i just need a little push 😅, if i find a problem i will seek the answer my own and ONLY if i don't find anything i will come back! I'm so sorry again!!!!😥

Edited by Max Sterg
Link to comment
Share on other sites

17 hours ago, remlei said:

be warned guys that the nightly image have ethernet issues, you basically loose your wired network connection and flood the dmesg with rk_gmac-dwmac up 100mbit and shortly follow with rk_gmac-dwmac link down


reflashing it with older image doesnt fix it, even with the 5.15.25 images, the only solution to fix this is reflash the android image and reflash stable armbian_22.02 image.


they probably effed up something on the u-boot when i flashed the latest nightly

You should at least describe the issue before alarming people this way, and moreover you should post logs to let people understand if there is an issue with the image.

I don't see logs and I don't see the filename of the image object of the problem, just a dubious procedure based upon a dubious hypothesis.


And I say it is a dubious hypothesis because what you are stating can be only an issue related to the kernel (or possibly device trees), just because u-boot and related code has been frozen months ago.

Everything is possible, and I will check soon, to me it looks very difficult that a newer minor release of the kernel could corrupt some ROM data about the ethernet that, even after reverting to a previous working image, you don't solve the problem.

Maybe you have a broken cable or a broken router?

Link to comment
Share on other sites

@Max Sterg Ok, no problems! From the previous post you let us think you were a total newbie, but yet you have some experience.

However, if you want a desktop image, you have to go with an xfce image.

Read carefully the first post for the instructions, also don't take the images from that directory you did the screenshot above, but follow the link to the community images built by armbian server.


I suggest to use a mainline kernel (either "current" 5.15 or "edge" 5.19) with xfce if you want to experience a desktop environment. The difference is that "current" kernel is more stable, "edge" kernels are development ones and may potentially break, even though I don't usually push anything that deliberately breaks things even for edge kernels.

Link to comment
Share on other sites

@jock thank you my friend, all this time i was with desktops for ubuntu or kali , I never done this before i believe i got this! ,  do you mean from the GitHub Rep? if yes i just download the xfce current 5,15 you just said! thanks if i have any questions i will tag you if you don't mind! 😁


Thanks a lot! 😅

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...