Jump to content

[SOLVED] Odroid XU4 does not boot from eMMC Card


Recommended Posts



I'm proud owner of an ODROID XU4  REV 0.1 20180912 and would like to use your latest Image.


Here are the steps I have done on my Win 10 - 1803 PC:

  1. Downloading your image file from your site
  2. Unpacking with 7zip to .img
  3. Starting Etcher Portable 1.5.63
  4. Select the .img file
  5. Connect my eMMC card (16GB) to my CardReader
  6. This card is auto-selected by Etcher as Target device
  7. Click on Flash
  8. Etcher tranfers the image to the eMMC card and then validates it.
  9. When ready i close Etcher, remove the card safely from my PC and put it onto my ODROID-XU4
  10. I connect only a LAN cable and a power cable to the ODROID XU 4.
  11. The on-board boot select switch selects eMMC as boot device
  12. The ventilator starts to run, the ethernet leds starts blinking, that’s all
  13. When I connect a Monitor via HDMI and/or a mouse, keyboard and/or external SSD -> same result
  14. No desktop ist displayed, no IP address is assigned (I have checked this on my router)


To check if I do anything wrong I exactly repeated the above steps but this time I used the standard Ubuntu image that I had downloded from the ODROID website.


With this image my ODROID-XU4 starts Ubuntu and runs without any problems.


I hope this helps to find the problem.

Thanks a lot for your support.


Board: Odroid XU3/XU4/HC1
Link to comment
Share on other sites

Help Armbian team helping you!

Hi garysn, and welcome to the forums.


If you can boot ODROID's official image, maybe PSU / SD card are not the problem.


But I will wait for someone more knowledgeable to come along.

Link to comment
Share on other sites

Because boot loader which was once flashed by Hardkernel to eMMC (and which can't be flashed with Etcher) is simply too old and only support booting from (Windows) FAT partition ... while Armbian use (proper) Linux partitions :rolleyes:


You need to do this:


Link to comment
Share on other sites

  • TRS-80 changed the title to [SOLVED] Odroid XU4 does not boot from eMMC Card
This topic is now closed to further replies.

  • Create New...