1 1
petrmaje

TVheadend missing?

Recommended Posts

Hi,

 

I am trying to install TVheadend using Debian-micro-home-server, but no success.

Armbian Wheezy with legacy kernel.

See printscreen.

 

Any idea?

 

PM

 

post-155-0-65136900-1464517315_thumb.png

Share this post


Link to post
Share on other sites
(edited)

 

Are you using latest script?

 

I just tested - working normally.

cat /etc/apt/sources.list.d/tvheadend.list 

must result in:

deb https://dl.bintray.com/tvheadend/deb wheezy release

It seems to be ok:

root@TVheadend:~# cat /etc/apt/sources.list.d/tvheadend.list
deb https://dl.bintray.com/tvheadend/deb wheezy release
root@TVheadend:~#

In the meantime I compiled tvheadend from source, but I have another issue with uploading firmware to USB dongle:

[    8.725304] dvb-usb: found a 'Leadtek WinFast DTV Dongle Gold' in warm state.
[    8.733722] dvb-usb: will pass the complete MPEG2 transport stream to the software demuxer.
[    8.744609] ERROR: 256 KiB atomic DMA coherent pool is too small!
[    8.744618] Please increase it with coherent_pool= kernel parameter!
[    8.751888] dvb-usb: Leadtek WinFast DTV Dongle Gold error while loading driver (-12)
[    8.757347] dvb_usb_af9015: probe of 1-1.2:1.0 failed with error -12
[    8.762924] usbcore: registered new interface driver dvb_usb_af9015

I am googling about it ...

 

Kernel 4.4.1-sunxi has no problem with uploading firmware ....

Edited by petrmaje

Share this post


Link to post
Share on other sites

i have the same error.tvheadend shows in :

 

cat /etc/apt/sources.list.d/tvheadend.list 

 

but fails when trying to install (with both apt-get or script) : Unable to locate package :(

Share this post


Link to post
Share on other sites

i have the same error.tvheadend shows in :

 

cat /etc/apt/sources.list.d/tvheadend.list 

 

but fails when trying to install (with both apt-get or script) : Unable to locate package :(

Try to compile it from source. It is easy with armbian, everything is preinstalled and you don't need to wait for somebody to fix it. Or, did you find another solution?

Share this post


Link to post
Share on other sites

It looks like there are problems with the new official AptRepository of tvheadend at bintray.

When I do an apt-get update I get the following error:

Error: http://dl.bintray.com jessie/release armhf Packages
  403  Forbidden [IP: 5.153.35.248 80]

I think they are working on it. Don't know when it will be fixed...

Share this post


Link to post
Share on other sites

@petrmaje

 

Hi, I had same problem today. They stopped building it for arm cpu's from some unknown reason for me.

Try download deb package manually from link bellow. Browser will complain about wrong certificate, so just add it.

https://nihil.selfhost.eu/tvheadend/nightly/

 

You can install it with command:

gdebi tvheadend*armhf.deb

 

If it will complain about missing dependency like:

Dependency is not satisfiable: libavcodec56 (>= 10:2.8.7)

You need add deb-multimedia backport repository to your system. This is output of my repository list for example:

 

cat /etc/apt/sources.list.d/multimedia.list
deb http://www.deb-multimedia.org jessie main non-free
deb http://www.deb-multimedia.org jessie-backports main

 

If you have not added deb-multimedia repo yet follow complete procedure:

(select/copy whole paragraph and paste it in your command line)

 

echo "deb http://www.deb-multimedia.org jessie main non-free

deb http://www.deb-multimedia.org jessie-backports main" > /etc/apt/sources.list.d/multimedia.list &&
apt-get update -y &&
apt-get install deb-multimedia-keyring --force-yes -y &&
apt-get update -y

Share this post


Link to post
Share on other sites

@technik007_cz

 

When I install tvheadend it abort on this message: Mutex not held at src/idnode.c:102

I don't know why, I used your current latest version: https://nihil.selfhost.eu/tvheadend/nightly/tvheadend_4.1-2236~g817f67e_armhf.deb

 

In dmesg I got this:

[  475.945058] usb 1-1: dvb_frontend_start: failed to start kthread (-4)
[ 1005.892539] rtl2832 2-0010: i2c reg read failed -11 reg 01

 somebody an idea?

Share this post


Link to post
Share on other sites

I got tvheadend installed and running with the package of the  official repo:

 

sudo apt-get install apt-transport-https
sudo apt-key adv --keyserver hkp://keyserver.ubuntu.com:80 --recv-keys 379CE192D401AB61
echo "deb https://dl.bintray.com/tvheadend/debjessie release" | sudo tee -a /etc/apt/sources.list.d/tvheadend
sudo apt-get update
sudo apt-get install tvheadend

 

No I can browse to the tvheadend server.  It discovers my r280T DVB-T usb-stick (with the mainline kernel module), but doesn't start scanning.  

 

Then I installed RTL-SDR, blacklisted the kernel module and tried again.  But now the DVB-T stick isn't recognized. If I check dmesg, the usb DVB-T stick is recognized but not initialized, something strange.

 

Or the stick is defective or my cubie A10 isn't up to the task.

 

I will try this evening on my PC running Arch with both the mainline kernel module and the rtl-sdr one.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
1 1