Armbian for Amlogic S905X3


Sergey2k
 Share

22 22

Recommended Posts

3 hours ago, TheMojoMan said:

Finally, Panfrost is working on my X96 Max + :)

 

I have used todays build (Armbian_20.06.0_Arm-64_focal_current_5.7.6_20200630.img.xz) with the meson-sm1-sei610-2.dtb (see some posts ago) and then followed the instructions of the first post here. This is essentially the same procedure that @m][sko mentions in @NicoD's guide here (which did not work with the older Armbian image). In summary, after starting the system do the following

  • sudo sh -c "echo 'PAN_MESA_DEBUG=bifrost' >> /etc/environment"
  • sudo add-apt-repository ppa:oibaf/graphics-drivers
  • sudo apt update
  • sudo apt upgrade
  • sudo apt install ubuntu-desktop -y
  • sudo reboot

And then you can try it with Gnome/Gnome on Xorg/Ubuntu or Ubuntu on wayland.

 

I will post details later when I did some more testing. Especially, I am interested if it works with Xfce.

 

Thanks to all the great people that made this possible!!! Especially to @balbes150 and Alyssa Rosenzweig and coworkers!

Sounds Great! Is there any way to upgrade from 20.05_bionic to this new image? or you have to reflash the image to the card? Thanks to the Armbian Team for this great job! :)

Edited by rna
Link to post
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

Panfrost for Bifrost GPUs (G31, G52) is a very fresh development. Therefore it is no wonder that it is still very unstable.

 

Quick test results for 'Ubuntu on Wayland':

The desktop gets blurred after a short while. Especially text output. Supertuxkart crashes, Firefox crashes and sends you back to login. The only thing I tested that did not crash was glmark2-es2-wayland. But I did not have time to get a little deeper into it, yet.

 

I tried to get Panfrost running on XFCE4 but failed. The window manager (xfwm4) seems to be the problem. I read that somewhere else where they suggested to use 'kwin_x11' instead. But I was not able to start xfce4 with kwin. Even after changing 'xfwm4' to 'kwin' in the respective .xml-file Xorg tried to start 'xfwm' and failed to do so when I activated 'glamor' and 'Panfrost' in /etc/X11/xorg.conf.d/01-armbian-default.conf. When it is set to 'none' and 'Lima' it starts the desktop.

When I tried to remove 'xfwm4' by typing 'sudo apt remove xfwm4' it was output that 'xfce4' would be removed as well ...

Link to post
Share on other sites

On 6/16/2020 at 11:23 AM, vanngocan said:

I am trying to install Armbian on Eachlink X3 Mini. I use image Armbian_20.05.6_Arm-64_bullseye_current_5.7.2_desktop_20200612.img with dtb file meson-sm1-sei610-ethfix.dtb (this is what I used for my X96 Air box).

It booted well from usb. However, ethernet does not work :(
Is there any way to fix this ethernet issue?

I plug SD card, box cannot start (blank led screen). I also tried toothpick but nothing appears. How can u boot with armbian for X3 mini????

vietnam ak?

Link to post
Share on other sites

Earlier in this thread some people were talking about editing the DTB files since some components appeared to be clashing with each other, but nobody said anything else on the topic. My box is an X96 Max+ (RTL8211F)

 

Like some other people I'm trying to run a headless server, so I don't need sound, I don't mind weird colours but I very much need gigabit ethernet and USB3.

 

@SteeMan and @balbes150 since you guys know a lot about the inner workings of these devices, is it possible to customise these DTB files to disable components to make sure only the ones we actually need work? If so, how one would go on about it?

 

Thanks in advance

Link to post
Share on other sites

21 hours ago, iSlaker said:

 

@SteeMan and @balbes150 since you guys know a lot about the inner workings of these devices, is it possible to customise these DTB files to disable components to make sure only the ones we actually need work? If so, how one would go on about it?

It is theoretically possible.  But I haven't seen this successfully done.  To undertake a task like this you need access to source code and support from the underlying device manufacturers, which generally doesn't exist.  (This is part of the reason that balbes150 doesn't support the s905x3 cpus as Amlogic does not provide support for their products under mainline kernels).

Link to post
Share on other sites

4 minutes ago, SteeMan said:

It is theoretically possible.  But I haven't seen this successfully done.  To undertake a task like this you need access to source code and support from the underlying device manufacturers, which generally doesn't exist.  (This is part of the reason that balbes150 doesn't support the s905x3 cpus as Amlogic does not provide support for their products under mainline kernels).

 

I see. Yes, it makes sense.

 

Since I've noticed that some DTBs enable certain components while others enable others, I was hoping there was a script (or someone could write it) that would load all the DTBs in a directory and let you pick individual components in the DTBs to create a new DTB. I could write such script myself if I understood the structure of these files.

 

Another option could be a "DTB Viewer" of sorts. Is there such thing?

Link to post
Share on other sites

55 minutes ago, iSlaker said:

I see. Yes, it makes sense.

 

Since I've noticed that some DTBs enable certain components while others enable others, I was hoping there was a script (or someone could write it) that would load all the DTBs in a directory and let you pick individual components in the DTBs to create a new DTB. I could write such script myself if I understood the structure of these files.

 

Another option could be a "DTB Viewer" of sorts. Is there such thing?

The dtb mechanism has support for a feature called "overlays" which is in theory designed for the use cases you are thinking about.  But the basic problem is getting all of the dtb specifics in place for a particular box and then figuring out how to make the selection process easier.  The hard part is the first part of that problem not the second.  The first step is to get working dtbs for a set of different device configurations and then finding the best method to select them.  While there are hundreds of different android tv boxes out there (even the same box based on outside markings can have many different clones/versions with different internal hardware) each requiring a different dtb to correctly map the specific hardware for each box, and only a handful of dtbs in the distribution, you have the situation we find ourselves in.

Link to post
Share on other sites

8 minutes ago, thanxx said:

Hi,
quick noob question here: why the box with 4gb ram shows only ~3,3gb under Armbian?

i have a Tanix tx5max on s905x2 and x96air on s905x3. Both of them are ~3,3gb under Armbian

Maybe PAE is missing in the kernel?

Link to post
Share on other sites

30 minutes ago, thanxx said:

i have a Tanix tx5max on s905x2 and x96air on s905x3. Both of them are ~3,3gb under Armbian

 

3.3 left? Or 3.3 in total? 
Armbian desktop uses about 600MB on arm64. 
You could try with the command

free

Or 

sudo apt install mate-system-monitor

to have a better visual insight. You open it by typing mate-system-monitor in terminal.

Link to post
Share on other sites

I update my box from X96Air_P3_20191220-2048 to X96Air_P3_20200619-2008,4G&64G,1G wired network.(Android os is 1000m wired network)

 

I use Armbian_20.08.0_Aml-64_bionic_current_5.7.0-rc7_desktop_20200531.img.xz,boot from tf. no u-boot.ext file.

 

I try this dtb files:
g12a_u212_4g.dtb, boot failure
meson-g12a-sei510.dtb, armbian boot ok,wired network failure
meson-g12a-x96-max.dtb,armbian boot ok, 100m wired network ok 
meson-g12a-x96-max-rmii.dtb,armbian boot ok,wired network failure
meson-g12a-x96-max-no-cvbs.dtb,armbian boot ok, 100m wired network ok 
meson-g12b-odroid-n2.dtb, boot failure
meson-sm1-sei610.dtb,armbian boot,ok,wired network failure

meson-sm1-sei610-2.dtb,armbian boot ok, 100m wired network ok 
meson-sm1-sei610-ethfix.dtb,armbian boot ok,wired network failure
meson-sm1-x96-max-plus.dtb, armbian  boot ok,100m wired network ok 
meson-sm1-x96-max-plus-ne.dtb,armbian boot ok,wired network failure
meson-sm1-x96-max-plus-100m.dtb, armbian boot ok, 100m wired network ok 
sm1_ac213_4g.dtb, boot failure

 

all dtb 1000m wired network failure.

 

I use: sudo ethtool –s eth0 speed 100 duplex full autoneg on.ping is ok.

if i use sudo ethtool –s eth0 speed 1000 duplex full autoneg on. 1000m wired network failure. ping is lost, but wired line is ok.

when i cp u-boot.sd to u-boot.ext, armbian boot failure. i only boot from tf or usb.

 

chenjun@X96Air_P3:~$ ethtool eth0

Settings for eth0:

        Supported ports: [ TP MII ]

        Supported link modes:   10baseT/Half 10baseT/Full

                                100baseT/Half 100baseT/Full

                                1000baseT/Full

        Supported pause frame use: Symmetric Receive-only

        Supports auto-negotiation: Yes

        Supported FEC modes: Not reported

        Advertised link modes:  10baseT/Half 10baseT/Full

                                100baseT/Half 100baseT/Full

                                1000baseT/Full

        Advertised pause frame use: Symmetric Receive-only

        Advertised auto-negotiation: Yes

        Advertised FEC modes: Not reported

        Link partner advertised link modes:  100baseT/Full

        Link partner advertised pause frame use: Symmetric

        Link partner advertised auto-negotiation: Yes

        Link partner advertised FEC modes: Not reported

        Speed: 100Mb/s

        Duplex: Full

        Port: MII

        PHYAD: 0

        Transceiver: internal

        Auto-negotiation: on

Cannot get wake-on-lan settings: Operation not permitted

        Current message level: 0x0000003f (63)

                               drv probe link timer ifdown ifup

        Link detected: yes

 

chenjun@arm-64:~$ ethtool -i eth0
driver: st_gmac
version: Jan_2016
firmware-version:
expansion-rom-version:
bus-info:
supports-statistics: yes
supports-test: no
supports-eeprom-access: no
supports-register-dump: yes
supports-priv-flags: no

 

chenjun@X96Air_P3:~$ dmesg|grep eth0
[   12.077051] meson8b-dwmac ff3f0000.ethernet eth0: PHY [0.0:00] driver [RTL8211F Gigabit Ethernet] (irq=29)
[   12.094384] meson8b-dwmac ff3f0000.ethernet eth0: No Safety Features support found
[   12.094420] meson8b-dwmac ff3f0000.ethernet eth0: PTP not supported by HW
[   12.094450] meson8b-dwmac ff3f0000.ethernet eth0: configuring for phy/rgmii link mode
[   13.700142] meson8b-dwmac ff3f0000.ethernet eth0: Link is Up - 100Mbps/Full - flow control rx/tx
[   13.700301] IPv6: ADDRCONF(NETDEV_CHANGE): eth0: link becomes ready
[   52.868317] eth0: renamed from veth97ff6f4
 

How to fix X96Air_P3_20200619-2008 work 1000m wired network in armbian.

I do not know how to fix dtb or dts files.

 

https://www.cnblogs.com/helloworldtoyou/p/5406913.html

chinese fix 1000m network.

Link to post
Share on other sites

19 hours ago, Werner said:

Maybe PAE is missing in the kernel?


Looks like it's missing

root@air:~# uname -a
Linux air 5.5.0-rc6-aml-s9xxx #rc1.037 SMP PREEMPT Wed Feb 5 17:28:41 MSK 2020 aarch64 aarch64 aarch64 GNU/Linux

root@air:~# grep --color=always -i PAE /proc/cpuinfo
root@air:~# cat /proc/cpuinfo
processor       : 0
model name      : ARMv8 Processor rev 0 (v8l)
BogoMIPS        : 48.00
Features        : fp asimd evtstrm aes pmull sha1 sha2 crc32 atomics fphp asimdhp cpuid asimdrdm lrcpc dcpop asimddp
CPU implementer : 0x41
CPU architecture: 8
CPU variant     : 0x1
CPU part        : 0xd05
CPU revision    : 0


 

18 hours ago, NicoD said:

3.3 left? Or 3.3 in total? 
Armbian desktop uses about 600MB on arm64. 
You could try with the command


free

root@air:~# free
              total        used        free      shared  buff/cache   available
Mem:        3335148      115028     3066236       24820      153884     3157688
Swap:       1048572           0     1048572

 



Updated the kernel to 5.77, the total memory is still the same
No changes in cat /proc/cpuinfo

Link to post
Share on other sites

40 minutes ago, thanxx said:

Guys, how much free RAM your system shows on 4GB devices?
thanks in advance for your input

blind@TX3X3:~$ free
              total        used        free      shared  buff/cache   available
Mem:        3684488      859436     2103944       24008      721108     2643560
Swap:       1842240           0     1842240
blind@TX3X3:~$

 

This is on a TX3 with s905x3 using meson-sm1-sei610.dtb

 

And on a H96 Max with s905x2 using meson-g12a-u200.dtb:

 

blind@H96MaxX2:~$ free
              total        used        free      shared  buff/cache   available
Mem:        3365644      216796     1203640       21244     1945208     2966404
Swap:       1682820           0     1682820
blind@H96MaxX2:~$

Link to post
Share on other sites

the legacy u-boot in those boxes is usually allocating away quite a bit of memory which you'll have to live with or your can try chainloading a mainline u-boot (which is what the u-boot.ext display hack is doing - on boxes where this is used there should be more memory available on average i guess)

 

best wishes - hexdump

Link to post
Share on other sites

On 6/13/2020 at 1:13 PM, thaidt said:

I bought X96Air S905X3 but only 2 Gb Ram and Ethernet is 100Mbs speed. Successful installed Armbian bionic with meson-sm1-sei610.dtb and also installed AdGuardHome to it. LAN & Wifi works well. No problem with color & resolution except Bluetooth does not working.

There is a small issue that I can not boot from SD card (Message: “Error -84 whilst initialising SD card” while booting). So I have to boot from USB.

Can anyone advise me how to boot from SD card? Or do I need to buy a new SD card?

(The function of card slot is normal in Android mode)

Thank you.

same with X3 Mini (4gb). armbian only see 1700mb of ram :( (Armbian_20.07_Arm-64_focal_current_5.7.8.img)

Edited by heroes1412
Link to post
Share on other sites

3 hours ago, Siraj said:

I have a board X96 max+ (s905x3). Am also working trying to run Ethernet at 1000Mbps but no success. My board can run "meson-sm1-sei610-2.dtb" file and "meson-sm1-sei610-ethfix.dtb" files. By looking into the source (dts) files of both of them i found that few values are different but both are working.  Moreover,  i found different value of the eg in both the .dts files 

compatible = "amlogic,meson-axg-dwmac\0snps,dwmac-3.70a\0snps,dwmac

whereas while looking into the andriod tvbox i found different values 

compatible = "amlogic, g12a-eth-dwmacsnps,dwmac" 

 

Even i found different values are changed

image.png

different compatibility of ethernet.PNG

 

After fighting with the TVbox am able to extract the .dtb file convert it in .dts file

i96.dts i96.dtb

Link to post
Share on other sites

1 hour ago, Martin Hyška said:

How can i install aarch64 on X96air? This tutorial work, but if grab another img, file stucture is different and it wont boot.

You need to provide more details on what you are trying.  What version are you trying to install (and from where did you download it).  What are the steps you are attempting to install on your box?

Link to post
Share on other sites

18 hours ago, Siraj said:

 

After fighting with the TVbox am able to extract the .dtb file convert it in .dts file

i96.dts 97.34 kB · 1 download i96.dtb 88 kB · 1 download

Using the extracted dtb file from andriod, i was unable to boot the tvbox (a green screen appears and remains there). Even i converted the .dtb file into .dts and than back to .dtb (because someone is saying that .dtb file is kernel dependent). Still same green screen. I know @balbes150  stop supporting this tvbox due to lack of support from amlogic. But still it the cheapest tvbox and if we defined a methodology of correctly extracting the .dtb file and do some changes than it can be documented and used for others (If only the .dtb file that does matter here). Or if we know the methodology of adding support of any tvbox (if the .dtb file is the only we need to change) than i can put an effort to document it all.

Link to post
Share on other sites

17 hours ago, Martin Hyška said:

i wanted to try some img with archlinux distro, but there is no in download

Armbian is Debian based, and since arch isn't it isn't a supported distribution.  But since this is open source, you are free to take the source code and add arch support for your needs, and contribute back to the community in that way.

Link to post
Share on other sites

  • Werner locked this topic
Guest
This topic is now closed to further replies.
 Share

22 22