1 1
dgm78

Run armhf on arm64 - Libhybris

Recommended Posts

Hi!

 

I installed libhybris on my armbian 19.11.5 (kernel 5.5.0) to use mali user space drivers from android. After done, I have verified that my system can not run armhf, so not calling libhybris libEGL.so. I already ran apt --add-architecture armhf; update; install libc6:armhf, but still can not run 32-bit armhf, why?

Share this post


Link to post
Share on other sites

I am very confused. 

 

Did you run "sudo apt --add-architecture armhf" and not just "apt --add-architecture"? 

 

Also it's libc6 not livc6. 

 

try "sudo apt-get install libhybris:armhf"

 

I don't have the specific experience with libhybris but i do have multiarch working on my H5

Share this post


Link to post
Share on other sites
15 hours ago, ej0rge said:

I am very confused. 

 

Did you run "sudo apt --add-architecture armhf" and not just "apt --add-architecture"? 

 

Also it's libc6 not livc6. 

 

try "sudo apt-get install libhybris:armhf"

 

I don't have the specific experience with libhybris but i do have multiarch working on my H5

Yes, only typing error. Maybe my kernel compiled without support?

Share this post


Link to post
Share on other sites

Check that kernel has CONFIG_COMPAT disable, I will enable and recompile it to test.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
1 1