TinkerBoard with Armbian_20.02.1_Tinkerboard_bionic_current_5.4.20_desktop doesn't start


q4a
 Share

0

Recommended Posts

Hi. I installed Armbian_20.02.1_Tinkerboard_bionic_current_5.4.20_desktop on my TinkerBoard (not S) and get weird screen state (white, then growing black circle in the middle).
I tried Armbian_20.02.1_Tinkerboard_bionic_legacy_4.4.213_desktop and it works very good, but I still want to test vulkan driver, so I updated only kernel to 4.19 (install linux-image-next-rockchip, linux-header-next-rockchip, linux-dtb-next-rockchip and delete 3 old packages).
After reboot I got same screen. Is it known bug? Can it be related, that I'm using HDMI-to-VGA adapter? Can you help me to fix it or get usefull logs?

Link to post
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

Can you take a photo of the issue ? Also, I'd highly recommend to try getting a SSH access on the board and provide some logs (dmesg at least).

 

That said, if you could avoid using the HDMI-to-VGA adapter, or at least try a few minutes with a direct HDMI connection, that could help determine if that's the adapter causing some issues (or the Rockchip driver not able to deal with the adapter configuration).

 

Also, understand that the only Mali Midgard user-space vulkan driver for RK3288 boards, that works on Linux, is tailored towards the fbdev display API, which might require some very specific kernel configurations (or a very old kernel).

Link to post
Share on other sites

So, I downloaded Armbian_20.02.7_Tinkerboard_bionic_current_5.4.28_desktop.7z for clean test and here screens:

At start screen almost white. Then black "thing" in the middle grow - screen 1. And then screen become almost black - screen 2 (white spot in center - is flash light).

I know - it's wired, but I installed armbian or TinkerOS (Debian based) with 4.4 kernel - all works fine. Android works fine too. I still would like to use lastest kernel and hope to help Panfrost (open source user land mali driver) with testing.


How can I get SSH access? Is there any instruction?

IMG_20200402_100917_HDR.thumb.jpg.98a18207c58298212d9b26eb17e1b096.jpg

IMG_20200402_100952.thumb.jpg.bdfca4066e963efa65fbd896d8d51942.jpg

Link to post
Share on other sites

18 minutes ago, q4a said:

with 4.4 kernel

 

On 3/22/2020 at 5:03 PM, q4a said:

Can it be related, that I'm using HDMI-to-VGA adapter?


With this TV you can probably only use Armbian with 4.4. kernel due to HDMI 2 VGA adaptor. Modern kernel is also slightly more power hungry which could make troubles. A device for 1 USD http://amzn.to/2wbNkLp would safe us hundreds. Get one and show boot logs on console.

 

 

Link to post
Share on other sites

Try to get a 4.4 kernel on this board and we'll try to analyze the HDMI (PLL) frequencies used by this kernel, and then see if we can replicate them on modern 5.x kernels.

 

It seems that PLL configuration for HDMI resolutions other than 720p, 1080p, 1440p and 2160p are still not mainlined...

However, I don't own any screen that differs from these resolutions, making it really hard to test.

Link to post
Share on other sites

9 hours ago, Myy said:

Try to get a 4.4 kernel on this board and we'll try to analyze the HDMI (PLL) frequencies used by this kernel

I have working SD card with 4.4 kernel armbian. What should I check?

PS I'm using this monitor for main PC with ubuntu eoan amd64 with 5.3.0-40 kernel. Default monitor resolution is 1600x900 60 Hz. And when I 1st time booted in TinkerOS with 4.4 kernel - monitor says that I booted in unsupported resolution like 1920x1080, but still shows desktop and I can change resolution to 1600x900. (Then I swiched to armbian, and I like it)

PSS my monitor is Samsung SyncMaster P2050:
https://www.samsung.com/ph/support/model/LS20LRZKU/XP/

Link to post
Share on other sites

Could you do this on the working part :

 

cat /sys/devices/platform/display-subsystem/drm/card0/card0-HDMI-A-1/modes

 

Also, by default, if you can connect the board via Ethernet to a DHCP server and then access tthat DHCP server (if you connect it directly to a box, check the box web UI, it generally has information about connected machines), you might be able to connect the Tinkerboard running a mainline kernel using :

 

ssh root@ip_of_the_tinkerboard

 

The default password is 1234

Link to post
Share on other sites

Here is output from working 4.4 kernel:

q@tinkerboard:~$ cat /sys/devices/platform/display-subsystem/drm/card0/card0-HDMI-A-1/modes
1600x900p60
1920x1080p60
1920x1080p60
1280x1024p60
1440x900p60
1280x800p60
1280x720p60
1280x720p60
1024x768p60
800x600p60
800x600p56
q@tinkerboard:~$

I have router with DHCP and I can connect to tinkerboard with 5.5 kernel:

root@tinkerboard:~# cat /sys/devices/platform/display-subsystem/drm/card0/card0-HDMI-A-1/modes
1600x900
1920x1080
1920x1080
1280x1024
1280x720
1280x720
1024x768
800x600
800x600
720x480
720x480
720x480

 

Link to post
Share on other sites

Hmm, I'll try to extract and test this patch, see if that doesn't generate issues with standard HDMI screens.

Then see how to let you test it on your adapter.

 

https://github.com/jernejsk/LibreELEC.tv/blob/updates/projects/Rockchip/patches/linux/default/linux-0006-experimental.patch#L610

 

I'm surprised by the outstanding amount of HDMI patches that LibreELEC.tv has for Rockchip.

This might need an entire directory specific for HDMI patches at this point.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

0