NEO2 + EDIMAX EW 7822ULC, can't connect to 5GHz network


 Share

0

Recommended Posts

I have a problem with NEO2 and EDIMAX EW 7822ULC.

I can't see none of my 5GHz network SSID, but I can connect to 2.4 GHz.

I am using Buster minimal image.

It is something I should do to solve this problem?

Thank you.

Edited by Aldoszx
Link to post
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

18 minutes ago, Aldoszx said:

I am using 5V 2.5A power adapter to power the board.


Power adaptor is not a problem, connector is:
 

 

18 minutes ago, Aldoszx said:

It was chosen because it is in the tested 3rd party hardware list.


Yes, that dongle works fine for me and it is the best performer. But if your powering is not proper, things can go south pretty quickly. Those dongles needs 1-1.5A only for them.

Once you don't rule out powering by putting a powered USB hub in between, it is powering problem.

Link to post
Share on other sites

I have it attached to the Opi Prime, build from trunk:
 

Spoiler

[77513.434157] Console: switching to colour frame buffer device 240x67
[77513.512084] sun4i-drm display-engine: fb0: sun4i-drmdrmfb frame buffer device
[77522.464983] usb 5-1: new high-speed USB device number 2 using ehci-platform
[77522.493761] usb 5-1: New USB device found, idVendor=1a40, idProduct=0101, bcdDevice= 1.11
[77522.493778] usb 5-1: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[77522.493789] usb 5-1: Product: USB 2.0 Hub
[77522.494711] hub 5-1:1.0: USB hub found
[77522.494868] hub 5-1:1.0: 4 ports detected
[77522.881002] usb 5-1.1: new high-speed USB device number 3 using ehci-platform
[77522.909758] usb 5-1.1: New USB device found, idVendor=1a40, idProduct=0101, bcdDevice= 1.11
[77522.909774] usb 5-1.1: New USB device strings: Mfr=0, Product=1, SerialNumber=0
[77522.909785] usb 5-1.1: Product: USB 2.0 Hub
[77522.910708] hub 5-1.1:1.0: USB hub found
[77522.910869] hub 5-1.1:1.0: 4 ports detected
[77523.093005] usb 5-1.2: new low-speed USB device number 4 using ehci-platform
[77523.327011] usb 5-1.2: New USB device found, idVendor=0c45, idProduct=7403, bcdDevice= 0.01
[77523.327026] usb 5-1.2: New USB device strings: Mfr=1, Product=2, SerialNumber=0
[77523.327037] usb 5-1.2: Product: USB Device
[77523.327047] usb 5-1.2: Manufacturer: SONiX
[77523.334164] input: SONiX USB Device as /devices/platform/soc/1c1d000.usb/usb5/5-1/5-1.2/5-1.2:1.0/0003:0C45:7403.0001/input/input2
[77523.394316] hid-generic 0003:0C45:7403.0001: input,hidraw0: USB HID v1.00 Keyboard [SONiX USB Device] on usb-1c1d000.usb-1.2/input0
[77523.401230] input: SONiX USB Device Mouse as /devices/platform/soc/1c1d000.usb/usb5/5-1/5-1.2/5-1.2:1.1/0003:0C45:7403.0002/input/input3
[77523.401907] input: SONiX USB Device System Control as /devices/platform/soc/1c1d000.usb/usb5/5-1/5-1.2/5-1.2:1.1/0003:0C45:7403.0002/input/input4
[77523.461532] hid-generic 0003:0C45:7403.0002: input,hidraw1: USB HID v1.00 Mouse [SONiX USB Device] on usb-1c1d000.usb-1.2/input1
[77523.501070] usb 5-1.1.2: new high-speed USB device number 5 using ehci-platform
[77523.532288] usb 5-1.1.2: New USB device found, idVendor=0409, idProduct=005a, bcdDevice= 1.00
[77523.532308] usb 5-1.1.2: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[77523.538126] hub 5-1.1.2:1.0: USB hub found
[77523.538453] hub 5-1.1.2:1.0: 4 ports detected
[77523.825002] usb 5-1.1.2.1: new high-speed USB device number 6 using ehci-platform
[77523.853980] usb 5-1.1.2.1: New USB device found, idVendor=0572, idProduct=6831, bcdDevice= 0.00
[77523.853987] usb 5-1.1.2.1: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[77523.853992] usb 5-1.1.2.1: Product: S960
[77523.853995] usb 5-1.1.2.1: Manufacturer: Bestunar
[77523.853999] usb 5-1.1.2.1: SerialNumber: 20120511
[77523.933026] usb 5-1.1.2.2: new low-speed USB device number 7 using ehci-platform
[77524.047860] usb 5-1.1.2.2: New USB device found, idVendor=0458, idProduct=0036, bcdDevice= 1.07
[77524.047867] usb 5-1.1.2.2: New USB device strings: Mfr=2, Product=1, SerialNumber=0
[77524.047871] usb 5-1.1.2.2: Product: NetScroll+Mini Traveler
[77524.047875] usb 5-1.1.2.2: Manufacturer: Genius      
[77524.052460] input: Genius       NetScroll+Mini Traveler as /devices/platform/soc/1c1d000.usb/usb5/5-1/5-1.1/5-1.1.2/5-1.1.2.2/5-1.1.2.2:1.0/0003:0458:0036.0003/input/input5
[77524.052767] hid-generic 0003:0458:0036.0003: input,hidraw2: USB HID v1.10 Mouse [Genius       NetScroll+Mini Traveler] on usb-1c1d000.usb-1.1.2.2/input0
[77524.101032] usb 5-1.1.2.1: dvb_usb_v2: found a 'DVBSky S960/S860' in warm state
[77524.101345] usb 5-1.1.2.1: dvb_usb_v2: will pass the complete MPEG2 transport stream to the software demuxer
[77524.101370] dvbdev: DVB: registering new adapter (DVBSky S960/S860)
[77524.101379] usb 5-1.1.2.1: media controller created
[77524.102719] usb 5-1.1.2.1: dvb_usb_v2: MAC address: 00:17:42:54:96:0c
[77524.103544] dvbdev: dvb_create_media_entity: media entity 'dvb-demux' registered.
[77524.116080] i2c i2c-2: Added multiplexed i2c bus 3
[77524.133031] usb 5-1.1.2.3: new high-speed USB device number 8 using ehci-platform
[77524.162231] usb 5-1.1.2.3: New USB device found, idVendor=7392, idProduct=b822, bcdDevice= 2.10
[77524.162239] usb 5-1.1.2.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[77524.162244] usb 5-1.1.2.3: Product: AC1200 MU-MIMO USB2.0 Adapter
[77524.162248] usb 5-1.1.2.3: Manufacturer: Realtek
[77524.162252] usb 5-1.1.2.3: SerialNumber: 123456
[77524.232224] ts2020 3-0060: Montage Technology TS2022 successfully identified
[77524.232330] usb 5-1.1.2.1: DVB: registering adapter 0 frontend 0 (Montage Technology M88DS3103)...
[77524.232351] dvbdev: dvb_create_media_entity: media entity 'Montage Technology M88DS3103' registered.
[77524.241060] usb 5-1.1.2.4: new high-speed USB device number 9 using ehci-platform
[77524.269497] usb 5-1.1.2.4: New USB device found, idVendor=0409, idProduct=005a, bcdDevice= 1.00
[77524.269506] usb 5-1.1.2.4: New USB device strings: Mfr=0, Product=0, SerialNumber=0
[77524.270070] hub 5-1.1.2.4:1.0: USB hub found
[77524.270224] hub 5-1.1.2.4:1.0: 4 ports detected
[77524.397054] Registered IR keymap rc-dvbsky
[77524.397231] rc rc1: DVBSky S960/S860 as /devices/platform/soc/1c1d000.usb/usb5/5-1/5-1.1/5-1.1.2/5-1.1.2.1/rc/rc1
[77524.397424] rc rc1: lirc_dev: driver dvb_usb_dvbsky registered at minor = 1, scancode receiver, no transmitter
[77524.397544] input: DVBSky S960/S860 as /devices/platform/soc/1c1d000.usb/usb5/5-1/5-1.1/5-1.1.2/5-1.1.2.1/rc/rc1/input6
[77524.397652] usb 5-1.1.2.1: dvb_usb_v2: schedule remote query interval to 300 msecs
[77524.397661] usb 5-1.1.2.1: dvb_usb_v2: 'DVBSky S960/S860' successfully initialized and connected
[77524.397753] usbcore: registered new interface driver dvb_usb_dvbsky
[77524.557033] usb 5-1.1.2.4.2: new high-speed USB device number 10 using ehci-platform
[77524.585986] usb 5-1.1.2.4.2: New USB device found, idVendor=0bda, idProduct=8179, bcdDevice= 0.00
[77524.585993] usb 5-1.1.2.4.2: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[77524.585998] usb 5-1.1.2.4.2: Product: 802.11n NIC
[77524.586002] usb 5-1.1.2.4.2: Manufacturer: Realtek
[77524.586005] usb 5-1.1.2.4.2: SerialNumber: 00E04C0001
[77524.665057] usb 5-1.1.2.4.3: new full-speed USB device number 11 using ehci-platform
[77524.738977] bFWReady == _FALSE call reset 8051...
[77524.769641] usbcore: registered new interface driver 8188eu
[77524.778656] usb 5-1.1.2.4.3: New USB device found, idVendor=093a, idProduct=8020, bcdDevice= 0.00
[77524.778668] usb 5-1.1.2.4.3: New USB device strings: Mfr=1, Product=2, SerialNumber=3
[77524.778672] usb 5-1.1.2.4.3: Product: Optical Touch
[77524.778677] usb 5-1.1.2.4.3: Manufacturer: Pixart Imaging, Inc.
[77524.778681] usb 5-1.1.2.4.3: SerialNumber: 0
[77524.794998] input: Pixart Imaging, Inc. Optical Touch Mouse as /devices/platform/soc/1c1d000.usb/usb5/5-1/5-1.1/5-1.1.2/5-1.1.2.4/5-1.1.2.4.3/5-1.1.2.4.3:1.0/0003:093A:8020.0004/input/input7
[77524.795867] 8188eu 5-1.1.2.4.2:1.0 wlx14cf922b09d8: renamed from wlan1
[77524.797520] input: Pixart Imaging, Inc. Optical Touch Touchscreen as /devices/platform/soc/1c1d000.usb/usb5/5-1/5-1.1/5-1.1.2/5-1.1.2.4/5-1.1.2.4.3/5-1.1.2.4.3:1.0/0003:093A:8020.0004/input/input8
[77524.797905] hid-generic 0003:093A:8020.0004: input,hiddev96,hidraw3: USB HID v1.10 Mouse [Pixart Imaging, Inc. Optical Touch] on usb-1c1d000.usb-1.1.2.4.3/input0
[77524.798143] usbhid 5-1.1.2.4.3:1.1: couldn't find an input interrupt endpoint
[77524.935328] input: Pixart Imaging, Inc. Optical Touch Mouse as /devices/platform/soc/1c1d000.usb/usb5/5-1/5-1.1/5-1.1.2/5-1.1.2.4/5-1.1.2.4.3/5-1.1.2.4.3:1.0/0003:093A:8020.0004/input/input9
[77524.935741] input: Pixart Imaging, Inc. Optical Touch as /devices/platform/soc/1c1d000.usb/usb5/5-1/5-1.1/5-1.1.2/5-1.1.2.4/5-1.1.2.4.3/5-1.1.2.4.3:1.0/0003:093A:8020.0004/input/input10
[77524.936103] hid-multitouch 0003:093A:8020.0004: input,hiddev96,hidraw3: USB HID v1.10 Mouse [Pixart Imaging, Inc. Optical Touch] on usb-1c1d000.usb-1.1.2.4.3/input0
[77525.468593] usbcore: registered new interface driver rtl88x2bu
[77525.485641] rtl88x2bu 5-1.1.2.3:1.0 wlx74da38eefdd2: renamed from wlan1
[77534.904148] IPv6: ADDRCONF(NETDEV_CHANGE): wlx74da38eefdd2: link becomes ready

 


Log when attaching a HUB with some stuff, including this wifi dongle.

Connected to 5G AP
 

wlx74da38eefdd2  IEEE 802.11AC  ESSID:"XXXXXXXXXXXXXXxx"  Nickname:"<WIFI@REALTEK>"
          Mode:Managed  Frequency:5.24 GHz  Access Point: XX:XX:XX:XX:XX:XX   
          Bit Rate:867 Mb/s   Sensitivity:0/0  
          Retry:off   RTS thr:off   Fragment thr:off
          Encryption key:****-****-****-****-****-****-****-****   Security mode:open
          Power Management:off
          Link Quality=63/100  Signal level=39/100  Noise level=0/100
          Rx invalid nwid:0  Rx invalid crypt:0  Rx invalid frag:0
          Tx excessive retries:0  Invalid misc:0   Missed beacon:0

 

Link to post
Share on other sites

After latest updates, does not work anymore !

My 5GHz wi-fi network is not even seen.

I've tried also another wi-fi adapter, ASUS AC-53 (same chipset AFAIK). In this case, the SSID appears, but I cannot connect.

Tried also Focal image: same issue !

Maybe there is a problem with drivers or this chipset.

2.4GHz connection works.

Any clues?

Thank you !

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

0