Jump to content

BananaPi M1 stops to work


Recommended Posts





my BananaPi M1 sometimes just stops working. The maximum uptime is 5 days. Usually the time is shorter. The system simply hangs. I can no longer access the system via SSH. When I connect a monitor to HDMI, nothing is displayed, so I can log in.

I have connected an external hard drive that is self-powered. I know the stories with the power supply. I have run ' stress -c 2 -m 1 '. The system remains stable.

Time CPU load %cpu %sys %usr %nice %io %irq CPU PMIC DC-IN C.St

19:09:19: --- 0.69 10% 5% 5% 4% 0% 0% 49.3°C 42.4°C 5.10V 0/6
19:09:49: --- 2.16 100% 33% 66% 0% 0% 0% 50.2°C 43.6°C 5.10V 0/6
19:10:16: --- 3.18 100% 33% 65% 0% 0% 1% 50.2°C 44.0°C 5.06V 0/6
19:10:47: --- 3.58 100% 33% 64% 0% 0% 1% 51.0°C 44.4°C 5.05V 0/6
19:11:17: --- 3.96 100% 33% 64% 0% 0% 1% 51.4°C 44.9°C 5.03V 0/6
19:11:47: --- 4.34 100% 33% 65% 0% 0% 1% 51.1°C 45.0°C 5.09V 0/6
19:12:17: --- 4.42 100% 33% 65% 0% 0% 1% 51.3°C 45.3°C 5.07V 0/6


I also executed 'armbianmonitor -u'.The log is here: http://ix.io/2lzX


I checked syslog, daemon.log, user.log, armbian-ramlog.log for errors. With my amateurish understanding I did not find any error entries. In which logs can I still look up to search for errors?


I have installed armbian buster minimal. Additionally I have pihole, transmission (to seed armbian torrents https://forum.armbian.com/topic/4198-seed-our-torrents/) and syncthing running. Other programs I have not installed yet.


Link to comment
Share on other sites

I'm also observing similar issue (device is not accessible via ssh after some time - from few hours to couple days). This happened with kernels 5.3.x (don't remember exactly which one I've installed) and the same 5.4.35 (I'm using Ubuntu).

Link to comment
Share on other sites

@Igor Thanks in advance. I changed the setup. In '/etc/default/cpufrequtils' is saw 'MAX_SPEED=1010000'. With 'cpufreq-info' i saw this line 'hardware limits: 144 MHz - 960 MHz'. I changed the value to 'MAX_SPEED=960000'.


Best regards!

Link to comment
Share on other sites

There was no /etc/default/cpufrequtils in my case but /etc/default/cpufrequtils.dpkg-old instead. I've copied it to /etc/default/cpufrequtils, replaced 'ondemand' to 'performance' and rebooted a device.

$ cat /sys/devices/system/cpu/cpu0/cpufreq/scaling_governor

Uptime is 23 hours at the moment.

Link to comment
Share on other sites

On 5/10/2020 at 9:09 PM, Igor said:

Try changing CPU governor to "performance" and report if that helps.

My uptime is 7 days. As long as never before. I guess the change to "performance" works. Thank you very much.

Link to comment
Share on other sites

This tip saved me from buying a new bananapi m3. 

The second bananapi that was increasingly unstable : just stopped responding. In the past only once in a few weeks, nowadays every day. So unusable.

I had set it to email me every 5 minutes and it also stops doing that. 


Now I have set governor to performance and it's up for almost a day now. So seems good so far.


If anyone has an idea why this governor change works I would certainly like to understand it. Probably some cpu-state in rest that it can't come out of? There are no signs anywhere of a crash. 

Link to comment
Share on other sites

I tried to use "userspace" and the bananapi stayed up for about four days. But then it crashed again. The red LED stops blinking (stays permanently on). And is no longer responsive on the network. Ping fails and checking ARP tables on the same network shows no MAC entry. So the bananapi seems to be locked up hard. Sometimes the HDMI shows a blank screen, sometimes it shows a crash debug.


I tried to change the CPU parameters in /etc/default/cpufrequtils to "performance" but, after a reboot, I always got "ondemand" output from cpufreq-info. What I found was that there are other CPU management modules running.

So I did this:

sudo systemctl disable loadcpufreq.service
sudo systemctl disable raspi-config.service
sudo apt install cpufrequtils

sudo systemctl enable cpufrequtils.service
sudo systemctl start cpufrequtils.service
sudo systemctl status cpufrequtils.service


Now I was able to set the parameters in /etc/default/cpufrequtils:




sudo systemctl daemon-reload
sudo systemctl restart cpufrequtils.service
sudo systemctl status cpufrequtils.service


I tried "userspace" (commented out above) but bananapi crashed after four days. Now I am switched to "performance" (shown above) and I will see how it goes. I will also try "performance" without lower and upper freq limits.


It would be great to hear from Igor why this change of cpu operating parameters is supposed to fix the hanging bananapi.

Edited by katoomba
added more details
Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

  • Create New...

Important Information

Terms of Use - Privacy Policy - Guidelines