1 1
olivluca

orange pi pc xenial: hostapd unmet dependency

Recommended Posts

Armbianmonitor:

Today unattended-upgrades warned me that hostapd was on hold:

 

Unattended upgrade returned: True

Packages that were upgraded:
 
Packages with upgradable origin but kept back:
 Armbian xenial:
  hostapd 

 

I checked and it's because it depends on libssl1.1 >= 1.1.1 which isn't available

 

The following packages have unmet dependencies:
 hostapd : Depends: libssl1.1 (>= 1.1.1) but it is not installable
E: Unable to correct problems, you have held broken packages.

 

The package comes from armbian's repository (ubuntu has an older version)

 

$ apt-cache policy hostapd
hostapd:
  Installed: 3:2.7-99~armbian5.73+1
  Candidate: 3:2.9-100~armbian20.05.0-trunk+1
  Version table:
     3:2.9-100~armbian20.05.0-trunk+1 500
        500 http://apt.armbian.com xenial/main armhf Packages
 *** 3:2.7-99~armbian5.73+1 100
        100 /var/lib/dpkg/status
     1:2.4-0ubuntu6.6 500
        500 http://ports.ubuntu.com xenial-security/universe armhf Packages
        500 http://ports.ubuntu.com xenial-updates/universe armhf Packages
     1:2.4-0ubuntu6 500
        500 http://ports.ubuntu.com xenial/universe armhf Packages

 

I don't use or need it (I suppose it was installed by default in the original image) but I thought to report it anyway.

Share this post


Link to post
Share on other sites

Hi folks,

 

I'm using a NanoPi Neo 2 with Armbian Buster but I think my problem does not relate to this specific hardware.

 

I wanted to update my Pi today, so I ran:

> sudo apt update
Hit:1 [... and so on]
Reading package lists... Done
Building dependency tree
Reading state information... Done
1 package can be upgraded. Run 'apt list --upgradable' to see it.

and

> sudo apt list --upgradable
Listing... Done
hostapd/buster 3:2.9-101~armbian20.05.0-trunk+1 arm64 [upgradable from: 3:2.7-99~armbian5.86+1]
N: There are 4 additional versions. Please use the '-a' switch to see them.

But I could not upgrade. It says there are no packages available. So I ran:

> sudo apt install hostapd
Reading package lists... Done
Building dependency tree
Reading state information... Done
Some packages could not be installed. This may mean that you have
requested an impossible situation or if you are using the unstable
distribution that some required packages have not yet been created
or been moved out of Incoming.
The following information may help to resolve the situation:
The following packages have unmet dependencies:
 hostapd : Depends: libssl1.0.0 (>= 1.0.2~beta3) but it is not installable
E: Unable to correct problems, you have held broken packages.

Today I updated Pi-Hole and yesterday I activated unintended-upgrades (security updates) by editing /etc/apt/apt.conf.d/02-armbian-periodic.  I also executed the following command: sudo dpkg-divert --no-rename --add /etc/apt/apt.conf.d/02-armbian-periodic

 

So there is something broken but I don't know what and how I can fix it. I hope you can help me. Thanks in advance.

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
1 1