Jump to content

rk3399 rockpi4 & wm8731 audioinjector stereo


Recommended Posts


first i want to say thank you to every armbian supporter and the hole team. thanks for providing this nice project and your work.


i did some work for adding an external sound card - the audioinjector pi stereo, which is based on a wm8731.

i used the radxa rockpi4(b)  board based on the rk3399. i choose this board because of pinout header is nearly the same as the one you find on raspberrys. so adding/ using raspberry Hats won´t be too hart in this case.

this will also work with radxa kernel https://github.com/verplant23/kernel

so there shouldn´t be any troubles porting it to armbian legacy.


i´m not a coder and i don´t know about linux that much.  for most things this was try and error of code snippets + lot´s of time. 

i tried diffrent ways and there are diffrent ways how thing can be get to work - for sure you guys could make things work better because there are still errors while dmesg.


i used 20.05 dev kernel but basicly this also work on master or current. 

please post what you think of or how to improve.


install debs or build your own by adding userpatch from 



after installing / compiling follow up the armbian docs and add i2c7 by adding 


to your /boot/armbianEnv.txt


i wasn´t able to use armbian-add-overlay. because error told me that i don´t use the correct device...

you can use the dtbo inside repo. it was build with the radxa kernel repo (link above). you can find dts inside.  

add the folder /boot/overlay-user/  and copy audioinjector-wm8731-audio.dtbo inside


follow up the armbian docs and add 


to your /boot/armbianEnv.txt


after reboot 

cat /proc/asound/cards should show up the card


dmesg will show some error:

audioinjector-stereo sound-ext-card: snd_soc_register_card failed (-517)


but since dmesg | grep i2s will show

audioinjector-stereo sound-ext-card: wm8731-hifi <-> ff890000.i2s mapping ok

the device should work.


when getting no sound go to alsamixer and check the mute cases especially  Item: Output Mixer HiFi is not muted


you can make it sound-card-0 by default

sudo nano /etc/modprobe.d/alsa.conf

should be something like

alias snd-card-0 wm8731-hifi

alias snd-card-0 snd_soc_audioinjector_pi_soundcard
alias snd-card-0 snd_soc_simple_card
options snd slots=,hdmisound,rockchiprk3399,snd_soc_audio_graph_card


make sound-card-0 default device 

sudo nano /etc/asound.conf

defaults.pcm.card 0
defaults.ctl.card 0

have fun and keep healthy


Edited by verplant23
Link to comment
Share on other sites

Donate your old hardware to community. Start a giveaway Raffle!

This topic is now closed to further replies.
  • Create New...