Problems mounting drive with usrjquota


Recommended Posts

Hi,

 

I can't seem to mount any drives with journaled user/group quota.

 

I just get this error:

root@bananapipro:~# mount -o rw,defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0 UUID=56790abd-531d-43b7-8cf8-9bfc85105f6a /media/56790abd-531d-43b7-8cf8-9bfc85105f6a
mount: wrong fs type, bad option, bad superblock on /dev/sda1,
       missing codepage or helper program, or other error

       In some cases useful info is found in syslog - try
       dmesg | tail or so.

If I run the mount command without the quota stuff the drive mounts without any problems and is browseable.

Link to post
Share on other sites
Armbian is a community driven open source project. Do you like to contribute your code?

@LarsN

 

zador.blood.stained just added quota for sunxi-next

 

but you will need to compile your kernel with http://www.armbian.com/using-armbian-tools/

 

Ah I see. Could we get it enabled by default, as OpenMediaVault bugs out because not being able to mount ext4 disks/partitions.

 

I can't read :)

 

These are the default mount values for OpenMediaVault:

defaults,nofail,user_xattr,noexec,usrjquota=aquota.user,grpjquota=aquota.group,jqfmt=vfsv0

I'll try and compile the kernel with quota enabled and see if it fixes the problem.

 

Thanks for the super fast replies from both of you.

Link to post
Share on other sites
Guest
This topic is now closed to further replies.