0
moshem

eth0 network down all of a sudden, update?

Recommended Posts

(edited)

Hi,

 

my S912 box was untouched for the past few weeks, I tried to connect to it and couldn't I tried direct access and turns out my eth0 (wired lan) is still detected but marked as down

the green/yellow light on the box and on the router is not blinking for it.

 

nothing changed in my setup, maybe a armbian update was done recently? my uptime is 7 days but I am not sure I recall restarting 7 days ago..

 

ifup eth0 image attached

 

what can I check or do to revive it? any help appreciated as the box is currently offline and useless

 

armbian 20.04 on a beelink GT1 TV box using a fast SD card

 

TGjTMPI.jpg

Edited by moshem

Share this post


Link to post
Share on other sites

Hi @moshem, I think something changed in the latest kernel. Mine was working fine a while ago with meson-gxm-q200.dtb. Then it got unstable and I even tried building my own images with no luck. I read somewhere that there is a timing change which was affecting some boards. This I believe introduced this instability.

 

Some observations:

1) Sometimes eth0 would come up, work for a short while and then stop. Not even rebooting works and it remains hard down

2) I can see on my router that auto negotiation  goes for 1Gbps, but my board is only 100Mbps. Did not find a place where I could change it

3) I noticed some changes in the dtb files over the last couple of images. I tried using the old dtbs which were more stable but no luck

 

Semi work around I found today was using the meson-gxm-mecool-kiii-pro.dtb. It still negotiates at 1Gbps and network performance is poor but at least it comes up.

 

If you can try Balbes150's latest GPU test image and see if any of the DTB files works for you.  I think there are a few new dtb files in this image, not sure.

 

 

Hope you find something that works and look forward to hearing your findings.

 

Share this post


Link to post
Share on other sites

thanks!

in my case after many hours of hairpolling, I rebooted the box once more, loaded it with android (original firmware on the emmc) and saw that the ethernet functions well.

I then restarted and boot armbian and to my suprise, it resumed working, puzzling indeed...

Share this post


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
0