‘command not found’ when I try to run docker-compose


Recommended Posts

I’m running Armbian 20.05.7 stable on an Odroid HC2 (XU4). I installed Docker Compose using the instrux found in the Linux section of the Docker install page.
I’m logged in as root via SSH. I run the curl command (which I literally copied/pasted from the docs install page)

curl -L "https://github.com/docker/compose/releases/download/1.26.2/docker-compose-$(uname -s)-$(uname -m)" -o /usr/local/bin/docker-compose

then

chmod +x /usr/local/bin/docker-compose

and I check it with

which docker-compose

which returns:

/usr/local/bin/docker-compose

 

When I try to test the installation…

docker-compose --version

it returns:
bash: /usr/bin/docker-compose: Permission denied
Notice that it seems to want /usr/bin instead of /usr/local/bin, so (as suggested on the docs install page) I run

ln -s /usr/local/bin/docker-compose /usr/bin/docker-compose

and I try to test the installation again. Now it returns:
/usr/bin/docker-compose: line 1: Not: command not found

I removed everything and tried the curl command (pointed at /usr/bin instead of /usr/local/bin) again, followed by the chmod command. Now which docker-compose returns
/usr/bin/docker-compose
So I try to test the installation again with docker-compose --version and I get the same thing:
/usr/bin/docker-compose: line 1: Not: command not found

 

What in the heck am I doing wrong? I tried posting this on the Docker forums but no one has responded so I'm wondering if it's more of an Armbian issue.

Link to post
Share on other sites
Donate and support the project!

3 hours ago, ErniePantuso said:

I'm wondering if it's more of an Armbian issue.

 

On a user space level its almost 99% chances that its not an Armbian issue. It can be yet another GNU software bug. "1000 people's" work we don't even try to fix or problem with a software you are trying to install.

 

https://github.com/docker/compose/releases

As you can see, ARM architecture is not available as binary. You will need to build from sources.

Link to post
Share on other sites

In case anyone stumbles upon this and, like me, is trying to install docker-compose on Debian Buster-based Armbian (arm64 architecture) the answer, as it turns out, is quite simple...

Install Docker using softy. (Softy does all the work - it's great!) I recommend testing the install with

docker run hello-world

Once that's done and successful, you can just run 

sudo apt install docker-compose

and it just works. If you want to test it, paste this into docker-compose.yml:

version: '3'  
services:
  web:
    image: nginx:latest
    ports:
     - "8080:80"
    links:
     - php
  php:
    image: php:7-fpm

then run 

docker-compose up -d && docker ps

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...