Anyone used D-WAV Scientific Co., Ltd eGalax TouchScreen? Problem with driver installation...



Recommended Posts

I had a untested touchscreen device lying in its box , presenting itself as:


Bus 006 Device 002: ID 0eef:0001 D-WAV Scientific Co., Ltd eGalax TouchScreen


The driver provided on their site ( complains that the controller is non-HID and reverts back the installation. I tried it manually with no success. I'm using an OPi PC Plus to build a Home Assistant machine.


Does anyone have pointers for this for Armbian?

Something like (this one is for RPi)


Link to post
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?



After compiling the kernel with usbtouchscreen as module and enabling it + apt-get xinput & xinput-calibrator , my touchscreen worked.

Axis were inverted, so a transformation matrix is needed on /etc/X11/xorg.conf.d/99-calibration.conf:


        Option "TransformationMatrix" "0 -1 1 1 0 0 0 0 1"

On the other hand it needs some scaling as I cannot reach the screen's edges. As far as I can see it can only be done by trial-error - a very tedious task.


By looking into /var/log/Xorg.0.log I can see the TransformationMatrix is read, but not other parameters suggested by xinput_calibrator mentioned in the log, so I'm not sure if they are relevant (modifying them had no effect).


That's it for now...


Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.