Switching SUNXI-DEV to 5.10.y (h3-h5-h6/megous)


5kft
 Share

0

Recommended Posts

With just a few local test hacks, I was able to bring up kernel 5.10-rc1 on sunxi this morning (based on the new megous branch):

 

root@air's password:
 _   _ ____  _      _    _
| \ | |  _ \(_)    / \  (_)_ __
|  \| | |_) | |   / _ \ | | '__|
| |\  |  __/| |  / ___ \| | |
|_| \_|_|   |_| /_/   \_\_|_|

Welcome to Armbian 20.08.14 Buster with Linux 5.10.0-rc1-sunxi

System load:   2%               Up time:       11 min
Memory usage:  14% of 491M      IP:            172.24.18.151
CPU temp:      34°C             Usage of /:    24% of 7.2G

Last login: Tue Oct 27 07:20:02 2020 from 172.24.18.20
root@air:~# cat /proc/version
Linux version 5.10.0-rc1-sunxi (root@355045fc2473) (arm-none-linux-gnueabihf-gcc (GNU Toolchain for the A-profile Architecture 9.2-2019.12 (arm-9.10)) 9.2.1 20191025, GNU ld (GNU Toolchain for the A-profile Architecture 9.2-2019.12 (arm-9.10)) 2.33.1.20191209) #trunk SMP Tue Oct 27 14:13:23 UTC 2020
root@air:~#
root@air:~# cpufreq-info -c 0
cpufrequtils 008: cpufreq-info (C) Dominik Brodowski 2004-2009
Report errors and bugs to cpufreq@vger.kernel.org, please.
analyzing CPU 0:
  driver: cpufreq-dt
  CPUs which run at the same hardware frequency: 0 1 2 3
  CPUs which need to have their frequency coordinated by software: 0 1 2 3
  maximum transition latency: 5.44 ms.
  hardware limits: 480 MHz - 1.20 GHz
  available frequency steps: 480 MHz, 648 MHz, 816 MHz, 960 MHz, 1.01 GHz, 1.10 GHz, 1.20 GHz
  available cpufreq governors: conservative, ondemand, userspace, powersave, performance, schedutil
  current policy: frequency should be within 480 MHz and 1.20 GHz.
                  The governor "ondemand" may decide which speed to use
                  within this range.
  current CPU frequency is 816 MHz (asserted by call to hardware).
  cpufreq stats: 480 MHz:97.72%, 648 MHz:0.22%, 816 MHz:0.20%, 960 MHz:0.23%, 1.01 GHz:0.15%, 1.10 GHz:0.19%, 1.20 GHz:1.29%  (679)
root@air:~#

 

I tested this on a spare NanoPi NEO Air board I had; I haven't tried an arm64 build yet.  dmesg is clean; cpufreq works,  overclocking works, wireless works, etc.  Our 5.9 kernel patchset applied almost completely without error (there are a few other changes needed such as the builddeb patches and fbcon reversion patch we did).

 

In any case I just wanted to let people know.  Given that 5.10 is confirmed to be the new LTS and 5.9 is the new primary -stable,  I'm wondering if 5.8's days are numbered (like what happened to 5.7).  I'm happy to put some work into bringing 5.10 into build if there is interest.

 

Link to post
Share on other sites

Donate and support the project!

I would not do that for two reasons:

The merge window for the next release is closed, so no new features which a major kernel version is

There was plenty of time to test 5.8 and it seems mostly reliable. For 5.9 there was barely testing and it also still seem to have issues.

 

I suggest to skip 5.9 and to for 5.10 which most likely will be current for the 21.02 release then...

Link to post
Share on other sites

If you're feeling adventurous and like living life on the edge, I have provided a buildable 5.10 tree here for sunxi:

 

git clone -b v5.10-dev-test https://github.com/5kft/build

 

Build as normal using "./compile.sh" using "BRANCH=dev" from this git branch and it'll build 5.10.0-rc1 targets.  Both sunxi and sunxi64 builds are enabled.  Note that I only tested on a few H3 and H5 boards (both Nano Pi and Orange Pi), but it seems to work pretty well.  But no guarantees, support, etc. - this is just a side project atm :)

Link to post
Share on other sites

27 minutes ago, martinayotte said:

Just to avoid issue, please, add a git tag on DEV 5.9.x before doing any change for 5.10.x, this way it will make things easier to switch CURRENT to 5.9.x ...

 

Yes, added appropriate pre-merge tags for both -current and -dev.  (Interestingly, at least at present, the delta between 5.9.x and 5.10.x is tiny.)

Link to post
Share on other sites

Well , it seems the 5.9.8 image I just downloaded ( Armbian_20.11.0-trunk.41_Nanopineo2_buster_current_5.9.8.img.xz ) did boot ok.

Therefore spun up a fresh 5.9.10 build to see how that went ... Alas no go ...

 

Yet trying to rule things out , but looks like it is my build environment as I seem to have issues with other boards too ( or flags I am using ) ,

thus apologies polluting this thread - once sorted will report back 5.10 should build fine imho - 
 

./compile.sh BRANCH=current RELEASE=buster BUILD_MINIMAL=yes BUILD_DESKTOP=no KERNEL_ONLY=no KERNEL_CONFIGURE=no EXTRAWIFI=no WIREGUARD=no

 

 

EDIT

 

So just wiping armbian dir and checking out did not work.

I had to reinstall Ubuntu from scratch and tada :

 

root@192.168.10.73's password:
 _   _ ____  _   _   _              ____
| \ | |  _ \(_) | \ | | ___  ___   |___ \
|  \| | |_) | | |  \| |/ _ \/ _ \    __) |
| |\  |  __/| | | |\  |  __/ (_) |  / __/
|_| \_|_|   |_| |_| \_|\___|\___/  |_____|

Welcome to Armbian 20.11.0-trunk Buster with Linux 5.10.0-rc5-sunxi64

No end-user support: built from trunk

System load:   29%              Up time:       1 min            Local users:   2
Memory usage:  15% of 474M      IP:            192.168.10.73
CPU temp:      26°C             Usage of /:    3% of 29G

 

Anyway 5.9 and 5.10 are building and booting just fine, false alarm for which my sincere apologies!

 

/EDIT

 

 

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

0