Ethernet 1Gbps often disconnects on Legacy kernel


Salamandar

Recommended Posts

I ran the 5.8/5.9 kernel for weeks without any issues (no RAM unstability, no crash, no ethernet issue).

Now I reinstalled the thing and came back to a 4.4 kernel to have USB-C support. The thing is… Once every hours, the 1GBps Ethernet disconnects.

 

Once connected through serial port, I can check the port status and it's shown as `Unknown`. I can `ip link set down eth0; ip link set up eth0` to set it back up.

 

Am I the only one with this issue ? Is it well known on 4.4 and solved on 5.9 ?

Link to post
Share on other sites
Armbian is a community driven open source project. Do you like to contribute your code?

It sometimes disconnects while idle (my Home Assistant web gui does not update, and I discover hours later it had been disconnected), sometimes while transferring data.

 

Quote

regarding USB-C support, what do you want to do? Currently the only issue with USB C support in LK 5.9 is switching role "on the fly".

 

OK, then I guess I will switch to `current`. Is there any easy switching procedure or should I just install `linux-current-image` ?

Link to post
Share on other sites