Auto user login


Christos
 Share

0
Go to solution Solved by Igor,

Recommended Posts

Hi,

 

Just did a new armbian build

Armbian_21.02.0-trunk_Orangepipc_buster_current_5.10.6_desktop

and flashed the image.

 

It works ok but after some reboot times the auto login to desktop is not working anymore and it prompts for user login.

Tried quite a few times to re-install but always after a few shutdown and start again cycles it reverts to login prompt and not auto login.

 

Also tried to find a solution in the forum but the files and config involved in previous solutions is no longer valid in the newer builds (/usr/share/lightdm/lightdm.conf.d/60-lightdm-gtk-greeter.conf or /etc/default/nodm).

 

So the question is this, how can I configure the systen for having auto login ?

 

Christos

 

Link to post
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

Need to check armbian-config, but you can try  this in the mean time:
https://github.com/armbian/build/blob/master/packages/bsp/common/usr/lib/armbian/armbian-firstlogin#L297-L304

 

11 hours ago, Christos said:

It works ok but after some reboot times the auto login to desktop is not working anymore and it prompts for user login.

 

This is now / since some time / the defaults.

Link to post
Share on other sites

 

Thanks @Igor

Hmm.. file (22-armbian-autologin.conf) looks not present now

 

christos@orangepipc:/etc/lightdm/lightdm.conf.d$ ls -l
total 4
-rw-r--r-- 1 root root 110 Jan 15 18:39 11-armbian.conf
christos@orangepipc:/etc/lightdm/lightdm.conf.d$

 

I added the file manually with the indicated contents and now it does work and autologin is ok.

 

Did though a new install and seen that the specific autologin config file is there present..

I'm gonna use another microsd just in case, it a first to have such issue (using SanDisk A1 16GB) but who knows.

 

Thanks

Christos

 

 

Link to post
Share on other sites

12 minutes ago, Christos said:

looks not present now


That is expected. Later on a timer starts which delete this file:
https://github.com/armbian/build/blob/master/packages/bsp/common/usr/lib/armbian/armbian-firstlogin#L318-L319

 

We figured out that it's best to provide autologin only at first run. If you want to have it always, you have to enable it manually by creating such file or that used to work fine via armbian-config, but it needs to be checked and fixed if it doesn't work anymore.

Link to post
Share on other sites

Ohh.. ok @Igor,

 

So its not a gremlin :-))

It got really weird but now its explained, thanks.

 

So, what is the appropriate procedure if someone wants to have the autologin always enabled?

You mentioned armbian-config but I could not find any relevant option there to use, could it be removed at some time or should I look better?

 

Link to post
Share on other sites

Thanks @Igor ,

 

I thought based on what you said  that there is some other method with armbian-config, ok no worries.

 

I got it now, it seems that the remove auto login service is a one-off, so it runs once after 10mins and removes the auto login and it never runs again so if we put again back the deleted file everything will be ok.

 

Thanks again

Christos

 

Link to post
Share on other sites

IMHO earlier, in all Armbian builds, autologin was enabled by default and all users are used to this behavior, so it is advisable to keep this in new versions (i.e. make autologin enabled by default and disable autologin yourself, through the armbian-config setting). For many users, this will preserve the usual behavior and at the same time allow you to disable autologin (if necessary).

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

0