assigning eth1 to usb network adapter


dolphs
 Share

0

Recommended Posts

Hi,

 

I added an USB3.0 adapter to my rockpi4a , which results in: " enx000ec667f0a2 " ( eth1 )

 

Since NetworkManager is being used I tried to update this name using : " nmcli c modify armbian connection.interface-name "eth1" "

But alas that does not seem to be picked up while nmconnection config file has been updated:

 

cat /etc/NetworkManager/system-connections/armbian.nmconnection

[connection]
id=armbian
uuid=8f61a97c-d0f1-4cb2-be4a-3fe2b4c08e7c
type=ethernet
interface-name=eth1

<snip snip>

 

Ideally this could be changed in armbian-config, but I realise this is a low-low 

 

 

rockpi-4a:system-connections:# ll
total 1.0K
-rw------- 1 root root 331 Feb  2 12:12  armbian.nmconnection
-rw------- 1 root root 384 Feb  2 11:54 'Wired connection 2.nmconnection'

 

 

That ideally gets changed to 'Wired connection 1.nmconnection'

which I updated manually using " nmcli c modify armbian connection.id 'Wired connection 1' "

 

Idea is eth0 will be used solely for outgoing traffic, while "eth1" will be used for incoming

 

Link to post
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

fantastic, thanks for your answer Igor

I was already about to mess with " 73-usb-net-by-mac.rules ", but this flag works so much better!

 

Out of the box, flashing image it shows:

2: eth0: <BROADCAST,MULTICAST,UP,LOWER_UP> mtu 1500 qdisc mq state UP group default qlen 1000
    link/ether 86:67:c3:ba:43:ca brd ff:ff:ff:ff:ff:ff
    inet 192.168.10.188/24 brd 192.168.10.255 scope global dynamic noprefixroute eth0
       valid_lft 14213sec preferred_lft 14213sec
    inet6 fe80::f791:3c34:96fb:aec3/64 scope link noprefixroute
       valid_lft forever preferred_lft forever
3: eth1: <NO-CARRIER,BROADCAST,MULTICAST,UP> mtu 1500 qdisc pfifo_fast state DOWN group default qlen 1000
    link/ether 00:0e:c6:67:f0:a2 brd ff:ff:ff:ff:ff:ff


Now remaining to configure static address , routing etc etc.

This is my test "system" , so I can configure/ test settings before applying them instantly to my R4S

thanks again!

 

Link to post
Share on other sites

On 2/2/2021 at 3:27 AM, dolphs said:

I added an USB3.0 adapter to my rockpi4a , which results in: " enx000ec667f0a2 " ( eth1 )

 

Since NetworkManager is being used I tried to update this name using : " nmcli c modify armbian connection.interface-name "eth1" "

But alas that does not seem to be picked up while nmconnection config file has been updated:

 

Shortcut perhaps... but this does override systemd assigning things there...

 

Add the following line to /boot/armbianEnv.txt

 

extraargs=net.ifnames=0

 

and then reboot...

 

sfx

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

0