Brightness option missing in armbian


shadowpho
 Share

0

Recommended Posts

https://justpaste.it/5jszu

 

I tried with I2C connected and disconnected between screen and tinkerboard.  No change. (See below, looks like i2c-3/3-0045/tinker_mcu_bl is missing ).   I checked around that area and tinker_mcu_bl is missing, but folder 3-0045 exists with lots of files in there. (bottom of the post)

 

From dmesg I also see that i2c had a failure (ret = -6). (see next paste)

 

Looking forward I see that -6 is no device found on i2c bus (assuming that's correct?). Does anyone know if brightness control works?

 

 

[    2.446829] tinker-mcu: tinker_mcu_probe: address = 0x45   
[    2.446843] tinker-mcu: send_cmds: 80  
[    2.493126] tinker-mcu: init_cmd_check: recv_cmds: 0xC3    
[    3.161121] tinker_mcu_screen_power_up 
[    3.161122] tinker-mcu: tinker_mcu_screen_power_up:   
[    3.161127] tinker-mcu: send_cmds: 8500     
[    4.545081] tinker-mcu: send_cmds: 8501     
[    4.569108] tinker-mcu: send_cmds: 8104     
[    4.572138] tinker-mcu: send_cmds: send command failed, ret = -6     
[    4.574293] tinker-mcu: tinker_mcu_set_bright: bright = 0xff 

 

shadowpho@tinkerboard:~$ sudo rpi-backlight -Btinker-board -p toggle    
Traceback (most recent call last):    
File "/usr/local/bin/rpi-backlight", line 10, in <module>  sys.exit(main())     
File "/usr/local/lib/python3.7/dist-packages/rpi_backlight/cli.py", line 103, in main   if backlight.power:  
File "/usr/local/lib/python3.7/dist-packages/rpi_backlight/__init__.py", line 213, in power     return bool(self._get_value("tinker_mcu_bl"))     
File "/usr/local/lib/python3.7/dist-packages/rpi_backlight/__init__.py", line 85, in _get_value raise e     
File "/usr/local/lib/python3.7/dist-packages/rpi_backlight/__init__.py", line 77, in _get_value return int((self._backlight_sysfs_path / name).read_text())    
File "/usr/lib/python3.7/pathlib.py", line 1199, in read_text with self.open(mode='r', encoding=encoding, errors=errors) as f: 
File "/usr/lib/python3.7/pathlib.py", line 1186, in open   opener=self._opener) 
File "/usr/lib/python3.7/pathlib.py", line 1039, in _opener   return self._accessor.open(self, flags, mode)   FileNotFoundError: [Errno 2] No such file or directory: '/sys/devices/platform/ff150000.i2c/i2c-3/3-0045/tinker_mcu_bl'   

 

Link to post
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

Sorry for post in old topic, but I can't change brightness via GUI on my ASUS tinker board (RK3288) with Ubuntu focal (21.05.8 + kernel 5.10.43-rockchip) and LXQt.
I tried to change brightness from terminal with: xbacklightxrandr and rpi-backlight - it did not help, but ddcutil (DDC/CI - Display Data Channel Command Interface):

// make sure, that feature 10 is brightness
$ sudo ddcutil capabilities | grep "Feature: 10"
  Feature: 10 (Brightness)
// get current brightness
$ ddcutil getvcp 10
VCP code 0x10 (Brightness                    ): current value =    60, max value =   100
// set current brightness
$ sudo ddcutil setvcp 10 40

 

Some more info about ddcutil can be found on Arch wiki: https://wiki.archlinux.org/title/backlight#External_monitors
 

I'm fine with changing brightness from terminal for now, but if you know better solution - post it here, please.

Link to post
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

0