X96 Max no wired network


Recommended Posts

Hello,

 

I use armbian on a mecool m8s pro+ but i want now to use a x96 max for usb 3.0 and 1000mb network.

I start armbian on a sd card, it's ok but i don't have wired network acces. I try with static and dhcp configuration but i can't ping on my network.

I don't understand why ?

My x96 max have an amlogic s905x2 with 4G of ram and 64G emmc. I use the file Armbian_20.10_Arm-64_buster_current_5.9.0.img and i've select meson-g12a-x96-max.dtb.

 

Thank you for your help

Link to post
Share on other sites
Armbian is a community driven open source project. Do you like to contribute your code?

I've got bad ip network when i was in dhcp

ip 169.254.139.154

submask 255.255.0.0

 

It's not good my submask is 255.255.255.0 and my ip should be 192.168.1.xxx

 

I think i would return the tv box.

Link to post
Share on other sites

Beware that there are different hardware versions of this same box. I myself have two X96 Max boxes, with two different hardware versions, both bought just days apart from each other. It has been a few weeks since I had the chance to play with them, but from what I recall, one of them worked OOTB with Armbian 20.10 5.9.0 and the expected dtb (x96max). The other one is instead more similar to the X96 Max+. It came with an 8822CS wifi chip (same as the Max+) instead of the AP6356SA that came on the first one. The "original" version of the X96 Max does work ethernet @ Gbit speed and WiFi OOTB with the 201014 image. The second one I do not recall now if I ended up managing to use either of the (onboard) network interfaces or if I simply plugged a USB wifi dongle at the time. I had but a couple hours at most with them. I plan to play again with them soon, I will let you know more details once I have the chance to check. Bottom line, first of all check what hardware you got inside your box!

Link to post
Share on other sites