KM8P was running old version of armbian but can't load the latest Armbian_20.10_Arm-64_buster_current_5.9.0


Peyton
 Share

0

Recommended Posts

Hi there,

I was a happy user of armbian balbe150's build and wanted to update to the latest one as i was on a very early kernel.

 

I tried to push it on my box freshly factored by default usb burning tool and android img from mecool. Install SD as usual with the settings according to the first post of balbe thread (it changed with the u boot) but after installing on emmc i'm stuck at the u boot and don't know why as it was working correctly on previous builds.

 

If i put SD back it boot right away on it. Guess it is a emmc boot number or something wrong like that.

 

If i do lsblk i can see emmc 0 (sd) and emmc 1 (real emmc)

 

Do you guys had the same prob ? i wish i had never wanted to upgrade and flash android back.

 

Ps : I don't have the previous img on my PC

Link to post
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

I renamed the uboot for S912 (as it is on KM8P) u-boot-s905x-s912.

 

and this file : meson-gxm-q201.dtb as i always used it before.


Of course it works on SD but i want to install it on EMMC so i used install-aml.sh.

Link to post
Share on other sites

I flashed back android and Armbian buster with Linux 5.7.2-arm-64 (old version which i found on internet) and it works on emmc.. It's a bit frustrating that the latest available isn't working anymore on tv boxes that was working before..


Can i manually update to 5.9 kernel ? What do i have to do ? I remember some swapping file on FAT partition. Do someone remember what to do ? Thanks.

Link to post
Share on other sites

Nevermind, except the u-boot which can't update, after an update and a reboot all goes on 5.90. I did not edit my previous reply just for information if someone got the same question. :)

Link to post
Share on other sites

 Share

0