Jump to content
  • 0

Orange Pi zero plus2 H3 problem with connecting GPIO UART to APM flight controller.


Josephjo
 Share

Question

Armbianmonitor:

Before this I used to connect my APM 2.8.4 Flight controller to a Raspberry PI on Ground, Pin 8 and Pin 10.

Today I tried to connect it to my orange pi zero plus2 H3. Pin 9, Pin 8 and Pin 10. On armbian-config toggle UART2.

 

When i tried to connect to it using cat /dev/ttyS2 nothing came out. Once a while sent out some gibberish.

 

I set the correct buadrate at 57600 and 91600 to no available.

But I know the settings are correct because when I connect using USB through /dev/ttyACM0 it works.

I tried ttyS1 and ttyS3 nothing came out of it.

 

On Raspberry I had done this many times just by turning on the Serial Connection using raspi-config.

 

Anyone have any solution for this?

Link to comment
Share on other sites

0 answers to this question

Recommended Posts

There have been no answers to this question yet

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...