Jump to content

Mov Z69 Amlogic s905x can't get Linux running ?.

Tanmay Saha

Recommended Posts



 everyone need a little bit of support if anyone can help me?


So a couple of weeks back i picked up a retro gaming box filled with emulators, roms etc. After a little digging to add emulators, mess with themes, change settings and stuff i find out the box it's self is just a mix of libreelec, emulationstation, kodi with a few modifications, skins added. So i decided to see if the box can run Linux (if it could i could easily get retropie for Linux running on it) which it can and after a little googling and watching a video by the MXQ Project to get Armbian (Lepotato) running on the box (using the tooth pick method) i followed the steps to get it running and tried each one of the dtb files included on in the OS copying it into the root of the SD card, changing the file each time to dtb.img etc. https://krogerfeedback.nl https://talktosonic.onl https://talktowendys.vip https://whataburgersurvey.onl


Now the problem is i tested every dtb file and not a single one will boot Linux primarily Ubuntu. I also tried without a dtb file and again it just boots into the libreelec OS which is installed internally on the on board memory. I downloaded libreelec and tried booting a fresh copy from an sd card and it booted fine without me adding a dtb file (one was already included). So i copied out the dtb file and tried running Ubuntu with that file and again nothing happens it boots straight into libreelec.





Link to comment
Share on other sites

Search Before Posting!

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Reply to this topic...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.


  • Create New...