1 1
perfstr

Autologin to Armbian console

Recommended Posts

Hello, I run my program system as a service in console mode, so no login is needed. The Linux system starts up almost quietly after changes in boot.scr. The only "small" thing that needs a solution is the login prompt. How can I prevent login prompt from appearing? I've tried some autologin options I found for different Linux systems, but they didn't work for me. Any suggestion?

Share this post


Link to post
Share on other sites

I found the solution - it should be similar to the change described in the link:

 

https://wiki.archlinux.org/index.php/Getty#Automatic_login_to_virtual_console

 

change /lib/systemd/system/getty@.service file, ExecStart string to contain

 

ExecStart=-/usr/bin/agetty --autologin username ...

 

After the change is applied, the console screen still shows some text, which needs to be disabled. Any idea?

Share this post


Link to post
Share on other sites

under armbian 5.35 Debian Jessie 3.4.113-sun8i I added the following file /lib/systemd/system/getty@tty1.service.d/20-autologin.conf with root privileges:

# /lib/systemd/system/getty@tty1.service.d/20-autologin.conf

[Service]
ExecStart=
ExecStart=-/sbin/agetty --autologin pi --noclear %I $TERM

If needed, change 'pi' with another username. Then reboot.

Share this post


Link to post
Share on other sites
Guest
This topic is now closed to further replies.
1 1