Jump to content
  • 0

5.15 broke zfs-dkms


eiglss
 Share

Question

Dear all;
I'm looking for some help with my Helios64 NAS, since I update kernel to 5.15, zfs-dkms won't work.
Which is normal, since the most recent version available for Helios64 of zfs-dkms is 2.0.3-1~bpo10+1 (tested on 1st April 2022), and this version is only compatible with kernel from 3.10 to 5.10.

Then the first solution that I thought was to downgrade to 5.10 through the armbian-config tool, however when I'm trying to install the linux-headears (through armbian-config) I'm having the herdears of 5.15 (same issue with apt install linux-headers-current-rockchip64) while zfs-dkms looking for 5.10.

Preparing to unpack .../zfs-dkms_2.0.3-1~bpo10+1_all.deb ...
Unpacking zfs-dkms (2.0.3-1~bpo10+1) ...
Setting up zfs-dkms (2.0.3-1~bpo10+1) ...
Loading new zfs-2.0.3 DKMS files...
It is likely that 5.10.63-rockchip64 belongs to a chroot's host
Building for 5.15.25-rockchip64
Building initial module for 5.15.25-rockchip64
configure: error: 
	*** None of the expected "capability" interfaces were detected.
	*** This may be because your kernel version is newer than what is
	*** supported, or you are using a patched custom kernel with
	*** incompatible modifications.
	***
	*** ZFS Version: zfs-2.0.3-1~bpo10+1
	*** Compatible Kernels: 3.10 - 5.10
	
Error! Bad return status for module build on kernel: 5.15.25-rockchip64 (aarch64)
Consult /var/lib/dkms/zfs/2.0.3/build/make.log for more information.

/var/lib/dkms/zfs/2.0.3/build/make.log:

DKMS make.log for zfs-2.0.3 for kernel 5.15.25-rockchip64 (aarch64)
Fri 01 Apr 2022 05:38:22 PM UTC
make: *** No targets specified and no makefile found.  Stop.

 

I try then to perform a fresh installation of the system by downloading Armbian_21.08.2_Helios64_buster_current_5.10.63, and then it goes worst since I can't download the header through armbian-config (nothing happen), and apt install linux-headers-current-rockchip64 keep installing the sources for 5.15 ('/usr/src/linux-headers-5.15.25-rockchip64').

So the problem how I see it is either to:
* Get the linux-headers of the previous kernel.
* obtaining a zfs-dkms version compatible with 5.15

 

Thank you in advance for your help.

 

PS: I am aware of the docker alternative, but I prefer to use zfs-dkms.

Edited by eiglss
spelling
Link to comment
Share on other sites

4 answers to this question

Recommended Posts

  • 0

If I am recalling correctly, it was non-trivial (and thus, took some time) to figure out some solution that worked, in order to make this 'easy' for end users.  It sounds like this broke now with kernel going up to 5.15.

 

If I am interpreting this search for zfs Issues on our Jira instance correctly, it looks like the developers are aware of the issue(?).

 

If you make any progress on figuring this out in the meantime, please do post back what you learned.

Link to comment
Share on other sites

Armbian is a community driven open source project. Do you like to contribute your code?

  • 0

Thank you TRS-80 for your answer, I took a look at the link:

On 4/1/2022 at 10:53 PM, TRS-80 said:

If I am interpreting this search for zfs Issues on our Jira instance correctly, it looks like the developers are aware of the issue(?).

And It seems indeed that they are aware, since there is this issue : "Add ZFS that supports kernel 5.15.y".

 

Thank you ebin-dev for your answer too, I tested your solution, and indeed it worked. However, it is not trivial since I had to download the header through your link, else I had the 5.15 header.
Moreover, even after a freeze through armbian-config: apt update && apt full-upgrade install 22.02 with 5.15. Then to prevent any upgrade with these commands and freeze at Armbian 21.08.2 Bullseye with Linux 5.10.43-rockchip64,  I had to comment the deb in this file /etc/apt/sources.list.d/armbian.list

 

Link to comment
Share on other sites

Join the conversation

You can post now and register later. If you have an account, sign in now to post with your account.
Note: Your post will require moderator approval before it will be visible.

Guest
Answer this question...

×   Pasted as rich text.   Restore formatting

  Only 75 emoji are allowed.

×   Your link has been automatically embedded.   Display as a link instead

×   Your previous content has been restored.   Clear editor

×   You cannot paste images directly. Upload or insert images from URL.

Loading...
 Share

×
×
  • Create New...